LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 06-06-2011, 04:06 PM   #1
dannin
LQ Newbie
 
Registered: May 2011
Posts: 11

Rep: Reputation: 0
Getting error: Failed to get size of gamma for output default


Hi everybody

I just installed debian on my desktop box but can't get Gnome to use the correct resolution. The monitor is an older Samsung LCD with an optimal resolution of 1280x1024. However, Gnome won't show any higher than 1152x864.

I googled the problem and found out that i should try 'xrandr' to list all avaliable resolutions, and if the desired resolution wasn't avaliable in the list, i should add it using "xrandr -addmode" and so on. But when i use 'xrandr' to show the available resolutions, and when i'm trying to add the missing one, it says "xrandr: Failed to get size of gamma for output default"

I have ofcourse tried to google this but haven't been able to find a solution :-(

I'm running debian 6.0.1a i386 and the graphicscard is onboard and the only screenoutput is VGA.
 
Old 06-06-2011, 07:02 PM   #2
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

It sounds like the problem is that your (older) monitor isn't providing the EDID information that xrandr needs to intelligently do its job.

The solution is to let xrandr take you as far as it can, then "second guess" the parts xrandr can't figure out for itself (by manually tuning your xorg.conf configuration).

There's lots of good info on the xrandr Wiki:

http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

'Hope that helps .. PSM
 
Old 06-07-2011, 01:44 PM   #3
dannin
LQ Newbie
 
Registered: May 2011
Posts: 11

Original Poster
Rep: Reputation: 0
But in debian 6.0 there IS no Xorg.conf so i can't manually add the resolution i need

I have read that i can just make an Xorg.conf and place it in /etc/X11/ but I tried that with no luck. I also tried dpkg-reconfigure xserver-xorg thinking it would make a Xorg.conf file so i had something to work with but that didn't help either.

I don't know how much is necessary to get the Xorg.conf to work, and the examples you can find on various sites are all different. Some have like 3-400+ lines of settings, others have 100-150..

Is there any way to get debian to make a Xorg.conf for me so I can just edit it? Like in the previous debian releases?



Quote:
Originally Posted by paulsm4 View Post
Hi -

It sounds like the problem is that your (older) monitor isn't providing the EDID information that xrandr needs to intelligently do its job.

The solution is to let xrandr take you as far as it can, then "second guess" the parts xrandr can't figure out for itself (by manually tuning your xorg.conf configuration).

There's lots of good info on the xrandr Wiki:

http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

'Hope that helps .. PSM
 
Old 06-07-2011, 10:05 PM   #4
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi, again -

Sorry you're still having problems:

1. The basic issue is that the auto-configuration tool you're using, xrandr, isn't giving you the resolution you need. This appears to be because it needs EDID information from the monitor, which the monitor isn't giving. A viable solution should be to augment the auto-configuration by tweaking the
configuration manually.

2. Debian definitely uses Xorg, and Xorg definitely uses Xorg.conf (if it exists).
You can create a new Xorg.conf with these commands:
Quote:
http://wiki.debian.org/Xorg

/etc/init.d/kdm stop
/etc/init.d/gdm stop
/etc/init.d/xdm stop
cd /etc/X11/
Xorg -configure
3. Reboot X windows at this point - it's entirely possible the newly generated configuration might be EXACTLY what you need, and you might be done

4. Otherwise, please:
a) tell us what graphics card you're using("lspci" is one way to find out)
b) tell us whether your system is loading an X driver for that card (you can look at "Xorg.0.log")
c) tell us what resolution it's defaulting to (again "Xorg.0.log" should tell you)

'Hope that helps .. PSM

PS:
This link might also help:
http://wiki.debian.org/DebianEeePC/HowTo/Configure#Xorg
 
Old 06-10-2011, 08:50 PM   #5
dannin
LQ Newbie
 
Registered: May 2011
Posts: 11

Original Poster
Rep: Reputation: 0
I tried to shutdown gdm (/etc/init.d gdm3 stop) and then run Xorg -configure. It gave me a xorg.conf, but it didn't work as you mentioned it could've.

I tried to change/add/remove some settings, and googled around for solutions still without luck. I managed to get the Gnome manager to stop showing the '1156x???' resolution. Now, however, it added '1366x768'.

I have _no_ idea why it did that.

Then I found a much simpler xorg.conf sample on google, and after adding the 1280x1024 modeline and the 1280x1024 mode i went to try it, and now it only shows 1 resolution - 1024x768?? That resolution isn't even in the xorg.config??

a) Matrox MGA G200e onboard VGA gfx
b) It seems like it does. in the xorg.conf that Xorg -configure generated, it also listed the graphicscard.
c) i think it's defaulting to 1024x768.

I uploaded my log and my xorg.conf - maybe you can see what i did wrong?

http://failed.dk/crap/Xorg.0.log
http://failed.dk/crap/xorg.conf

Notice how brilliantly my domain matches my situation :-)

Last edited by dannin; 06-11-2011 at 01:19 PM.
 
Old 06-14-2011, 12:31 PM   #6
dannin
LQ Newbie
 
Registered: May 2011
Posts: 11

Original Poster
Rep: Reputation: 0
Bump
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/sda: read failed after 0 of 4096 at 0: Input/output error Danesh Linux - Software 3 04-08-2008 06:31 AM
/dev/sda: read failed after 0 of 4096 at 0: Input/output error Danesh Linux - Newbie 1 04-03-2008 06:59 AM
RPM iinstallation [error: failed to stat /mnt/windows: Input/output error] Ameii83 Linux - Software 1 04-09-2007 07:05 AM
pppd[n]: tcflush failed: Input/output error musasabi Linux - Networking 0 01-02-2005 02:45 AM
unpacking of archive failed: cpio: read failed-input/output error rafc Linux - Newbie 0 04-21-2004 09:03 AM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration