-   Linux - Newbie (
-   -   getting back to GUI from command line (

lexx11 03-25-2006 02:10 AM

getting back to GUI from command line
What is the command to get back to KDE from bash?
I've been stumped on this for a while (first time playing around with CLI).


kevkim55 03-25-2006 02:22 AM

If you switched to the virtual console by pressing Alt+Ctrl+F<1-6> you should know how to get back to GUI - Alt+Ctrl+F7 !

lexx11 03-25-2006 02:28 AM

still having problems
I'm not in virtual console... I somehow changed it so that it boots up to CLI and I don't know how to enter GUI mode.

I typed "startx" but it says:

execute failed for /etc/X11/X (error 2)
giving up.
xinit: No such file or directory (error 2): unable to connect to xserver
xinit: No such process (error 3): Server error

Please help!


I read somewhere else to go to /etc/inittab to change id:3:initdefault to a "5" instead of "3". I tried switching to su, but I still get permission denied when I type /etc/inittab.

What should I do from here?



inam75 03-25-2006 02:46 AM

init 5 to switch to GUI
If you switched to the virtual console by pressing Alt+Ctrl+F<1-6> you should know how to get back to GUI - Alt+Ctrl+F7 !

Secondly, you can type run level command "init 5" to switch to GUI interface from CLI.
Just type
init 5
dont enclose it in double qoutes.

Lastly if u want to make it default (run GUI at startup) you can make changes in inittab (inittab cantains run level settings) file.
cd /etc
vi inittab
Find the line containing word 'default', set default to 5. Save the changes and exit from the vi editor.
next time when you restart your system, it will bootup in GUI mode.

lexx11 03-25-2006 02:50 AM

This isn't working at all. I did "vi inittab" like you said, and I figured out how to change the 3 to a 5, then save and exit.

I restart, and I am back in Bash. If I look at inittab, it says "id:5:initdefault", which is what I think I want. Why is it not booting up into GUI?

Also, typing "init 5" doesn't do anything.


bmarx 03-25-2006 01:08 PM

which distro are you using? i use slack, and runlevel 5 is configured to be the same as runlevel 3, which boots into text mode - although startx from the command line boots to my default window manager with no problem. And I point out that I have never tried booting to runlevel 5...

I boot to runlevel 4 to get to my login gui screen, but figuring out your inittab sounds like it would fix the problem...

johndoe0028 03-25-2006 04:20 PM

If you're trying startx, do you have a .xinitrc file in your home?

If not, make one and put this line in it:

exec startkde

Then, startx will start X, then KDE.

Hope this helps.


Oops, thanks

sumguy231 03-25-2006 04:43 PM

^Typos can cause problems, so it should be noted that the above should read '.xinitrc'.

All times are GMT -5. The time now is 07:00 AM.