LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-22-2017, 10:57 AM   #1
257shishir
LQ Newbie
 
Registered: Sep 2017
Posts: 1

Rep: Reputation: Disabled
getting an error while doing 'make depend' for ns2 installation in ubuntu12.04


getting an error while doing 'make depend' for ns2 installation in ubuntu12.04....
giving an error
make:**No rule to make target 'mac/macngenhanced.cc', needed by 'depend'. Stop
please help me.......
 
Old 09-23-2017, 06:00 PM   #2
Mike_Walsh
Member
 
Registered: Jul 2017
Location: King's Lynn, UK
Distribution: Nowt but Puppies....
Posts: 542

Rep: Reputation: 287Reputation: 287Reputation: 287
I wouldn't bother going any further with that. Ubuntu 12.04 LTS 'Precise Pangolin' hasn't been supported since it hit EOL ('end-of-life') in April. It's now dangerous to continue to use it.

You would do well to upgrade to a newer version of Ubuntu. 16.04 LTS 'Xenial Xerus' if your system will run it, otherwise 14.04 LTS 'Trusty Tahr' is still supported for another 18 months or so.....


Mike.
 
Old 10-07-2017, 08:45 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,430

Rep: Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623
Welcome to LQ.

No reason to use the 'make depend' command.
The required 'make depend' is done by the './install' command
.... in the top directory ns-allinone-2.xx/ !

It's purely a misunderstanding to run 'make depend' again after changes.


Latest instructions, CRCN example :
Code:
$ tar xvf ns-allinone-2.31.tar.gz
$ cd ns-allinone-2.31/
$ patch -p0 < crcn_ns231.patch
https://drive.google.com/file/d/0B7S...ew?usp=sharing
$ export CC=gcc34 CXX=g++34 && ./install
Note : CRCN can can be built only with the 32bit OS CentOS 6.9 - i386
http://ftp.funet.fi/pub/mirrors/cent...86-LiveDVD.iso


-

Last edited by knudfl; 10-07-2017 at 08:51 AM.
 
  


Reply

Tags
crcn, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
validation error in ns2.34 on ubuntu12.04--./validate is giving unexpected result banerjee Ubuntu 1 10-27-2014 03:14 PM
[SOLVED] make depend error in crcn installation fabe856 Linux - Newbie 17 06-24-2014 05:59 AM
Leach installation on ns2.35-- error after "make" command supu Linux - Newbie 2 03-27-2012 03:20 AM
Error in Make Depend while CVS install of WineX calmlikeabomb Mandriva 1 04-28-2004 05:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration