LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2010, 06:36 AM   #16
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472

Change
Code:
## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
to
Code:
## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted non-free
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted non-free
(Bolded to show the change)
Then do
Code:
sudo apt-get update && sudo apt-get install b43-fwcutter
Let us know if it works.
 
Old 04-16-2010, 06:42 AM   #17
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,620

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Quote:
Originally Posted by Bruno2010 View Post
user1@admin:~$ grub --version
The program 'grub' is currently not installed. You can install it by typing:
sudo apt-get install grub
grub: command not found
user1@admin:~$
Hi,

you probably have grub2 installed and that means that the setup is differrent than with grub. E. g., as you already noticed you do not have a menu.lst. Instead you have a grub.cfg. Manual configuration, however, is done by modifying /etc/default/grub. Change the DEFAULT value there, e.g.
Code:
#GRUB_DEFAULT=0 #first menu entry
GRUB_DEFAULT=2 #third menu entry
GRUB_HIDDEN_TIMEOUT=3
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
 
Old 04-16-2010, 01:35 PM   #18
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by XavierP View Post
Change
Code:
## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
to
Code:
## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted non-free
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted non-free
(Bolded to show the change)
Then do
Code:
sudo apt-get update && sudo apt-get install b43-fwcutter
Let us know if it works.
Ok, this is where my experience is limited. Are you asking that I find the file:

etc/apt/sources.list

and go in and add text to those files indicating what you said to change?

Or is all of this done at the terminal with commands...please advise.

Thanks for your help BTW.
 
Old 04-16-2010, 01:38 PM   #19
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by crts View Post
Hi,

you probably have grub2 installed and that means that the setup is differrent than with grub. E. g., as you already noticed you do not have a menu.lst. Instead you have a grub.cfg. Manual configuration, however, is done by modifying /etc/default/grub. Change the DEFAULT value there, e.g.
Code:
#GRUB_DEFAULT=0 #first menu entry
GRUB_DEFAULT=2 #third menu entry
GRUB_HIDDEN_TIMEOUT=3
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

This is incredibly confusing. Is all this stuff what I type in the terminal? Or can I somehow change it in a file.

Ill try and see what I can learn from the grub.cgf file.
 
Old 04-16-2010, 02:31 PM   #20
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,620

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Quote:
Originally Posted by Bruno2010 View Post
This is incredibly confusing. Is all this stuff what I type in the terminal?
No, you do not type this into the terminal. This are contents of the textfile /etc/default/grub. What you type into the terminal is
Code:
sudo gedit /etc/default/grub
Enter your password and you will be able to modify the textfile. A '#' marks a comment, that means the rest of the line will be ignored. Now change the 'DEFAULT=' setting as you like.
 
Old 04-16-2010, 02:51 PM   #21
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by crts View Post
No, you do not type this into the terminal. This are contents of the textfile /etc/default/grub. What you type into the terminal is
Code:
sudo gedit /etc/default/grub
Enter your password and you will be able to modify the textfile. A '#' marks a comment, that means the rest of the line will be ignored. Now change the 'DEFAULT=' setting as you like.
Linux is for the birds.

I found the grub.cfg file. I found the default "0" part. I changed it to 4, what I think is my windows spot. And it won't let me save it. It won't let me save another copy and overwrite.

So, Im not sure how Im supposed to "login" as the administrator or whatever.

EDIT: Ok, i went back in to the terminal, gave that command you mentioned. Was able to edit and save. Now its telling me "If you change this file, run "update-grub" to update /boot/grub/grub.cfg"

I went back to the terminal, and input "update-grub" for which it replied, "You must run this as root"

Last edited by Bruno2010; 04-16-2010 at 03:09 PM.
 
Old 04-16-2010, 03:45 PM   #22
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,620

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Quote:
Originally Posted by Bruno2010 View Post
Linux is for the birds.

I found the grub.cfg file. I found the default "0" part. I changed it to 4, what I think is my windows spot. And it won't let me save it. It won't let me save another copy and overwrite.

So, Im not sure how Im supposed to "login" as the administrator or whatever.

EDIT: Ok, i went back in to the terminal, gave that command you mentioned. Was able to edit and save. Now its telling me "If you change this file, run "update-grub" to update /boot/grub/grub.cfg"

I went back to the terminal, and input "update-grub" for which it replied, "You must run this as root"
Code:
sudo update-grub
will do the trick.

P.S.:
grub.cfg is an auto-generated file and is not supposed to be manually edited. However, if you do it anyway the changes are not permanent and will be lost the next time update-grub is run.

Last edited by crts; 04-16-2010 at 03:48 PM.
 
Old 04-16-2010, 06:18 PM   #23
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
Quote:
Originally Posted by Bruno2010 View Post
Ok, this is where my experience is limited. Are you asking that I find the file:

etc/apt/sources.list

and go in and add text to those files indicating what you said to change?

Or is all of this done at the terminal with commands...please advise.

Thanks for your help BTW.
Open a terminal and put in those commands. You can also enable the extra repositories by using your package manager.

So, to edit the file, open a terminal and do
Code:
sudo gedit /etc/apt/sources.list
Once we have your wireless card and grub issues sorted, I would strongly advise you bookmark and read the help pages at Ubuntu. They are well written pages and will walk you through most things.
 
Old 04-17-2010, 09:13 PM   #24
kwhit
LQ Newbie
 
Registered: Apr 2010
Location: a Speck on the map
Distribution: Fedora
Posts: 7

Rep: Reputation: 0
What distro of linux are you using??

Possibly look into using NDISWRAPPER.

NDISWRAPPER emulates windows drivers to work in linux
 
Old 04-17-2010, 10:57 PM   #25
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
The B43 drivers work excellently for me. Why use the extra layer if you don't need to? Ndiswrapper, like Wine, was always intended as a stop gap until more programs and drivers were produced that worked natively.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change grub boot order, all instructions say change default, but I don't see default mhg Linux - Newbie 5 11-09-2008 11:01 AM
grub not seeing grub-set-default change bic Linux - Software 4 02-15-2008 02:44 PM
Change Default Boot from GRUB lel800 Red Hat 14 08-25-2004 02:32 AM
How do you change the default Boot-up OS in Grub? buckwheat12 Fedora 3 05-08-2004 04:24 PM
how to change default os in Grub eye Linux - Software 3 05-16-2003 09:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration