LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-15-2010, 03:57 PM   #1
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Rep: Reputation: 15
Get wireless card working. How to change default in GRUB.


hello all, im new to linux and I can't figure out anything without asking questions.

So, #1: Ive installed linux with the latest ubuntu on a partition on my hard drive.

I have NO IDEA how to get the wireless card working. How do I do this?

02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

is my card.


#2 That GRUB interface starts up my comp. The default is Ubuntu followed by a couple more options followed by windows. Windows is the last option and i want it to be the first/default option. How do I do this?

You guys are gonna have to talk to me like im 6. I'm not familiar with any of the linux terminology. Ive attempted to read a bit, and am learning but still is greek.
 
Old 04-15-2010, 04:17 PM   #2
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,620

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Quote:
Originally Posted by Bruno2010 View Post
hello all, im new to linux and I can't figure out anything without asking questions.

So, #1: Ive installed linux with the latest ubuntu on a partition on my hard drive.

I have NO IDEA how to get the wireless card working. How do I do this?

02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

is my card.


#2 That GRUB interface starts up my comp. The default is Ubuntu followed by a couple more options followed by windows. Windows is the last option and i want it to be the first/default option. How do I do this?

You guys are gonna have to talk to me like im 6. I'm not familiar with any of the linux terminology. Ive attempted to read a bit, and am learning but still is greek.
Hi,

to get your wireless working you probably will have to install proprietary hardware drivers first. Go to System->Administration->Hardware Drivers. If it displays any drivers for your wireless, install them.
 
Old 04-15-2010, 04:41 PM   #3
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by crts View Post
Hi,

to get your wireless working you probably will have to install proprietary hardware drivers first. Go to System->Administration->Hardware Drivers. If it displays any drivers for your wireless, install them.
Your suggestion didn't work.

There are no divers listed. It says "There are no proprietary drivers in use on this system" at the top of the window.
 
Old 04-15-2010, 04:44 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
Open a terminal and type the following:
Code:
sudo apt-get install b43-fwcutter
Follow the prompts.
 
Old 04-15-2010, 07:05 PM   #5
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by XavierP View Post
Open a terminal and type the following:
Code:
sudo apt-get install b43-fwcutter
Follow the prompts.
Your suggestion didn't work.

When I typed in the command, here's what I got:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package b43-fwcutter
 
Old 04-15-2010, 07:37 PM   #6
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
What do you have in your sources.list? Could you post it here please, you may need to enable some extra repositories.
 
Old 04-15-2010, 07:48 PM   #7
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by XavierP View Post
What do you have in your sources.list? Could you post it here please, you may need to enable some extra repositories.
Is this what your talking about?

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

If not, what is the command for that or how do I find the sources?
 
Old 04-15-2010, 08:52 PM   #8
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
The command you need is
Code:
sudo cat /etc/apt/sources.list
Then copy/paste it here.

You will probably need to enable extra repositories. The instructions here will help: http://ubuntuguide.org/wiki/Ubuntu:K...a_Repositories
 
Old 04-15-2010, 09:10 PM   #9
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by XavierP View Post
The command you need is
Code:
sudo cat /etc/apt/sources.list
Then copy/paste it here.

You will probably need to enable extra repositories. The instructions here will help: http://ubuntuguide.org/wiki/Ubuntu:K...a_Repositories
Here's what I got...

#deb cdrom:[Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)]/ karmic main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://us.archive.ubuntu.com/ubuntu/ karmic main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic universe
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ karmic multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://us.archive.ubuntu.com/ubuntu/ karmic-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://us.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu karmic partner
# deb-src http://archive.canonical.com/ubuntu karmic partner

deb http://security.ubuntu.com/ubuntu karmic-security main restricted
deb-src http://security.ubuntu.com/ubuntu karmic-security main restricted
deb http://security.ubuntu.com/ubuntu karmic-security universe
deb-src http://security.ubuntu.com/ubuntu karmic-security universe
deb http://security.ubuntu.com/ubuntu karmic-security multiverse
deb-src http://security.ubuntu.com/ubuntu karmic-security multiverse
 
Old 04-15-2010, 09:32 PM   #10
gerardorn
LQ Newbie
 
Registered: Nov 2009
Location: México
Posts: 9

Rep: Reputation: 0
open and read the file /boot/grub/menu.lst
theres a line that says "default 0"
change it to match your windows line
so say u have:

ubuntu
another ubuntu
then a line that says Other OS
and the windows option here

then u should change the default to 3

remember u need root privileges
 
Old 04-15-2010, 09:46 PM   #11
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by gerardorn View Post
open and read the file /boot/grub/menu.lst
theres a line that says "default 0"
change it to match your windows line
so say u have:

ubuntu
another ubuntu
then a line that says Other OS
and the windows option here

then u should change the default to 3

remember u need root privileges
Your suggestion didn't work.

There is no menu.lst file in my grub folder. I navigated there using the "finder". All of the folders you listed were present. But as I said, there was no menu.lst file.
 
Old 04-15-2010, 09:48 PM   #12
gerardorn
LQ Newbie
 
Registered: Nov 2009
Location: México
Posts: 9

Rep: Reputation: 0
finder
what files do you have there?
 
Old 04-15-2010, 09:50 PM   #13
itsbrad212
Member
 
Registered: Nov 2009
Location: Chicago
Distribution: Arch and OpenBSD
Posts: 104

Rep: Reputation: 19
Code:
grub --version
 
Old 04-15-2010, 10:15 PM   #14
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by gerardorn View Post
finder
what files do you have there?
Theres a hundred of them. Is there a way to list them in the terminal? Then I can copy and paste them.
 
Old 04-15-2010, 10:21 PM   #15
Bruno2010
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by itsbrad212 View Post
Code:
grub --version

user1@admin:~$ grub --version
The program 'grub' is currently not installed. You can install it by typing:
sudo apt-get install grub
grub: command not found
user1@admin:~$
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change grub boot order, all instructions say change default, but I don't see default mhg Linux - Newbie 5 11-09-2008 11:01 AM
grub not seeing grub-set-default change bic Linux - Software 4 02-15-2008 02:44 PM
Change Default Boot from GRUB lel800 Red Hat 14 08-25-2004 02:32 AM
How do you change the default Boot-up OS in Grub? buckwheat12 Fedora 3 05-08-2004 04:24 PM
how to change default os in Grub eye Linux - Software 3 05-16-2003 09:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration