LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Gentoo sshd help (https://www.linuxquestions.org/questions/linux-newbie-8/gentoo-sshd-help-589764/)

mistert209 10-05-2007 05:18 PM

Gentoo sshd help
 
hello linux guru's

I need a little bit help with a problem i'm having And DON'T understand why and how to resolve it.

I installed gentoo 2007 6.*.22-r5 No problems there.
After installing gentoo i installed samba server for a home network.
Now i want to lose the monitor and login remotly via a windows computer for updating and managing the system. To do this i knew gentoo had sshd standart so I added this to auto start by doing

# rc-update add sshd default

after this i had to edit the config file in
/etc/ssh/sshd_config

and wrote the folowing lines:

Port 22
Protocol 2
ServerKeyBits 2048
SyslogFacility AUTH
LogLevel INFO
LoginGraceTime 60
PermitRootLogin no
RSAAuthentication no
PubkeyAuthentication yes
PasswordAuthentication no
PermitEmptyPasswords no
PAMAuthenticationViaKbdInt no
Compression yes
KeepAlive yes
ClientAliveInterval 30
ClientAliveCountMax 4

After this I restarted sshd and to be sure I rebooted my system. ssh is running.

THE PROBLEM: when I connect with a client "putty" it shows the login as: screen. I type in my username "NOT ROOT becouse that is disabled" and hit enter

after doing this I get the following error message:

DISCONNECTED: No Supported authentication methods available

How do I resolve this problem and is it possible to login to KDE like remotedesktop in windows with sshd

thank

bmarx 10-05-2007 08:28 PM

Try setting RSAAuthentication to yes, and make sure you have ssh_host_rsa_key in your /etc/ssh directory, or wherever sshd_config is located. Restart sshd. There should also be some messages in /var/log/messages that may help you troubleshoot.

To login to KDE as a remote desktop type session you will probably want to look into tightvnc, and piping the data through an ssh tunnel.

dxqcanada 10-06-2007 11:03 AM

You should first make sure password or keyboard-interactive authentication works first before attempting key-exchange.

With key-exchange your Client (PuTTY) must be configured for key-exchange authentication have the same keys as the Linux user (usually found in ~/.ssh).

PuTTY Public keys

mistert209 10-06-2007 03:15 PM

Thanks I'll try this and post if it works

mistert209 10-07-2007 02:34 PM

It works fine now, the problem was that i saved the key in the wrong folder.

thank you all for helping


All times are GMT -5. The time now is 10:07 AM.