-   Linux - Newbie (
-   -   Gentoo Lags when Transferring Files (

ImpactDNI 01-19-2005 10:54 AM

Gentoo Lags when Transferring Files
About a week ago I upgraded from 2.6.8 to 2.6.9 in Gentoo. I loved 2.6.8 and had no problems, but to use the new nvidia driver (6629) I had to upgrade the kernel as well. I didn't change much in the kernel, just changed from Architecture "Generic x86_64" to "Athlon64", and that was is. However as soon as I booted up with the new kernel I noticed some serious slowdowns. Whenever compiling or transferring files between drives or over the network, Gentoo showed some serious lag. It has problems keeping up with keyboard/mouse input whenever compiling or transferring files.

It never had these problems before, so I tried everything I could think of to remedy the situation. I tried reverting to the old "Generic x86_64" setting in the kernel, no dice. Thought it might be the new nvidia driver, reverted back to 6111 (worked fine before), with no success, and tried dropping back to 2.6.8. Nothing seems to have fixed the problem.

Since last week I have tried reinstalling Gentoo onto my system (thinking something might have just gone wrong in the installation), but can't seem to get it back to proper working order.

I also thought my hard drives could have possibly started going bad
original setup was:
hdb1 (1gb) as SWAP
hdb2 (159gb) as /shared
hdc1 (100mb) as /boot
hdc2 (80gb) as /
hdd1 (80gb) as /home

So I have tried installing to different drives, and tried using different combinations of partitions/mount points to see if there is any notable difference. All I have noticed is: with the latest install (hdd2 (80gb) as /) and the other two drives as just mounted extra space (/shared and /music), I can compile fine, and can transfer files to /home (on the same drive as /) without any lag and no problems. However, as soon as I start moving files to the other drives (hdb or hdc, no matter where they are mounted) I start getting lag again...

Does anyone know of any reason this would be happening? Did something involving extra mounted drives change in 2.6.9 or 2.6.10 (running 2.6.10 currently), or should I do some diagnostics on my other hard drives? If so, can anyone recommend any programs to test whats wrong?

__J 01-19-2005 12:25 PM

With the local transfers (between drives), did you make sure dma was on? (hdparm -d /dev/hda )

ImpactDNI 01-19-2005 02:10 PM

I did not check that... but would it make _that_ big of a difference?
Plus... would it change with a new kernel?

ImpactDNI 01-19-2005 02:36 PM

Why would it be telling me that hdparm -d1 /dev/hdb is invalid?
"HDIO_SET_DMA failed: Operation not permitted"

__J 01-19-2005 03:25 PM

when you compiled your kernel did you add support for your chipset in?

and yeah (at least in my experience) dma makes a significant difference in transfer speed

ImpactDNI 01-19-2005 03:33 PM

As far as I can tell its there...
Running an Asus K8V SE Deluxe (AMD64), which uses the nforce2 chipset
in the kernel I have Device Drivers > ATA > "AMD and nVidia IDE support" compiled in (non-module)... Unless I'm missing something _Very_ obivous...

ImpactDNI 01-19-2005 03:37 PM

I'm retarded... Its a via chipset... Added support in and DMA is on and happy... Time to see if thats the problem....

Would having a low read/write speed on the drive cause the whole machine to lag the cursor/keyboard?

hdparm -Tt /dev/hdc reported:
Originally (before support compiled) 3.5mbs
now: 46mps
hopefully that was the problem!

__J 01-19-2005 03:43 PM

yeah I've had that problem where I forgot to add the chipset in and during big transfers the entire machine goes into a crawl. Hopefully that will take care of it.

ImpactDNI 01-19-2005 03:46 PM

Very glad to hear that =P
Thanks a lot you guys!
Once again linuxquestions manages to solve a (seemingly) major problem in under a day! =P

All times are GMT -5. The time now is 11:54 AM.