-   Linux - Newbie (
-   -   Gentoo> determinig root device (

Ezzy 04-16-2005 08:03 AM

Gentoo> determinig root device

I am trying to use Gentoo Kernel-2.6.11-r3 but so far I am not able to boot... I have followed the guide from the Gentoo install CD.

I used genkernel to compile the kernel. Since the I was not able to configure the DNS correctly a download to install coldplug and hotplug was not executed. So these 2 are not installed. Since I'm not fully sure if this is relevant I'm mentioning this.

I have used grub to install a dualboot (Linux - WIN XP) system. My SATA disks partitioning looks like this;
HD0 (160Gb) [windows disk]
/dev/sda1 ntfs [10Gb]
/dev/sda2 w95 [150GB]
/dev/sda5 ntfs [150GB]

HD1 (74GB) [linux disk]
/dev/sdb1 ext3 [32M]
/dev/sdb2 swap [512M]
/dev/sdb3 ext3 [rest]

My grub.conf file looks like this;
default 0
timeout 30

title=Gentoo Linux 2.6.11-r3
root (hd1,0)
kernel /kernel-2.6.11-gentoo-r3 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3
initrd /initrd-2.6.11-gentoo-r3

title=Windows XP
root (hd0,0)
chainloader +1

When I reboot my system from disk I get nicely the Grub menu and can select the OS without problem. Win XP works fine. But Gentoo stops after initial boot with following error; "/dev/sdb3 is not a a valid root device" It than asks for new root device or shell????

a) What did I do wrong here?
b) What do I need to do to make it work?

I also would like to understand better the options "root=" and "real_root=" in the kernel command in grub. I just follwed the guide from the CD as explained.

Thx for any advise!

masonm 04-16-2005 09:45 AM

Shouldn't real_root=hdb1?

atom 04-16-2005 10:46 AM

This is really basic :D

You say you have SATA harddrives?

do a make menuconfig and compile INTO the kernel (not as modules):

Device Drivers -> SCSI device support ->

mark everything you see *
proceed to the SCSI lowlevel drivers ->
mark everything that has SATA in it's name with *
If you are lucky, it will support everything you have, and will at least let you do further study on your own system and not the livecd one.

I realise this is like killing a fly with a bazooka but in the end, the fly is still dead :D

Ezzy 04-16-2005 01:13 PM

again a step further... pfff
Thx for help but I have again a problem.... Gentoo boots but stops at a certain point saying;
SIOCSIFADDR: no such device
eth0: unknown interface: no such device
SIOCSIFBRDADDR:no such device
eth0: unknown interface: no such device
SIOCSIIFNETMASK: no such device

* error : Problem starting needed services
* "netmount" was not started.
*Starting local....

tux_bl login:

Than the keyboard doesn't work so I can't enter anything. I probably need to go back to setup the keyboard differently..... Pfff.. I will not give up!

Please advise again? (THE BIGGEST NEWBIE)


atom 04-16-2005 01:18 PM

dunno, that might be under input devices or usb support... It's definitely the kernel. If you can't enter anything, but local (and login) start, it's the kernel..

About the netmount... You need to tell us more about your hardware. Not just what but the manufacturer and model. The faster you report all that, the faster we can help you compile into your kernel whatever you need.

Oh, and btw, i hope you are using gentoo-sources and not vanilla-sources.

Ezzy 04-16-2005 02:46 PM


I have re-compiled the kernel again. I'm getting crazy; now the screen turns into power save after boot.... Probably a problem with the grub video settings? Or power-saving settings?

As requested my hardware (Dell Dimension 5000, P4, 3.4GHz) configuration;
CPU= x86 Family 15 Model 3 Stepping 4 GeniuneIntel 3391 Mhz

Keyboard --> USB-HID (Italian, 101 keys)
Mouse --> Logitech Optical USB mouse
Soundcard --> Sound Blaster Live! 24-bit (creative)
Video adapter --> Radeon X300 series, 128Mb (1280x1024x75hz, 32bit)
Network card --> Broadcom 440x 10/100 integrated controller (adapter type 802.3)
Screen connected via DVI to video adapter.

I'm using indeed gentoo-sources from Gentoo install CD.

Please advise on kernel compiler settings? I'm burning hours behind the thing....

Thx in advance:confused:

Ezzy 04-16-2005 03:50 PM

borring story...
Black screen problem solved. I have removed the DVI cable between screen and pc; used a normal vga-cable instead and it works again.

Linux boots completely and asks for "tux_bl login:" but I'm not able to respond since my keyboard is not working...

Still kernel problem around input devices or usb support as suggested I guess?

Please advise?

comprookie2000 04-16-2005 04:48 PM

Need to get hotplug and coldplug for the keyboard.First get your network up.Use modprobe to load the driver for your card.Make sure you put a "m" for your network device then modprobe it to load it.Then follow the guide and start it with /etc/init.d/net.eth0 start or restart(change eth0 to whatever) then emerge sync and emerge hotplug coldplug rc-update add them to the default runlevel(again read the guide I have to go out and I'm doing this fast)reboot.I'll be back soon,good luck
also check this out;

Ezzy 04-16-2005 06:33 PM

Problem solved!
Great after re-compiling (enabling the right USB options) my kernel; it finaly works! :D Gentoo boots completely and I can use my keyboard. I just updated the system which took some time, but it is running fine now.

Next step, 2morrow, installing KDE. :study:

Thx for all the help so far!

atom 04-17-2005 11:51 AM

Happy for you man!

Sorry that I haven't been around to help you, I fixed a friend's computer today (windows fans, read and learn: he had around 400 adaware items and 132 virii items on his machine... that's what explorer's C:\documents and settings\username\local settings\temporary internet files\content.ie5 does to you!). I cleaned it (took 6 hours!), but he still doesn't have the context menu in windows explorer, he's gonna have to do a repair install. (couldn't format, his dad's got some sensitive data on it).

Anyway, glad you made it!

Ezzy 04-17-2005 12:34 PM

No worries you put me on the right trial. Any suggestion for this one?

Thx in advance!

All times are GMT -5. The time now is 12:59 PM.