LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-15-2004, 11:27 PM   #1
geogeer
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Unhappy GCC compiler issues redhat 7.3


Hey all,
I'm a super duper newbie at this so be kind...
I've installed RedHat 7.3 and I'm trying to install a couple other programs. I get to the configure part and it tells me that I don't have a compiler. So I'm hunting for the GCC compiler. I've looked on the RedHat RPM CD and found the GCC source RPM, but it isn't letting me install it (rpm -ivh gcc-2.96-110.src.rpm). I get an error about cannot create %sourcedir /usr/src/redhat/SOURCES. I am logged into root. Is there some other way to install a source rpm? Any other easier ways of getting GCC installed on my system?

Thanks!!!
 
Old 04-16-2004, 12:01 AM   #2
Mr.Bill.Gates
Member
 
Registered: Apr 2004
Location: Moscow, Russia
Distribution: Debian
Posts: 55

Rep: Reputation: 15
First install the GCC itself. The right file is gcc-2.96-110.i386.rpm

If you can't find it then download from here:

ftp://fr.rpmfind.net/linux/redhat/7....6-110.i386.rpm
 
Old 04-16-2004, 12:14 AM   #3
geogeer
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks! Now I'm getting some dependency issues...
got any good spots to find these?

error: failed dependencies:
binutils >= 2.11.93.0.2-6 is needed by gcc-2.96-110
cpp = 2.96-110 is needed by gcc-2.96-110
glibc-devel is needed by gcc-2.96-110
 
Old 04-16-2004, 12:25 AM   #4
Mr.Bill.Gates
Member
 
Registered: Apr 2004
Location: Moscow, Russia
Distribution: Debian
Posts: 55

Rep: Reputation: 15
Hmm... All these RPMs should be on your CD. But check this link

http://rpmfind.net/linux/RPM/redhat/...-110.i386.html

there's a "requires" section with links to all dependencies.
 
Old 04-16-2004, 07:38 PM   #5
geogeer
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks again for all the help. I think I'm getting it now.

I just have one little snag left to figure out.
Apparently I have a more recent version of cpp installed than what gcc is asking for and it doesn't seem to realise this. When I try to install GCC it says that cpp-2.96-110 is required. So I grabbed the rpm for cpp-2.96-110 and tried to install it, but I get errors about conflicts:

eg.
file /usr/share/info/cpp.info-1.gz from install of cpp-2.96-110 conflicts with file from package cpp-2.96-113

So I grabbed a copy of cpp-2.96-113 and it says it's already installed. OK, makes sense.

So how to I get GCC to know this? Can I uninstall the newer version of cpp and then install the older one that GCC wants? How?

Thanks!
 
Old 04-16-2004, 11:09 PM   #6
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
rpm -ivh --nodeps --force or

use 'man rpm'

to read how to use rpm to install an --oldpackage
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install gcc and c compiler into RedHat Linux spykid Linux - Newbie 4 10-25-2006 05:35 AM
GCC Compiler rr_rr_29 Linux - Software 2 10-17-2005 04:14 AM
Redhat 9 GCC compiler HELP! (n00b here) Jaykay3k Linux - General 11 02-23-2005 02:51 PM
Redhat 9 GCC compiler HELP! (n00b here) Jaykay3k Linux - Software 5 02-21-2005 12:59 PM
gcc compiler canyon289 Linux - Software 3 10-23-2004 10:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration