-   Linux - Newbie (
-   -   Game Editor with WINE couple issues. (with /lib in linux, and window size in wine) (

Hevithan 05-23-2011 06:10 AM

Game Editor with WINE couple issues. (with /lib in linux, and window size in wine)
I am running Game Editor (or trying to) ... and I have a couple different problems:

1) When I run the linux binary from terminal it says:


gameEditorLinux: /usr/lib/ version `GLIBCXX_3.4.11' not found (required by /home/hevithan/GameEditor/gameEditorLinux)
I searched google, and found that sometimes lib files will get into usr/local/lib instead of just usr/lib and when a program calls on it from /lib it doesn't realize it can be in local. I saw a recommendation to type:


$echo ld_library_path
and the return I get is blank.

The problem being I don't know where to go from here.

And it leads us to the next problem:

2) Since I don't know what comes next with the linux version, I tried to run the .EXE through wine. Wine doesn't seem to like it when I run anything fullscreen. Yet the .exe is defaulted at full. Checked around a little on another forum, and found someone with a similar problem, they said they solved it by Right click>Properties>Size ... but I don't have the size option. Would I find that in the WINE .config or could I issue a command in the terminal like:


$ ./gameEditor.exe -w 640x480
Or some other solution?

business_kid 05-23-2011 01:52 PM

locate The usual format is symlinks and one lib --> locate --> locate

Put in an appropriate symlink in /usr/lib. Try this exact line

readelf -V /usr/lib/ |egrep 'GLIBCXX_3.4.11'
If 3.4.11 doesn't show, you might have the wrong version. Plenty of fun to be had with readelf, and grep and they each have good man pages.

All times are GMT -5. The time now is 11:57 PM.