-   Linux - Newbie (
-   -   GAIM - "SSL support needed" [Slack] (

NomDeGuerre 03-10-2004 08:41 AM

GAIM - "SSL support needed" [Slack]
I'm using Slackware 9.1 and installed GAIM 0.7 which apparently won't work on Slack unless you do some extra stuff. I found an article at which said what to do.


ln -s /usr/lib/mozilla-1.4/ /lib/
ln -s /usr/lib/mozilla-1.4/ /lib/
ln -s /usr/lib/mozilla-1.4/ /lib/
ln -s /usr/lib/mozilla-1.4/ /lib/
ln -s /usr/lib/mozilla-1.4/ /lib/
ln -s /usr/lib/mozilla-1.4/ /lib/
ln -s /usr/lib/mozilla-1.4/ /lib/

Now, the problem is that I got rid of Mozilla since I'm using Firefox and now I can't log on to MSN 'cause it says something about SSL-library needed.
Is there an easy way to fix this? I was thinking that I'd uninstall GAIM and install a package which has the library-thingies that I need. I don't remember where I saw it but I'm sure I can find it again.
I can't find GAIM (which is installed in /home/MYUSERNAME/gaim-0.75) in the list of packages to remove with pkgtool.

rootyard 03-10-2004 09:56 AM

Have you tried installing openssl?

NomDeGuerre 03-10-2004 12:06 PM

I haven't. But since I've changed the things I've changed wouldn't it be easier just to uninstall and reinstall?

rootyard 03-10-2004 12:12 PM

You can do that but eventually you'll need to install openssl by the looks of your error message.

NomDeGuerre 03-10-2004 01:25 PM

I'll give it a try then.

NomDeGuerre 03-10-2004 02:41 PM

I installed OpenSSL and did this:


bash-2.05b# ln -s /lib/ /usr/lib/mozilla-1.4/
bash-2.05b# ln -s /lib/ /usr/lib/mozilla-1.4/
bash-2.05b# ln -s /lib/ /usr/lib/mozilla-1.4/
bash-2.05b# ln -s /lib/ /usr/lib/mozilla-1.4/
bash-2.05b# ln -s /lib/ /usr/lib/mozilla-1.4/
bash-2.05b# ln -s /lib/ /usr/lib/mozilla-1.4/
bash-2.05b# ln -s /lib/ /usr/lib/mozilla-1.4/

but it still won't connect.

If someone could just tell me how to uninstall GAIM I think I'd be able to fix the rest myself :)

NomDeGuerre 03-11-2004 05:58 AM


samsbox 03-11-2004 06:19 AM

Yes, I have the same problem.

The only articles I could come across on this subject were relating to SLL with Mozilla :(

NomDeGuerre 03-11-2004 11:02 AM

Well keep an eye on this thread and sooner or later someone might give the answer.

NomDeGuerre 03-11-2004 11:52 AM

I tried "make uninstall" and it was doing some stuff for a long time. But the GAIM-folder is still there and it still has files in it. I tried "rm -rf /gaim-0.75" and that didn't work either.
Surely someone must know how to do this?

Phorem 03-12-2004 01:03 PM

You have to add this path to /etc/ld.conf (that might not be the exact file...i'm at work but it's close....might be If you open that file, you should see a list of the lib's on your computer).


Or where ever that folder is on your computer (could be just "mozilla" without the 1.4 as well....just saw slack 9.1 in the user's mozilla-1.4).

Then do "ldconfig" at a command line.

Then when you compile GAIM, you should see at the very end of ./configure that it has found ssl in the mozilla directory.

Always worked for me.
Cheers! :-)

Edit** : As for uninstalling gaim, go to the folder you compiled the software in and do a "make uninstall" or if it's a rpm, try "rpm -e gaim". As for that annoying folder, just move it to a useless directory for now and delete it later or in the X console delete it.

All times are GMT -5. The time now is 02:31 PM.