LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   GAIM missing file depencies (https://www.linuxquestions.org/questions/linux-newbie-8/gaim-missing-file-depencies-84325/)

Brother Michael 08-21-2003 06:34 PM

GAIM missing file depencies
 
Alright this one is for anyone who has used GAIM with Redhat and on a KDE desktop.

When I try to install GAIM, I get an error with KDE saying that it is missing File Dependencies.

Alright fine. But where do I go to get the Files it needs, where do I install them to?

Thanks,
Mike

BTW: if you think you can help but need more info, I'll post it. I would do it now, but I am not in Linux right now.

martinman 08-21-2003 06:42 PM

errr...could you specify what packages? lol

in the future, a tool called apt-get can be used to download and install programs and ALL required depency packages automatically.

http://apt.freshrpms.net

Brother Michael 08-21-2003 09:50 PM

Which one do I download? the binaries or the regular .RPM?

Mike

martinman 08-21-2003 10:35 PM

shouldn't matter.

Brother Michael 08-21-2003 11:09 PM

didnt work.

another webpage opened, and it said i was missing a realplayer file.

umm...interesting.

slackmagic 08-21-2003 11:21 PM

hi Brother Michael,

welcome to LQ.org first of all.

Which GAIM are you trying to install on which system (6.1 or 7.3RH)?

If you're trying to install GAIM v 0.67, you more likely will need the
libgtkspell rpm (and maybe some others too) which is probably not installed on your system

In order to get that, you should simply go to http://www.freshrpms.net/ and choose the distro you are running (Valhalla for RH 7.3) and it will give you a list of rpms it has available for you on the left coloum of that website.

As my martinman has already suggested, you should at least tell us which dependencies it is missing. Simply copy the text from your terminal and paste it here and we can give you the links of where you can get those missing deps.

apt-get should work also, because I remember that it worked for me when I ran RH 7.3.

Let me know if I can be of any further assistance :)

Brother Michael 08-23-2003 05:22 PM

First off thank you all for your help! Secondly, I am running Redhat 7.3.

This is my error:

Found 0 source and 1 binary packages
Dependency Problem:
libc.so.6(GLIBC_2.3) is needed by gaim-0.67-1
libgcc_s.so.1 is needed by gaim-0.67-1
libgtkspell.so.0 is needed by gaim-0.67-1
libperl.so is needed by gaim-0.67-1
libstdc++.so.5 is needed by gaim-0.67-1

When I download from http://ftp.freshrpms.net/pub/freshrp...rh73.2.src.rpm :
Plugger: No approperiate application for type audio/x-pn-realadio-plugin found!

acid_kewpie 08-23-2003 06:11 PM

basically you're distro is too old.... well, not really but that's why you have those messages, either 1) upgrade glibc and the other packages from rpmfind.net or similar, 2) compile gaim from source, which then won't have these problems or 3) get a newer distro (overkill, but always a possibility for newbies)

Brother Michael 08-24-2003 11:22 AM

I have Redhat 9 BUT it wont install. Infact it wont even work as a boot disc. Very intersting. I will do a search on how to get it to work. Thanks

Mike

mhearn 08-24-2003 11:45 AM

Don't upgrade your glibc. Basically, recompile from the source or find an RPM built for your exact version of your distro.

The best solution is to figure out why RH9 won't install for you of course, otherwise you'll rapidly get left behind......

Brother Michael 08-24-2003 11:56 AM

The computer deosnt even recognize the Rehat 9 Cd as an Install CD. Am I doing something wrong?

Mike

mhearn 08-24-2003 12:04 PM

Yup :) Dunno what though. If you put CD 1 in the drive and reboot, it should do *something*.

If it doesn't you may have to change a BIOS setting to allow you to boot from the CD

Brother Michael 08-24-2003 12:25 PM

nah, the bios are correct, because I got Redhat 7.3 to work.

umm...

slackmagic 08-24-2003 01:35 PM

just wondering..how did you burn the RH 9.0 CDs ?

:D

Brother Michael 08-24-2003 04:53 PM

Using Windows XP I copied the files onto the CD's...think that is what is the problem? I mean when I open mount the cd-rom in linux i see the files.


All times are GMT -5. The time now is 01:13 PM.