-   Linux - Newbie (
-   -   FTP server install in Fedora Core 4 (

rafiqul 12-04-2005 01:15 AM

FTP server install in Fedora Core 4
Recently I installed FC4 in two computers, one with full installation that includes everything, and other only basics due to space problem. I was able to install my FTP server at my first computer, however I am unable to install at my second one ( I was getting some error saying - unable to create some files in /usr/src/ .I downloaded the FTP rpm package, but cannot install the rpm package. I used the command "rpm -i *.rpm"

I am however trying to install the FC3 compatible FTP rpm package, I could not find any FTP rpm for FC4. I am not sure if that is the reason why I am not able to install. If so can anybody tell me where to get the right FTP rpm for FC4 ?

There is no rpmbuild found on my second FC4 installed computer, however it is present in my first one (where I installed the full version of FC4)

WhatsHisName 12-04-2005 01:38 AM

yum install vsftpd

rafiqul 12-04-2005 02:57 AM

I just tried with yum, looks like it can install any package available at its repository. Thanks - it was a great help.

rafiqul 12-04-2005 03:20 AM

I got ftp working on both of my computer.However, telnet does not seem to working. I installed telnet-server.i386 on my second computer, looks like it installed, but not running (ps -ef | grep telnet). Also at my first computer (where I installed FC4 full) - when I try to install using yum (yum install telnet-server.i386) - it says as follows:
"parsing package install arguments
Nothing to do"
- also telnet does not seem to running at this computer too.

Can you please help ?

WhatsHisName 12-04-2005 11:01 AM

On the first system, try searching for installed and available rpms like this:

yum list installed telnet*
yum list available telnet*

Both telnet-0.17-35.i386.rpm and telnet-server-0.17-35.i386.rpm are available in the original FC4 distribution and have not been updated.

telnet is a xinetd-based service that is disabled by default. Edit /etc/xinetd.d/telnet and change the line “disable = yes” to “disable = no”. Actually, I think you can just comment out the “disable = yes” line, but I usually change yes to no. Habit. You may need to restart xinetd to start telnet.

rafiqul 12-06-2005 09:30 PM

I found Installed Packages
telnet.i386 1:0.17-35 installed
telnet-server.i386 1:0.17-35 installed

After I issued command "yum list installed telnet"

And started xinetd, after editing /etc/xinetd.d/telnet "disable = no", and now its working.

Thanks so much for your help.

All times are GMT -5. The time now is 07:48 PM.