LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   FTP Server configuration (https://www.linuxquestions.org/questions/linux-newbie-8/ftp-server-configuration-66570/)

mauritian 06-19-2003 06:24 AM

FTP Server configuration
 
Hi,

i want to setup an FTP server where machines running window platform can access the ftp server.

I have installed RH7.3 with wu-ftp and anonftp package.

I'm using cuteFTP on the client to try to access the FTP server but the connection fails ..

Could any one help me out?

I'm sure I messed up in the configuration.Thx

trickykid 06-19-2003 09:59 AM

Error messages would help us determine what the problem might be?

Also, how are you trying to connect, thru IP or by host name? Are you trying to connect on internal LAN or from outside network?
Can your windows machines ping this FTP server?
Is wu_ftp running?
Do you have a firewall setup?

mauritian 06-23-2003 12:35 AM

Hi

I'm trying to connect using IP. The Win machine can ping the FTP server and I'm trying to connect on an internal LAN.

There is no firewall. I'm using CUteFTP to connect and I get the following error:
'Can't connect to remote server. Socket error = #10054.'

How do I know if wu_ftp is running?I've run the command:

/sbin/service xinetd status

and I got xinetd is running so I think that wu_ftp is running.

MasterC 06-23-2003 01:15 AM

Run:
ps aux | grep ftp

And post the outcome.

Also, look at the server side log files (/var/log) to see if you can find an error there.

Cool

mauritian 06-24-2003 02:08 AM

outcome
 
The outcome is :

root 1682 0.0 0.9 1700 608 pts/0 11:06 grep ftp

Looking_Lost 06-24-2003 02:34 AM

Doesn't look like it's on:

Assuming it's the same as later version of Red Hat:

chkconfig --list

will show what services handled by xine are installed and turned on
or not.

or netstat -a look for port 21

Check for file

/etc/xinetd.d/wu-ftpd

and change to disable=no if it isn't already

restart xinetd

/etc/init.d/xinetd restart

Might be better offusing VSFTP if it's installed but personal choice and all that.

mauritian 06-24-2003 03:18 AM

the xinetd status is running and when using netstat, it shos ftp is listenning on port 21.

I can ftp on the same local machine(ftp server itself) that is using : ftp localhost.

However when accessing the ftp server from a window based client machine on the LAN, I get the following message

ftp: connect : Unknown error number

twantrd 06-24-2003 03:45 AM

You say you have no firewall...so you mean no ipchains or no iptables are loaded right? to check:

ipchains -L or
iptables -L

and you'll see the rules. Just to check, turn it off by:

lokkit (and select No firewall)

then try connecting to your linux machine locally. Everything looks good at what you've done so far. I have redhat 7.3 and I use wu-ftpd also.

-twantrd

mauritian 06-24-2003 06:04 AM

THKX twantrd

It worked great!!

One little Question :I'm using IP address to access the FTP server. What's the next step to use a domain name(e.g ftp:// myftpserver)

MasterC 06-24-2003 06:06 AM

www.noip.com www.dyndns.org www.godaddy.com www.zoneedit.com

Just registrar, from there it's all done at there end, not yours. If you have a dynamic IP look at the first 2 links first.

Cool

mauritian 06-25-2003 11:57 PM

THKX

ALL UP and RUNNING!


All times are GMT -5. The time now is 01:43 PM.