LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-15-2015, 08:18 AM   #1
callis07
LQ Newbie
 
Registered: Jul 2014
Posts: 15

Rep: Reputation: Disabled
FTP issue from one server to anothe server


when i try to ftp from server to another server I am getting error below

bash-3.2$ ftp 172.25.27.120
Connected to 172.25.27.120.
220 Service ready for new user.
Name (172.25.27.120:ccnusr): crsftp
331 User name okay, need password for crsftp.
Password:
230 User logged in, proceed.
Remote system type is UNIX.
ftp> cd /tmp
250 Directory changed to /tmp
ftp>
ftp> mput /tmp/tst.air
mput /tmp/tst.air? y
200 Command PORT okay.
550 /tmp/tst.air: Permission denied.
ftp>
ftp>

Please let me know if anyone has faced the simialar issue.

I have checked the vsftpd.conf file and seems everything is fine

anonymous_enable=YES
local_enable=YES
write_enable=YES
#anon_upload_enable=YES
#anon_mkdir_write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
#chown_uploads=YES
# The name of log file when xferlog_enable=YES and xferlog_std_format=YES
# NO writes to vsftpd_log_file, YES to xferlog_file
xferlog_std_format=YES
#async_abor_enable=YES
#ascii_upload_enable=YES
#ascii_download_enable=YES
#deny_email_enable=YES
# directory. If chroot_local_user is YES, then this list becomes a list of
#chroot_local_user=YES
#chroot_list_enable=YES
#ls_recurse_enable=YES
listen=YES
#listen_ipv6=YES
userlist_enable=YES
tcp_wrappers=YES
 
Old 04-15-2015, 08:50 AM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Appears to be permission issue. Did you check the permission on the destination where you are trying to do mput. Was it working before or this is a new setup.

You used the command: cd /tmp which will change your FTP directory not your local directory. So if you are trying to do mput from local directory you should use: lcd /tmp instead.

Quite possible that user account is not allowed to write to /tmp (since you have changed it to /tmp using cd /tmp) via FTP.

You did not mention which flavour of Linux you are using?
 
Old 04-16-2015, 08:05 AM   #3
callis07
LQ Newbie
 
Registered: Jul 2014
Posts: 15

Original Poster
Rep: Reputation: Disabled
OS version : Red Hat Linux 6.4

My doubt is will there be any firewall between two nodes. since to able to send files to the required directories from other Solaris machine I am working.
 
Old 04-16-2015, 08:18 AM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Firewall can be there but it will not just affect the write permission. You won't be able to access the service at all if firewall is blocking a particular port.

Are you trying to say you are not able to enter the passive mode? Did you check if port 20 is open for FTP passive connection?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi, I have ftp server issue rajini23 Linux - Security 3 08-03-2012 07:43 AM
FTP server issue DD554 Linux - Networking 1 06-02-2010 07:45 PM
How to monitor web server, FTP server, Mail server and database server vodka33us Programming 1 06-16-2008 05:20 AM
ftp server suse 9.3 issue svar SUSE / openSUSE 4 12-04-2005 04:14 PM
ftp server issue Kumado Linux - Networking 4 09-16-2005 12:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration