LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-03-2014, 01:50 PM   #1
gabotron2000
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Rep: Reputation: Disabled
ftp: connect: Connection refused


Trying to connect to an ftp server outside of our network. I hopped on a Windows box on a different sub-domain and an ftp transfer worked fine. On this Linux box, any command (ls, send, etc..) once authenticated, returns the following.

Last edited by gabotron2000; 04-08-2014 at 03:40 PM.
 
Old 04-03-2014, 01:56 PM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,713

Rep: Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279
Try switching to passive mode as the first command (or use "ftp -p servername").

You are likely behind a firewall/NAT that is causing the data channel to be blocked. The Windows system may be using passive mode by default (assuming it is behind the same firewall/NAT).
 
Old 04-03-2014, 02:09 PM   #3
gabotron2000
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
Tried passive mode, still not working though

Last edited by gabotron2000; 04-08-2014 at 03:39 PM.
 
Old 04-03-2014, 11:22 PM   #4
mddnix
Member
 
Registered: Mar 2013
Distribution: Redhat, Ubuntu
Posts: 525

Rep: Reputation: 141Reputation: 141
Have you tried
Code:
# modprobe ip_conntrack_ftp
 
Old 04-04-2014, 11:55 AM   #5
gabotron2000
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
So it was an issue with passive mode. In IE, it worked unless you specified passive. I had tried it before after toggling passive mode and it didn't work. Networking says they didn't make any changes though I'm kinda suspicious. But now it works!

I also did add modprobe ip_conntrack_ftp.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i am getting problem to connect ftp.connection refused is showing san_singh97 Linux - Newbie 1 08-01-2008 02:20 AM
ftp:connect:connection refused shihuien Linux - Server 2 11-21-2007 07:33 AM
ftp: connect: Connection refused dn7 Linux - Software 1 09-01-2004 06:51 PM
ftp: connect : connection refused udayan Linux - Networking 4 05-14-2003 12:55 AM
ftp: connect: Connection refused shusseina Linux - Networking 3 05-05-2003 07:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration