LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-07-2012, 11:37 AM   #1
gemmajid
Member
 
Registered: Mar 2012
Location: Karachi
Distribution: Ubuntu, RedHat, CentOs,
Posts: 104

Rep: Reputation: Disabled
Question FSTAB Mounting Shares Read Only


Dear Friends,

I have mounted my Ubuntu Samba Sharing in Centos 6.2 through "FSTAB" with the above entry

//192.168.44.100/share /path_to/mount cifs username=server_user,password=secret,_netdev,file_mode=0777,dir_mode=0777 0 0

Every thing goes well but still i'm facing one problem that all the data is read only if i access that through mounted drive but if i use it through Network Sharing it's fine.

Kindly let me know that how can i fix that problem.
 
Old 04-07-2012, 12:50 PM   #2
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 4,703

Rep: Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731
Please define exactly what you mean by accessing thru mounted drive and accessing through Network Sharing.

jlinkels
 
Old 04-09-2012, 05:51 AM   #3
gemmajid
Member
 
Registered: Mar 2012
Location: Karachi
Distribution: Ubuntu, RedHat, CentOs,
Posts: 104

Original Poster
Rep: Reputation: Disabled
Dear jlinkels,

I mean to say that when i access Ubuntu Samba Sharing through (Place --> Connect to Server) option it works fine there is no read only option.

I have the following entry in FSTAB "//192.168.44.100/Data-Sharing /home/gemmajid/Desktop/Windows username=server_user,password=secret,_netdev,file_mode=0777,dir_mode=0777 0 0"

this one is working fine but it's read only, when i access my sharing through /home/gemmajid/Desktop/Windows it shows all data as read only.
 
Old 04-09-2012, 05:59 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
If you think there is an issue with fstab entry, use "rw" option.
 
Old 04-09-2012, 09:09 AM   #5
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 4,703

Rep: Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731
That might very well be true. Then the fstab entry becomes:
"//192.168.44.100/Data-Sharing /home/gemmajid/Desktop/Windows rw username=server_user,password=secret,_netdev,file_mode=0777,dir_mode=0777 0 0"
(without the quotes)

jlinkels
 
Old 04-11-2012, 01:24 AM   #6
gemmajid
Member
 
Registered: Mar 2012
Location: Karachi
Distribution: Ubuntu, RedHat, CentOs,
Posts: 104

Original Poster
Rep: Reputation: Disabled
//192.168.1.200/Audit-Data /home/test/Desktop/Testing rw username=majid,password=maj123,_netdev,file_mode=0777,dir_mode=0777 0 0

//192.168.1.200/Audit-Staff /home/test/Desktop/Audit-Staff rw username=majid,password=maj123,_netdev,file_mode=0777,dir_mode=0777 0 0


above mentioned is my fstab entry which you have suggested to me, when i have entred this to fstab & run "Mount -a" command it gives me error

mount: unknown filesystem type 'rw'
mount: unknown filesystem type 'rw'


Kindly suggest me what should i do..
 
Old 04-11-2012, 01:34 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
rw should be in options field and not FS.
 
Old 04-11-2012, 02:10 AM   #8
gemmajid
Member
 
Registered: Mar 2012
Location: Karachi
Distribution: Ubuntu, RedHat, CentOs,
Posts: 104

Original Poster
Rep: Reputation: Disabled
Now what entry i should use to do that..
 
Old 04-11-2012, 02:34 AM   #9
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: RHEL 7.x, SLES 11 SP2/3/4
Posts: 1,195
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
check the location of rw
Code:
//192.168.1.200/Audit-Data /home/test/Desktop/Testing rw username=majid,password=maj123,_netdev,file_mode=0777,dir_mode=0777,rw 0 0
and after changing the entry you need to update the fstab
Code:
#sudo mount -a
 
Old 04-11-2012, 03:41 AM   #10
gemmajid
Member
 
Registered: Mar 2012
Location: Karachi
Distribution: Ubuntu, RedHat, CentOs,
Posts: 104

Original Poster
Rep: Reputation: Disabled
//192.168.1.200/Audit-Data /home/test/Desktop/Testing cifs username=majid,password=maj123,_netdev,file_mode=0777,dir_mode=0777,rw 0 0

//192.168.1.200/Audit-Data /home/test/Desktop/Testing rw username=majid,password=maj123,_netdev,file_mode=0777,dir_mode=0777,rw 0 0

I have tried both entries but same result for me the data is read only.
 
Old 04-11-2012, 05:05 AM   #11
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Are the files in read only mode sharing at the source?
 
Old 04-11-2012, 05:31 AM   #12
gemmajid
Member
 
Registered: Mar 2012
Location: Karachi
Distribution: Ubuntu, RedHat, CentOs,
Posts: 104

Original Poster
Rep: Reputation: Disabled
Nope dear the sharing is not in read only mode from the source, as i'm telling you that if i use the sharing through (Places --> Connect to Server Option) than it works fine but when i use it from the mounted network drives it shows file as read only.
 
Old 04-11-2012, 05:41 AM   #13
gemmajid
Member
 
Registered: Mar 2012
Location: Karachi
Distribution: Ubuntu, RedHat, CentOs,
Posts: 104

Original Poster
Rep: Reputation: Disabled
is there any difference B/W nifs & cifs, because i'm using cifs in fstab but when i i see my sharing through ls -l it shows me

"-rwxr--r--. 1 nfsnobody nfsnobody 22283 Jan 10 12:59 abdul mateen.xlsx"

in every file. is this effects ??

Last edited by gemmajid; 04-11-2012 at 05:43 AM.
 
Old 04-11-2012, 05:57 AM   #14
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
If your File server is linux and you want to mount the shares in Linux, it would be easier for you to use NFS rather than samba.
Can you list the permissions on the folder that you have shared? If that folder is shared as read only or if the file system permissions on the folder are set to read only, then you wont be able to mount it as read write. The original source folder should have appropriate permissions before you look into client fstab entries.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 15 not mounting NFS shares from fstab PreacherBill Fedora 11 07-05-2011 04:16 PM
Mounting RW (read write) SMB (Samba) shares via FSTAB - Ubuntu 10.10 bcyork Linux - Networking 2 12-09-2010 03:43 PM
Fstab Mounting Windows Shares...help ssa2204 Linux - Newbie 2 08-20-2006 12:16 AM
Mounting Windows shares in fstab raypen Slackware 4 10-16-2004 06:16 PM
mounting w2k shares in fstab GraemeK Linux - Networking 2 01-30-2004 05:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration