LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Fstab doesn't listen (https://www.linuxquestions.org/questions/linux-newbie-8/fstab-doesnt-listen-330723/)

cryptoX 06-06-2005 12:21 AM

Fstab doesn't listen
 
I can't get my usb drive to mount from my user account. It says that only root can do that. Before I re-installed, I could use uid=adam in the fstab to allow me to mount, but that isn't working anymore.

ls -l /mnt
drwxr-xr-x 2 adam adam 1536 Jun 5 23:07 usb_drive

cat etc/fstab
/dev/sda1 /mnt/usb_drive vfat noauto,owner 0 0
/dev/sda1 /mnt/usb_drive vfat noauto,uid=adam 0 0

Neither of the ways above work. The only way it works is with
/dev/sda1 /mnt/usb_drive vfat noauto,user(s) 0 0

Shouldn't the uid in the fstab allow me to mount?

bigrigdriver 06-06-2005 01:05 AM

Unless I am sorely mistaken, you are only allowed one entry in fstab per device. Otherwise, you create a conflict of some kind. Even if thay seem to be one and the same. Your fstab has 2 entries for the same device. Try commenting out 1 of the lines (add the # before the line) and see if that works. If it does not, remove that # and add it to the next line. Then try again.

If both of those fail, try editing fstab. Change owner to user, so that the logged-in user has permission to mount. You could also try changing owner to users, so that members of the users group have permission.

cryptoX 06-06-2005 01:15 AM

Sorry for the confusion, but I meant that I had tried without it working
/dev/sda1 /mnt/usb_drive vfat noauto,uid=adam 0 0
then i changed it to
/dev/sda1 /mnt/usb_drive vfat noauto,owner 0 0
and it still didn't work

While changing owner to user or users works, i thought that using uid=adam should have worked.

a thing 06-06-2005 01:20 PM

"uid=xxx" is not what you want. You want to use the "user" option. And I'm pretty sure uid uses user numbers (found in /etc/passwd) not names.


All times are GMT -5. The time now is 12:59 PM.