LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   fstab defaults sets wrong permissions (https://www.linuxquestions.org/questions/linux-newbie-8/fstab-defaults-sets-wrong-permissions-145958/)

dibblethewrecke 02-14-2004 09:06 AM

fstab defaults sets wrong permissions
 
i have a weird problem. the subject says it all. here is my fstab

# /etc/fstab: static file system information.
#
# The following is an example. Please see fstab(5) for further details.
# Please refer to mount(1) for a complete description of mount options.
#
# Format:
# <file system> <mount point> <type> <options> <dump> <pass>
#
# dump(8) uses the <dump> field to determine which file systems need
# to be dumped. fsck(8) uses the <pass> column to determine which file
# systems need to be checked--the root file system should have a 1 in
# this field, other file systems a 2, and any file systems that should
# not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

# This is a root linux ext2 partition:
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1

# This is a linux ext2 partition:
#/dev/hda2 /mnt/linux ext2 defaults 0 2
/dev/hda7 /home ext3 defaults,user 1 2

# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.
/dev/cdrom /mnt/cdrom iso9660 defaults,noauto,ro,user 0 0
/dev/fd0 /mnt/floppy auto defaults,noauto,user 0 0
#/dev/fd1 /mnt/floppy auto defaults,noauto,user 0 0

# If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.
#/dev/hdd /mnt/ls120 auto defaults,noauto,user 0 0

# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de /mnt/nfs nfs defaults 0 0

# proc file system:
proc /proc proc defaults 0 0

# Unix98 devpts filesystem:
none /dev/pts devpts gid=5,mode=666 0 0

# Shared memory filesystem:
#none /var/shm shm defaults 0 0
# Basic USB filesystem
usbdevfs /proc/bus/usb usbdevfs defaults,noauto 0 0

# For dos partition use type 'msdos'.
# For win95/98 fat16 or FAT32 partition use type 'vfat'.
/dev/hda1 /mnt/win_c vfat defaults,user,umask=000 0 0
/dev/hda2 /mnt/win_d vfat defaults,user,umask=000 0 0
/dev/hda3 /mnt/win_e vfat defaults,user,umask=000 0 0

# The 'sw' option indicates that the swap partition is to be activated
# with 'swapon -a'.
/dev/hda6 none swap sw 0 0

# Swap file:
#/swap none swap sw 0 0

and here is the result of mount:

[dibble:myBox] dibble: mount
/dev/hda5 on / type ext3 (rw,errors=remount-ro)
/dev/hda7 on /home type ext3 (rw,noexec,nosuid,nodev)
proc on /proc type proc (rw)
none on /dev/pts type devpts (rw,gid=5,mode=666)
/dev/hda1 on /mnt/win_c type vfat (rw,noexec,nosuid,nodev,umask=000)
/dev/hda2 on /mnt/win_d type vfat (rw,noexec,nosuid,nodev,umask=000)
/dev/hda3 on /mnt/win_e type vfat (rw,noexec,nosuid,nodev,umask=000)
usbdevfs on /proc/bus/usb type usbdevfs (rw)

man fstab says defaults should not be setting permissions like this - what has gone wrong - i can't execute in /home at all!

michaelk 02-14-2004 11:05 AM

Quote:

/dev/hda7 /home ext3 defaults,user 1 2
Remove user option from your /home fstab entry. See man pages for mount for more info.

user Allow an ordinary user to mount the file
system. This option implies the options
noexec, nosuid, and nodev (unless overridden
by subsequent options, as in the option line
user,exec,dev,suid).

dibblethewrecke 02-14-2004 11:56 AM

don't know how i missed that when i read the man and discovered what the defaults "should" have been

whoops

that explains an AWFUL lot about why loads of things don't work for me!

cheers

fortezza 12-11-2004 03:10 PM

Would this explain my inability to mount ISO images that reside on an NFS Share?


All times are GMT -5. The time now is 03:32 PM.