-   Linux - Newbie (
-   -   Fsck - Win XP no longer reads USB drive (

Jinouchi 01-15-2009 08:37 AM

Fsck - Win XP no longer reads USB drive
Ok, so I noticed that there were several corrupt files on my 500GB External USB HDD, so I ran dosfsck on it. After 48 hours it still had not finished, and I needed to ctrl+c fsck (can't remember why). Apparently, that was a bad idea. I've figured that out from other forums etc. Well, I maganed to somewhat fix my mangled filesystem (it's FAT32 btw) by running fsck again (which took around 72 hrs), but now windows doesn't read it, and fdisk -l returns


Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x44fdfe06

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1              1      60801  488384001  83  Linux

(Emphasis added)

For some reason now it's a Linux "system" type instead of FAT32. AFAIK, Windows XP is still supposed to be able to read ext2/3 filesystems just fine anyway. So...

1. Is this really a "Linux" filesystem, instead of FAT32?
2. Is it even possible to reformat an entire filesystem without loosing all data on it?
3. Why doesn't windows read this, and how do I make it do so?

TYVM in advance for any help.

zulfilee 01-15-2009 09:28 AM

Maybe the system id got changed when running fsck.
Is the disk accessible in linux ?

Try this [You can revert back if it doesnt work]

In linux login as root
If the external harddisk is sdb , run

$ fdisk /dev/sdb

In fdisk type the following

<partition number>
<corresping id> [ex. c W95 FAT32 (LBA)]

Then boot to windows and check if the disk is accessible.

- zulfi

Didier Spaier 01-15-2009 09:36 AM

A am afraid no, you can't reformat a entire filesystem without loosing data.

Probably a silly question, but did yo try to mount /dev/sda1 under Linux, either with "-t auto" or "-t <file_system>" ?

Jinouchi 01-15-2009 09:41 AM

There seems to be some confusion - I failed to mention that I can read/write to it just fine with Linux. Accessing it w/Windows is my only problem. I mount it using "pmount /dev/sda1", or "mount /dev/sda1 /mount/point".

Zulfilee, I just tried your suggestion. I'm rebooting now to see if it works. Will report back.

EDIT: Ok, it didn't work. Here's all I can get in windows...

Jinouchi 01-16-2009 11:41 AM


All times are GMT -5. The time now is 12:14 PM.