LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Frustrated by Dial-Up Set Up, External Modem on FC3 (https://www.linuxquestions.org/questions/linux-newbie-8/frustrated-by-dial-up-set-up-external-modem-on-fc3-315026/)

donv2 04-19-2005 04:53 PM

Frustrated by Dial-Up Set Up, External Modem on FC3
 
Hi,

I'm a first time Linux installer.

I'm re-tasking a Win98 machine to Linux for my Mom. Got tired of Juno, AOL, etc. changing stuff on the machine within a week of my "fixing" it so that it "broke" again... Decided to go Linux (permissions based control) with wine to cover the few apps (games) she can't leave behind.

Fedora Core 3 is loaded and everything works great in all aspects when connected to my home ethernet network. (I like this! I'm going to switch my own machine too!)

I just can't get the dial-up stuff to work. (Grrrrrrr!!) This is my last obstacle to delivering the system to Mom.

I've up2date-d to all the latest packages. When I boot it the system sees the external serial modem (Actiontec EX560LKA). I know this because if I boot again when it is off, the configuration checking thingy (sorry, forget the name) asks me if I want to remove it from the config. I select do nothing and reboot with it powered on to bring it back into the config.

I've checked every forum link I could find via Google, most seem to be dealing with the use of internal Winmodems (making them Linmodems). I've found precious little on using a serial modem with my FC3 set-up (other than that it should be the easiest way to go ;) ).

Here's where I'm at:

The machine seems to believe the modem is at /dev/ttyS0 and has created the /dev/modem link for it (I've not confirmed device yet, see below).

Have disabled the ethernet connection with the Network GUI tool.
Have set up a dial-up connection (phone number, user, etc.) through the same tool and then click to activate it... status window pops up and then I get:

Failed to activate [CONNECTION NAME HERE] with error 8

and I hear nothing from the modem like dialing, negotiation/handshake tones, etc.

I've tried wvdialconf/wvdial as well, no luck (other than a compaint about [Dialer Defaults] being missing), so I can't confirm the system is actually finding the modem, once it is up. I've tried looking in the HW Browser and it makes no mention of the modem (would it?).

I'm running Gnome, in case that matters.

I'm stumped on where to go from here. :scratch: I'd appreciate any help possible, including any pointers to good tutorials on doing this with FC3 if you know of them.

Thanks!

username17 04-19-2005 05:02 PM

Well, I have some good news for you, it's on the HCL.

http://www.linuxquestions.org/hcl/sh...cat=162&page=1

Most posts in the HCL about this modem say it works effortlessly.

It's been a while since I've dealt with dialup (thankfully) but try minicom, it should give you a little more control over the connection and hopefully will tell you more about any problems.
GL

Mara 04-19-2005 05:04 PM

The most important question is which COM port it's connected to. COM1 is /dev/ttyS0 in Linux, COM2 is /dev/ttyS1. If you hear no dial tone etc it's very likely that it's just connected to ttyS1, not ttyS0. Your machine has probably port names written near them. Check it.

Boow 04-19-2005 05:05 PM

try wvdial from the console or you could download gnome-ppp fedora does come with a graphical dialer look at network devices in the menus. also check your /etc/resolve.conf if your isps name servers are not in there then

cat /etc/ppp/resolve.conf >> /etc/resolve.conf

i didn't read your whole post oh well. do lsmod to see if these are loaded

serial_core
ppp_generic
8250

i dont have fedora so i dont know if they compile those in the kernel but if their modules you'll need to load them then udev will create /dev/ttyS0 and so on.

donv2 04-20-2005 12:01 AM

More data, thanks for help so far...
 
Thanks for the replies. Here's what I've done using this info:

Checked for the packages/commands mentioned:

[prompt]$ which lsmod
/usr/bin/which: no lsmod in (/usr/java/j2re1.4.2_08/bin:/usr/kerberos/bin:/usr/java/j2re1.4.2_08/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/diana/bin)

I get similar results trying 'which' for serial_core, ppp_generic, 8250, ppp and pppd.

If I try to grep for these same terms using dmesg and ps -ef, I get only one item turning up:

[prompt]$ dmesg | grep -i serial
Serial: 8250/16550 driver $Revision: 1.90 $ 76 ports, IRQ sharing enabled

I've tried finding anything about ppp under Applications -> System Settings ->
[Add/Remove Applications | Server Settings -> Services] and nothing like 'ppp' appears.

If I do 'yum info ppp' I get a bunch of lines with #### and ending with:

Installed Packages
Name : ppp
Arch : i386
Version: 2.4.2
Release: 6.4.FC3
Size : 636 k
Repo : installed
Summary: The PPP (Point-to-Point Protocol) daemon.

Description:
The ppp package contains the PPP (Point-to-Point Protocol) daemon...
...and so on...

How do I establish that what I need to set up/support the modem serial connection is present in my system? I did a "workstation" install of Fedora Core 3, currently with
Linux version 2.6.10-1.770_FC3.

The good news:

I tried using the Knoppix live CD to boot the system, which has kppp included. With this,
I could connect to the modem at ttyS0 and it would dial OK. So it appears I'm all
set with the hardware, all I have to figure out is what is going on with the SW.

Thanks again, I look forward to any more suggestions and help. This is my third late night trying to figure this out...

Dummy-in-Linux 04-20-2005 12:22 AM

Hello Donv2,

My all time ‘graphical’ favorite dialer is KPPP which is on the FC3 CD’s; you need to install the KDE network package for that.

KPPP looks automatically for the modem; all I found that it helps for some modems to modify the init string for the best performance.

With kind regards,

Richard

donv2 04-20-2005 01:08 AM

Thanks for the pointer... I installed the kdenetwork package and I'm now able to connect via dial-up!

Now just need to figure out how to start/run kppp without requiring root access and then Mom will have
her new computer delivered right afterwards...

Thanks!
Don

donv2 04-20-2005 01:35 AM

Dial-Up Success with Gnome Network Configuration Tool
 
Just to close the loop here, I was finally able to get the Gnome Network Configuration (GNC) tool to make a dial-up connection.

I compared what kppp was doing/had set vs. what was in the GNC tool and discovered that the field "Modem initialization string"
under the "Advanced" tab was blank - in kppp under "Edit Modem Commands" the field "Initialization string 1" was set to "ATZ".
Once I tried entering ATZ for the Modem initialization string in the GNC tool, it connected fine!

This is good news as I was able to set the GNC tool to allow a regular user to start the Dial-up session easily through the GUI supplied.

Posting this message using my now working dial-up connection...

Thanks for all the help, hope this makes it easier for someone following me down this road.

-Don

Dummy-in-Linux 04-20-2005 04:02 AM

Hello Donv2,

I don’t know which chipset is in your modem, but I can recommend that you try to find an init string for your specific modem (or chipset).

This fixed in my case some strange disconnects and made redialing and overall performance a bit better.

Boow 04-20-2005 12:16 PM

donv2 here's a tip many of the commands on fedora are not avalible unless you are the root user. to get there

su -

then type your admin password a regular su wont work. the su - logs you into roots env.

donv2 04-20-2005 03:11 PM

Great, thanks for the additional info! I'll check into the modem commands and be sure to keep the su - in mind.


All times are GMT -5. The time now is 03:17 PM.