-   Linux - Newbie (
-   -   Frozen Shell session... (

tcv 05-26-2007 08:43 AM

Frozen Shell session...
Hey folks,

I have a frozen shell session and I'm not sure how to recover it.

I opened one up a session via CTRL+ALT+F1 (tty1) and while reading about kmsg and attempted to do a 'sudo most /proc/kmsg'. I haven't seen the prompt return.

I can't seem to abort whatever it's doing. CTRL-Z/C doesn't work. If I run 'sudo top' in another console session (I can switch back over to Gnome to run one in a window), I don't see most listed, though I do see lynx which is a paused job in that session, but...

Can anyone offer some suggestions? I'd like to recover the session if possible. As a nifty aside, I'd like to know what I could have done in a situation where I couldn't have switched to Gnome? Reboot?

Thanks everyone!!



tcv 05-26-2007 09:06 AM

Ah! I got it.

First, I now understand that CTRL-ALT-F2 brings up a terminal on TTY2.


I ran 'ps' and found the process and PID.

I then ran, as sudo, 'kill 7501'. Of course, 7501 was the PID.

That fixed it! Yay!


All times are GMT -5. The time now is 03:59 PM.