LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Fresh RH9 install - oops I forgot to install something (https://www.linuxquestions.org/questions/linux-newbie-8/fresh-rh9-install-oops-i-forgot-to-install-something-105923/)

blaint 10-19-2003 11:40 AM

Fresh RH9 install - oops I forgot to install something
 
Okay, now I have a little bit of experience with Linux previously, but it has been quite a while.

I just installed RH9, everything went seamlessly. While installing I did *NOT* check install development tools.

I wanted to upgrade my version of GAIM to the latest, so grabbed the RPM for it. I pulled down gaim-071-1rh9.i386.rpm. Did rpm -ivh on it and got that it was missing dependencies for libgtkspell.so.0 and libtk8.3.so Okay, no problem.

Went out and pulled down the source files for gtkspell (gtkspell-2.0.4.tar.gz) got those file into a directory and did a ./configure in that directory and got:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... missing
checking for working autoconf... missing
checking for working automake-1.4... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

Okay... so now it looks like not previously installing the development tools is coming back to haunt me. I put the RH9 disc in the drive and it goes to the package installer, I choose development tools, and now I get:
krb5-libs = 1.2.7-10 required by krb5-devel
openssl = 0.9.7a-2 required by openssl-devel

Now this is where my confusion begins really. The only files I can find for krb5-libs are the source files, and if I don't have an acceptable C compiler than that source is useless to me.

But I think the more important point that confuses me is that, if it was an option to install these development tools from the RH9 cd on initial install that means that the RH9 CD should contain all the neccesary packages to do that installation. Why can't it use those now? It doesn't make sense to me that coming off of the RH9 cd, I should get an error about a package not being found. Know what I mean? Any help would be appreciated! Thanks.

=Blain

Frodak 10-19-2003 01:08 PM

Hello,

I had the same situation. I didn't install the development tools and then tried installing them later. I downloaded the following from Redhat and installed them:

krb5-devel-1.2.7-14.i386.rpm
krb5-libs-1.2.7-14.i386.rpm
krb5-server-1.2.7-14.i386.rpm
openssl-0.9.7a-20.i386.rpm
openssl-devel-0.9.7a-20.i386.rpm
openssl-perl-0.9.7a-20.i386.rpm

Then I could install the development tools from the Add/Remove Applications tool.

I never did email Redhat about the missing packages from the CD...

:-)
Frodak

blaint 10-19-2003 03:01 PM

Hey Frodak,

Thanks for the tips. I did as you reccomended and manually installed those rpms from redhat's site, now I'm hitting a different snag. When I go in and select to add the "Development" stuff using the redhat proram I get stuck when it is searching for CD 2.

I created the three CD's from the .iso files.

I open up add/remove programs, select development hit okay (same behaviour whether I select it from the menu or do autorun from CD1) it gets to the first package (autoconf-2.57-3) and prompts me to put in "Red Hat Linux 9" disk 2. Well the disk in is in the drive, mounted and I can browse it, but no matter how many times I hit OK, it just isn't working.

Not sure if it is looking for a different volume name on the CD or what. Should I just do all of them manually? thoughts?

Thanks,
=Blain

Frodak 10-19-2003 09:29 PM

I forgot about that... I had a problem with it too. I think I had to unmount CD1 before I put it and mounted CD2. I've got two drives, both CD1 and CD2 may have been mounted. It took a couple of trys... sorry I just don't recall exactly what I had to do.

:-)
Frodak

blaint 10-21-2003 08:03 PM

Would anyone else have any ideas for this?

When it pops up the dialog box saying to insert Disc 2, it unmounts the cdrom drive (i checked the listing by the mount command), I insert disc 2, it gets mounted and I can browse the file system. If I click OK on the "Insert Disc 2" dialog though it just brings up another "Insert Disc 2" dialog in its place.

Now the kind of funny thing is the first package it is looking for is autoconf. If I brose on Disc 2 to /RedHat/RPMS there is no autoconf package so I'm wondering if it even asking for the correct Disc.

Thanks in advance all.

=Blian

Frodak 10-25-2003 01:29 PM

Hi again,

I've recently just had to install the Gnome development packages that I didn't install when installing Redhat 9. I tried doing it as if I had only 1 cd-rom available. I had Disk 1 mounted when I started the Add/Remove Packages app and started the update. Then it asked for Disk 2. I noticed that it already had ejected disk 1 so I popped in disk 2. What happened next was kind of weird. Apparently one of the kids left in Atlantis in the dvd player. It got mounted and then the Add/Remove Packages app popped up an error message and closed itself. So I unmounted everything popped out the dvd, and then mounted disk 2. I then restarted the Add/Remove Packages, selected the stuff I wanted to install again and hit update. It finished installing the rest of the packages without issue. ( I didn't say anything about some of the dependency issues I had when doing this, but that's a different issue... )

Hope this helps,
Frodak


All times are GMT -5. The time now is 01:27 PM.