LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   forwarding CDE from Solaris to X.org? (https://www.linuxquestions.org/questions/linux-newbie-8/forwarding-cde-from-solaris-to-x-org-494451/)

commander_crash 10-21-2006 05:18 PM

forwarding CDE from Solaris to X.org?
 
Does anyone know how I can forward the CDE desktop from a Solaris box to an X server running on linux (red hat or ubuntu)?

I've tried:
ssh -X <server>
Xsun

And get:
Fatal server error:
Server already running !!!

I'm trying to avoid using XDMCP such as:
Xnest -query <server>
or
X -query <server>

As our applications don't always work with that approach and I want to be able to go through our firewall.

Any suggestions?

Jerre Cope 10-22-2006 12:54 AM

Xnest
 
You probably are looking for Xnest

Something like:

ssh -X theserver

$Xnest :1 -query localhost

You may need to install Xnest

commander_crash 10-22-2006 11:57 PM

I'll look into installing Xnest, in the meantime,I found out that we have Exceed on the PCs in the office and they issue a command to the solaris box something like this:

rexec olwm

Is there any way I could get something like that working with my Xserver?

It's not as simple as:
ssh -X <server>
olwm

Because it says that a server is already running on the display.

jlliagre 10-28-2006 04:44 AM

Why are you trying to avoid xdmcp, which I believe does just what you need ?

frob23 10-28-2006 10:10 AM

First you start a new instance of X on your local computer. Then you set that as the default display for the shell session you're in. Then you use the "ssh -X" command. Finally you issue the window manager start command.

Code:

X :1 &
env DISPLAY=:1 ssh -X user@host
olwm &

The first command starts a new X server on your local machine. The second says to use that for the DISPLAY variable for the ssh command, which starts X forwarding to it and logs you into that machine. Note: this will probably switch you to the X session a couple times during this process. Use <ctl>-<alt>-<f1> or <f6> or whatever it takes to get you to the place where you were typing these commands. By default, I use <f1> just so I'm not starting a new X session from inside X.

The last command starts the window manager, it will open and run on the new display.

I use this occassionally and it works just fine.

commander_crash 10-28-2006 11:40 PM

Thanks frob23! That worked nearly perfectly - one piece of software is a little finicky but that might be because of the display resolution.

jlliagre 10-29-2006 01:49 AM

olwm isn't launching CDE, you need to run dtwm instead, but I guess you already know that.

commander_crash 10-29-2006 01:37 PM

With both CDE and OLWM I get an error when running two apps. I can get one of the apps to load under XDMCP, but sometimes it's not drawing the graphics correctly (Fedora doesn't, but Xubuntu did and gentoo did).

The error says:

Quote:

server: X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 53 (X_CreatePixmap)
Value in failed request: 0x8
Serial number of failed request: 1178
Current serial number in output stream: 1521
Any ideas? Basically I can run just about everything but this legacy software. Could it be a font issue?

Also under Fedora Core 6, the SSH forwarding looks to be blocked. I tried turning off the firewall, but it continues to not go through.

jlliagre 10-29-2006 03:12 PM

More likely a bug in this legacy application.

commander_crash 10-30-2006 10:08 AM

Now my follow up, I have to make this work on fedora core 6 for another staff member. Using the same steps as listed above:

%:Xnest :2
%:env DISPLAY=:2 ssh -X <ip>
server: olwm &

I get the following error:
AUDIT: Mon Oct 30 10:05:01 2006: 3265 Xnest: client 1 rejected from local host
Quote:

AUDIT: Mon Oct 30 10:05:01 2006: 3265 Xnest: client 1 rejected from local host
Auth name: MIT-MAGIC-COOKIE-1 ID: -1
Xlib: connection to "localhost:11.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
olwm: cannot connect to (NULL DISPLAY)
I've checked the ssh_config and sshd_config and both have X11 forwarding on, I saw some things on another board about PAM being setup incorrectly, but the entire PAM file is commented out. PAM is set to yes in the sshd file of the fedora box, but I'm using fedora as the client. Any thoughts?


All times are GMT -5. The time now is 10:40 AM.