LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   formatting floppy (https://www.linuxquestions.org/questions/linux-newbie-8/formatting-floppy-435135/)

soldan 04-14-2006 12:58 PM

formatting floppy
 
is there a commandline in linux to format a floppy disk so that the files on the disk are available to both linux (EXT3) and XP (NTFS) filesystems?

SlackerDex 04-14-2006 01:03 PM

man fdformat ; From what I remember floppies can only be formatted into one format not many.

2damncommon 04-15-2006 01:30 AM

Quote:

format a floppy disk so that the files on the disk are available to both linux (EXT3) and XP (NTFS) filesystems?
I believe a normal FAT (16?) floppy is the easiest way to have the floppy available to multiple operating systems.
"mkdosfs" works. Check the "-m" option to add custom "not a boot floppy" message.
"man mkdosfs" for more info.

soldan 04-15-2006 10:51 AM

i looked at the man page for mkdosfs and it says that it will either create a fat12 or fat16 filesystem by default if no options are specified to the 'mkdosfs' command (based on what it thinks best), so with the advice from 2damncommon i didnt use any options. so i then went ahead and formatted the floppy with..

'mkdosfs /dev/fd0'

i then tested to see if i could transfer a file from linux to xp via the floppy disk, by first mounting the floppy in linux with a commandline i found elsewhere on the net..

'mount -t [fstype] [something] [somewhere]

so i actually typed..

'mount -t vfat /dev/fd0 /mnt/floppy'


next i copied a file to the floppy with..

'cp filename /mnt/floppy'


then i unmounted the floppy with..

'umount /mnt/floppy'


i then started XP, and successfully transfered the file from the floppy disk to XP.

thanks for your help guys :) (ps, ive given a full account of what worked for me incase any other noobs find it useful too)

Stabby McTwist 06-02-2006 01:40 PM

I've got an odd problem with this command. The man mkdosfs comes up, but when I try to use it it says command not found.

Lotharster 06-02-2006 02:04 PM

You must be root to execute that command

Stabby McTwist 06-03-2006 03:12 AM

I'm still new to this, thanks.


All times are GMT -5. The time now is 11:45 PM.