-   Linux - Newbie (
-   -   Force Check done ever time. Unmount won't work on "Busy device"... (

R4ndom 04-20-2009 07:55 PM

Force Check done ever time. Unmount won't work on "Busy device"...
I have searched for hours on this site and I cannot find the answer (and my eyes are crossing now.) I have just installed backtrack 3 and am fairly new to Linux. I have it installed on my harddrive (as /dev/sda6) on a dual boot with Qindows XP using Lilo. My problem is everytime I try to shutdown the last message is "unmount: /dev/sda6 device is busy" so that everytime I boot up my system goes through a several minute check on my main disk as it was "unmounted improperly."

I have tried logging off, ctrl-alt-del, sync;sync;halt, shutdown -h now, reboot, poweroff etc. I read somewhere that you cannot unmount a disk you're currently on, but I can't figure out how to log onto another disk at shutdown as this is the last one to shutdown (I tried 'cd ~' before but that didn't work.

Please tell me if I am missing something as a 2-3 minute boot up time is annoying.


MensaWater 04-21-2009 01:52 PM

First you need to know what is on /dev/sda6. Type "df -h" and see what filesystem is mounted there. It may not be the one you think.

One you see a filesystem (e.g. /var) you can use lsof or fuser to determine what is using the filesystem (e.g. lsof /var). It may be there is some process running that you need to stop first.

Linux does allow for init scripts to stop and start things automatically so if you do find something to stop manually you might investigate creating an init script to stop it automatically when you issue the shutdown command.

Also "cd ~" goes to the current user's home directory. If you're not root user then that is likely somewhere under /home. Try logging in as root and doing a "cd /" to go to root directory to do the shutdown if you can't figure it out with lsof.

All times are GMT -5. The time now is 07:16 AM.