LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   font installation (https://www.linuxquestions.org/questions/linux-newbie-8/font-installation-147380/)

befuddled 02-17-2004 08:59 PM

font installation
 
A colleague at Cambridge University has given me a custom font (it's actually available for anybody) to use for printing and viewing on screen transliterated Sanskrit. Following his directions I have installed the pcf files in /usr/X11R6/lib/X11/fonts/CSX (this last is the subdirectory I made just for this group of fonts). I ran mkfontdir on that subdirectory, which produced the desired fonts.dir file. I then made sure that that particular subdirectory was listed in /etc/XF86Config. Then, as root, I checked to make sure Xwindows could find the font. I used the command xlsfonts *csx* and got the correct response.

Then I logged out of the root account and logged into my own user account. There, in a virtual terminal off KDE I went into superuser mode and tried the same xlsfonts command. The response is:

Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
xlsfonts: unable to open display ':0.0'

Needless to say, it doesn't find the fonts when I use the command xlsfonts while in my own user account, but it doesn't complain as above either.

I am doing this so that I can use this font in XEmacs.

My setup is this: kernel 2.2.14 (still working fine for me) behind Caldera Open Linux 2.4, GUI KDE 1.1.2, XFree86 is 3.3.6, and this runs on an IBM ThinkPad A21m G1U 2628 (i686), Intel's Coppermine (600 Mhz).

Grateful for any help.


All times are GMT -5. The time now is 06:08 PM.