LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-18-2008, 08:19 PM   #1
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Rep: Reputation: 0
Folder Rename


I was playing .mp3's in Amarok and renaming them at the same time, maybe that was something I shouldn't have been doing, but several times as the song came to an end, and I'd hit the enter button at the same time, would cause Amarok to lock up. Several times I had to reboot, the last time the folders on the drive (separate physical drive) had a "drwx------" in addition to their given names to each one. A similar renaming occurred on the Home drive as well, only there the renaming was drwxr-xr-x and suchlike. All the drives in Computer have also had 'unknown' added to each as well. Also, in the Permissions tab for Filesystem it says "The permissions of "/" could not be determined." Which sounds particuarly ominous. This renaming hasn't affected how I can access the folders, or their contents. Should I be concerned? How should I repair this problem?
 
Old 10-18-2008, 09:54 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,898

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Several times I had to reboot,
Probably not. Just ctrl+alt+backspace to restart the X server (terminating applications you started as user in the process), then log back in and restart Amarok.
Quote:
the folders on the drive (separate physical drive) had a "drwx------" in addition to their given names to each one. A similar renaming
I am very curious to see a listing of such folders, along with the command used to list them.

Check your log files in /var/log. Look for error messages relating to Amarok. The event that occurs when you press the enter key after renaming a .mp3 while playing should generate an error message if it's in any way related to the file rename.
 
Old 10-18-2008, 11:17 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
What you're seeing there are the description of the access rights granted various classes of users of your system. Specifically, the drwx indicates that you're looking at a directory (what you've mistakenly referred to as a "folder"), and that the owner of the file that describes the directory can read, write, and exacute it. Normally that information is followed by two more sets of three indicators for the group that to which the file belongs, and the access granted to any user not the owner of a member of the group. A dash in place of the r, w or x indicates that the read, write or execute permission has not been granted to the corresponding owner, group, or others.

You can change or set the permissions on any file in the file system using the chmod command. And you can read about chmod (and the chown command which is used to change ownership and group assignment) by using the man chmod or info chmod command. man man or info info will explain how to use those commands.

By the way, to confuse you further (if that's either necessary or helpful), you should understand that a Linux system treats almost everything as a file. Thus a "directory" or "folder" is just a file that describes the location, etc., of other files on the system. And Linux uses a single file system "inverted tree" hierarchy, starting at "/," that may contain an unlimited number of branches, and any branch may be a device, file, etc. If you want to use the "file cabinet" - "folder" metaphor, Linux uses a single "cabinet" containing "folders," and each "folder" can contain "documents" or more "folders." This is in contrast to the MS metaphor, where the "Windows" OS is a "Room" containing no more than 26 different "cabinets," each "cabinet" containing a limited number of "folders," and each "folder" containing a limited number of "documents" or "folders."

Last edited by PTrenholme; 10-18-2008 at 11:20 PM.
 
Old 10-20-2008, 07:34 AM   #4
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
Sorry bigrig, I checked the log file too late, I had no idea that the log files deleted after a day.

Thanks PT, that's actually what I thought it was, my main question now is, is there any way to put it all back to the way it was before? All my files, directories, and drives now have this "extra" information that used to be invisible. It's unnerving to see "unknown" under all my drives, and "The permissions of "/" could not be determined" on the Permissions tab of "Filesystem".

Thanks for your attention.
 
Old 10-20-2008, 01:02 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Well, are you running a file manager (Nautilus or Konquer or a similar app.) to see these listings? If so, look under settings->view or view->settings or whatever you use to specify the file view format. You should have there an option to specify the "details" you want to see in the listing.

I'm not sure what you mean by
Quote:
It's unnerving to see "unknown" under all my drives, and "The permissions of "/" could not be determined" on the Permissions tab of "Filesystem".

It makes a huge difference as to which application you're running when you see a "Permissions tab" of "Filesystem" and which application you're using to see the "unknown" under all your drives.

Also, you have never mentioned which Linux distribution you're using. That, too, can make a lot of difference to what ou see, and what it means.

Normally you would specify where your drives are attached to your (single) file system with entries in /etc/fstab, and the permissions would be set in the "options" field in that file. It seems to me to be quite unusual to see actual drives listed in any application since that information would, in almost all cases, be useless for any Linux user.

For your edification, here's a copy on my /etc/fstab with the lines where "optional" drives are attached to the file system highlighted in red:
Code:
$ cat /etc/fstab
/dev/Fedora/Base        /                       ext3    defaults        1 1
UUID=92ff1a1e-9e16-4828-953e-fbdfde536452 /boot ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
UUID=22b2553f-6199-4b82-b20c-6ad7c7b6688f swap  swap    defaults        0 0
/dev/Fedora/Swap        swap                    swap    defaults        0 0
# Other drives
UUID=17841f9e-fa3a-4850-aa52-0e6d0ba242e3 /Ubuntu ext3  defaults        0 2
UUID=342D7D7923AC4107   /Vista                  ntfs-3g rw,defaults     0 0
UUID=2C88743C8874071C   /Vista/Recovery         ntfs-3g rw,defaults     0 0
# Removable Drives
UUID=48A7-175E          /Kingston               vfat    defaults,noauto 0 0
/dev/USB_Fedora/Base    /USB_Fedora             ext3    defaults,noauto 0 0
UUID=85d4ec8b-3199-4819-a7c3-0f23d7d42aa6 /USB_Fedora/boot ext3 defaults,noauto0 0
 
Old 10-21-2008, 02:51 AM   #6
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
I'm not using Nautilus or Konqueror, this is just by merely clicking on the Computer tab and looking inside. I'm using Ubuntu 8.04.1 Hardy.
I just ran fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda5
UUID=0a713fe7-aae3-43e1-8e40-3a2c8b0a0005 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda6
UUID=ae5734bc-f079-4ab4-b573-59cda2c181a2 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

Only problem is, I have no idea what it means...

Okay, in Ubuntu, I can click on "Places" on my top bar, and it gives me a listing including "Computer" I click that, and it shows me all my drives, which I use to navigate about, since I still don't know how to use "cd". These additional listings (under the names of each drive) used to be invisible, and if I click on any of these drives, in this case, Floppy Drive Properties, I can get five different tabs, including "Properties". In the current case of "Floppy Drive" I can click on it's Permissions tab and see "The permissions of Floppy Drive could not be determined".

I'm just wondering if the only way to remedy this situation is to reinstall Unbuntu, and I'd seriously like to avoid that if possible.

Again, thanks so much for your attention.
 
Old 10-21-2008, 05:30 AM   #7
openSauce
Member
 
Registered: Oct 2007
Distribution: Fedora, openSUSE
Posts: 252

Rep: Reputation: 39
Quote:
Originally Posted by linn View Post
I'm not using Nautilus or Konqueror, this is just by merely clicking on the Computer tab and looking inside.
What you're using is the default file browser you installed with Ubuntu, which from what you've said, sounds like Nautilus. You can confirm this by selecting Help -> About on the file browser (any window where you're browsing files), and see what program name it gives you info on.

Quote:
Originally Posted by linn View Post
I just ran fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda5
UUID=0a713fe7-aae3-43e1-8e40-3a2c8b0a0005 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda6
UUID=ae5734bc-f079-4ab4-b573-59cda2c181a2 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

Only problem is, I have no idea what it means...
fstab is a file telling your system where different drive partitions and other physical devices should be mounted on your file system (type man fstab for more info). Yours contains 5 lines (the ones beginning with '#' are comments and are ignored):
  • the 'proc' one you don't need to worry about.
  • the two beginning 'UUID=...' refer to partitions on your hard drive, the first is mounted at / (that's the partition on which Ubuntu is installed), and the second is mounted as swap.
  • the other two give default options for mounting floppies and CDs.

It doesn't have anything about a "separate physical drive" that you mentioned your mp3's were on. So are these on an external USB/firewire drive? If so, the drive will be mounted in the /media/ directory.

Can you open a terminal, go to /media, and look for a directory containing some of your problem files? You said you didn't know how to use "cd", but there's not much you need to know:
enter cd /media to go to the /media directory (cd = "change directory").
enter ls to list all directories and files in the current directory, or ls [DIR NAME] to list directories and files in DIR NAME.
Use cd again to go to a subdirectory of /media containing the filesystem on your external drive, and to go to the problem directory.
When you've found the directory with the problem files, please post the output of ls -l so we can see the file names and the permissions. This will tell us if there's really something odd going on with your files, or if it's just the file browser.

Quote:
Originally Posted by linn View Post
I'm just wondering if the only way to remedy this situation is to reinstall Unbuntu, and I'd seriously like to avoid that if possible.
shouldn't be necessary!
 
Old 10-22-2008, 04:04 AM   #8
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
Oops, guess you were right about that Nautilus thing. Well, I did say I'm very new at this, lol. I did run something else, so maybe you can see what I'm talking about a bit better:

lin@name:~$ ls /dev/disk/by-label -lah
total 0
drwxr-xr-x 2 root root 80 2008-10-21 20:16 .
drwxr-xr-x 6 root root 120 2008-10-21 20:16 ..
lrwxrwxrwx 1 root root 10 2008-10-21 20:16 Primary -> ../../sda1
lrwxrwxrwx 1 root root 10 2008-10-21 20:16 SECONDARY -> ../../sdb1

SECONDARY is where my mp3's are. No matter how I try, I can't cd to that directory. when I use sdb1 to cd to it, I get the response back that it doesn't exist.

What you see there as "lrwxrwxrwx" on each drive is what I see on every file in my computer, or how it's interpreting them now. On each drive, instead of "lrwxrwxrwx" I see "unknown" and that's what perturbs me, nearly to panic, mainly because I didn't think my Home Folder was supposed to be "unknown" with the mount point "/" with it's permissions to be unable to be determined.
All my files on all visible drives exhibit this condition, not only the ones on SECONDARY.

This is the result after running fstab after I can see all my drives on the desktop:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda5
UUID=0a713fe7-aae3-43e1-8e40-3a2c8b0a0005 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda6
UUID=ae5734bc-f079-4ab4-b573-59cda2c181a2 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

Contents of Media:

lin@name:/media$ ls
cd CD cdrom cdrom0 floppy floppy0 Primary SECONDARY

Contents of SECONDARY:
lin@name:/media$ ls SECONDARY
D2 Items Jamella Recycled Shared WASEO
Documents Media save Some Tunes Wavs
Downloads Pix Shadowmaster System Volume Information Windoze Games

Some Tunes is the directory where my mp3's are.
 
Old 10-22-2008, 05:52 AM   #9
openSauce
Member
 
Registered: Oct 2007
Distribution: Fedora, openSUSE
Posts: 252

Rep: Reputation: 39
Quote:
Originally Posted by linn View Post
Oops, guess you were right about that Nautilus thing. Well, I did say I'm very new at this, lol.
Not a problem

I don't see anything to worry about in the output you posted. It's expected that you can't cd into /dev/sd**, so don't worry about that - I don't know exactly how to explain it but the files in /dev are used by the system to manage devices; they're not used directly to access files on the devices.

To access the files, you need to mount the device on some other directory (called the "mountpoint") and cd to that. In your case, /dev/sdb1 is mounted on /media/SECONDARY and you seem to be able to access it just fine. Where are you seeing "unknown"? Is it the output of a command, or something on Nautilus?

Please post the output of the following, as we still haven't seen anything which shows a problem with any permissions:
ls -ld /
ls -ld /home
ls -l /media
ls -l /media/SECONDARY

And if you can find anywhere where the output of ls -l includes the word "unknown", post that also.

If this is just a problem with Nautilus, as I suspect, then although it's annoying it's nothing fundamental, and shouldn't cause you too much hassle (famous last words...)
 
Old 10-22-2008, 03:31 PM   #10
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
You do seem to be fixated on Windows terminology and methods. There are several entries in the "tutorials" section (the fifth button in the bar at the top of each LQ page) that might help you become more comfortable with the "Linux way" of computing.

Let me go over it one more time. Consider the output you posted above:
Code:
lin@name:~$ ls /dev/disk/by-label -lah
total 0
drwxr-xr-x 2 root root  80 2008-10-21 20:16 .
drwxr-xr-x 6 root root 120 2008-10-21 20:16 ..
lrwxrwxrwx 1 root root  10 2008-10-21 20:16 Primary -> ../../sda1
lrwxrwxrwx 1 root root  10 2008-10-21 20:16 SECONDARY -> ../../sdb1
First, the command you entered: ls /dev/disk/by-label -lah has requested a long listing (-l) of all (a) entries in /dev/disk/by-label, reporting the entry sizes in human-readable (h) format.

The first two entries you see (. and ..) are implied entries present in any directory, and refer to the current directory (.) and the parent of the current directory (..). You see those because of the a option you used. (If, instead, you had used A these "always there" entries would have been suppressed.) (One "peculiarity" of the ../ convention is that the "parent" of the files system root directory (/) is, by definition, itself. But that's the only exception to the rule that ../ is the parent of ./)

The next two entries tell you that you have to partitions defined with labels "Primary" and "SECONDARY." the information at the start of each line (lrwxrwxrwx 1 root root 10) is interpreted as like this for Primary (as an example):

"Primary" is a symbolic link (l) to /dev/sda1 (since the listing is in /dev/disk/by-label, the parent of the parent -- ../../ -- is /dev) and the link is owned ay "root" and the "root" group. The link uses one "hard link" (to it's "real" location), can be read, written on, and executed by "root" (rwx), by members of the "root" group (the second rwx), and by anyone else (the third rwx). The link occupies 10 bytes on the drive.

Now, all that this listing is telling you is that those are the labels on the frist partitions on each of the two disks. That doesn't mean that you can access those partitions.

In order to access a partition, you have to attach the partition someplace on your file system. That is normally done by "mounting" the partition at a specific location that you (or your distribution) have created prior to doing the "mount." Ubuntu automatically creates a "/media" mount point and, by default, will mount removable devices in the /media directory. However, /dev/sdb1 is not a removable device, so it's not normally mounted in the /media directory.

If you look at your /etc/fstab file, what you see are instruction to the Linux system for mounting internal drives. (By the way, /etc/fstab is not a program that you can execute. It's just a set of description of where and how devices should be connected. Now, look at your /etc/fstab:
Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc            /proc         proc   defaults  0      0
# /dev/sda5
UUID=0a713fe7-aae3-43e1-8e40-3a2c8b0a0005 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda6
UUID=ae5734bc-f079-4ab4-b573-59cda2c181a2 none swap sw 0 0
/dev/scd0       /media/cdrom0  udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0        /media/floppy0 auto        rw,user,noauto,exec,utf8 0 0
The first (non-comment) line just defines the proc "directory" which stores information about processes running on your system.

The second line, UUID=0a7.. tells Ubuntu that the root file system (/) is located on partition 5 of your "Primary" disk. (That is, on the first extended partition.) If you do a ls -l /dev/disk/by-uuid you should see a link pointing from that UUID to /dev/sda5.

The other UUID= line describes the location of your Ubuntu swap partition. (Equivalent to a Windows "pagefile," but on it's own partition.)

The last two lines tell Ubuntu to mount your CDs at /media/cdrom0 and your floppy disks at /media/floppy0 when you have one in the respective drive.

(Since your Ubuntu is at /dev/sda5, may we assume that you installed a dual-boot system and have Windows XP or Vista in the first partition of "Primary?" What (if anything) do you have in partitions 2 and 3?

Can you do a sudo /sbin/fdisk -l /dev/sd? and explain youd drive configuration for us? The output should look something like this:
Code:
$ sudo /sbin/fdisk -l /dev/sd?
[sudo] password for peter:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa602a602

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        8820    70846618+   7  HPFS/NTFS
/dev/sda2           17927       19457    12297757+   7  HPFS/NTFS
/dev/sda3            8821       17926    73143945    5  Extended
/dev/sda5            8821       17549    70115661   83  Linux
/dev/sda6           17550       17926     3028221   82  Linux swap / Solaris

Partition table entries are not in disk order

Disk /dev/sdb: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00032256

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          25      200781   83  Linux
/dev/sdb2              26       38913   312367860   8e  Linux LVM
My explanation would be tike this: I have Windows Vista in sda1, the Vista Recovery information in sda2, extended partition information in sda3, no sda4 (because extended partitions always start at partition 5), Kubuntu at sda5, and Kubuntu's "swap" space at [b]sda6[/]. On sdb I have a Fedora 9 boot partition at sdb1 and a Logical Volume containing the Fedora 9 root (/) and "swap" logical partitions in sdb2.

F.Y.I., Ubuntu does not normally use Logical Volumes (although it can), so that stuff on my sdb drive can remain a mystery to you for now since it's not relevant to your access to your "SECONDARY" drive.

Now, to access you "SECONDARY" drive, you'll need to edit (sudo gedit /ect/fstab) your fstab to add the necessary information there. If you go back to my first post (above), you'll see that I've shown you an example of how I get my two Vista partitions mounted so I can access them from my Linux systems. Using the information you find with the fdisk -l command, and the ls -l /dev/disk/by-uuid you should be able to add the necessary line(s) to you fstab file.

The one thing you need to do before you can do this is to create the "place" in your Ubuntu file system where you want to attach the partition(s) from your "SECONDARY" drive. Traditionally you would do a sudo mkdir /mnt/d to create a place under "/mnt" to "park" your "D:" drive, although (as you can see in my example) I prefer to park things like that directly under /, but it's really a matter of choice. I happen to prefer "wide" trees with little "depth," but, traditionally, most Linux users seem to prefer narrow, deep file trees.

Anyhow, once you've created the "parking place" for the partition, that "place" is what you put into the second entry of the line you're going to write in your fstab.

When you've finished making the changes to your fstab and written the changes back out to the file, you can test your changes to make sure they work by doing a sudo mount /mnt/d (where I've assumed that you used /mnt/d as your "parking place" name). If that works, you're done.

Oh, I can' remember if the ntfs-3g file system type is installed by default in Ubuntu systems. If it's not there, it is available in the repositories. Just search on ntfs-3g and install it.

Caution: Be sure you test your changes before you reboot because errors in your fstab can prevent you system from starting.

Note: If you are running a dual-boot system, I recommend that you install the IFS driver on your Windows system. That will give you access to your Ubuntu files from Windows. (I attach my Kubuntu partition as a U: drive from Vista. It can be handy at times.)
 
Old 10-22-2008, 03:47 PM   #11
openSauce
Member
 
Registered: Oct 2007
Distribution: Fedora, openSUSE
Posts: 252

Rep: Reputation: 39
Quote:
Originally Posted by PTrenholme View Post
Note: If you are running a dual-boot system, I recommend that you install the IFS driver on your Windows system. That will give you access to your Ubuntu files from Windows. (I attach my Kubuntu partition as a U: drive from Vista. It can be handy at times.)
Not wanting to stray off-topic, but just to quickly let you know, I've found that if Windows blue-screens on me with the IFS driver installed, it causes trouble on my Linux partition (even if it's not actually assigned a drive letter at the time of the crash) - forces a filesystem check at boot, then drops into single-user mode due to an unknown error. I was just lucky I happened to have backed up the partition the same day it happened! Just discovered the IFS driver recently and it is very handy, but something to watch out for.
 
Old 10-22-2008, 07:06 PM   #12
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Strange. I've never had a problem on either XP or Vista. Of course, I don't use Windows for anything serious, so losing those partitions would not cause much of a problem.
 
Old 10-23-2008, 04:12 AM   #13
linn
LQ Newbie
 
Registered: Oct 2008
Posts: 21

Original Poster
Rep: Reputation: 0
Output of ls -ld:
drwxr-xr-x 60 lin lin 12288 2008-10-23 01:10 .

Output of ls -ld /home:
drwxr-xr-x 3 root root 4096 2008-10-12 23:45 /home

Output of ls -l /media:
lin@name:~$ ls -l /media
total 30
drwxr-xr-x 2 root root 4096 2008-10-16 17:19 cd
drwxr-xr-x 2 root root 4096 2008-10-16 17:19 CD
lrwxrwxrwx 1 root root 6 2008-10-12 23:39 cdrom -> cdrom0
dr-xr-xr-x 1 root root 2048 2001-05-23 09:16 cdrom0
lrwxrwxrwx 1 root root 7 2008-10-12 23:39 floppy -> floppy0
drwxr-xr-x 2 root root 4096 2008-10-12 23:39 floppy0
drwx------ 19 lin root 16384 1969-12-31 18:00 SECONDARY

Output of ls -l /media/SECONDARY
lin@name:~$ ls -l /media/SECONDARY
total 320
drwx------ 2 lin root 16384 2008-10-13 22:57 D2 Items
drwx------ 2 lin root 16384 2008-10-18 19:50 Documents
drwx------ 5 lin root 16384 2008-10-21 04:25 Downloads
drwx------ 2 lin root 16384 2008-10-23 01:05 Images
drwx------ 2 lin root 16384 2008-10-13 22:55 Jamella
drwx------ 2 lin root 16384 2008-10-21 05:14 Media
drwx------ 2 lin root 16384 2008-10-16 03:36 Pix
drwx------ 2 lin root 16384 2008-09-30 18:16 Recycled
drwx------ 2 lin root 81920 2008-10-13 22:45 save
drwx------ 2 lin root 16384 2008-10-13 22:54 Shadowmaster
drwx------ 2 lin root 16384 2008-10-06 20:57 Shared
drwx------ 4 lin root 16384 2008-09-30 18:31 Some Tunes
drwx------ 4 lin root 16384 2008-09-30 11:41 System Volume Information
drwx------ 3 lin root 16384 2008-10-13 22:47 WASEO
drwx------ 4 lin root 16384 2008-10-01 11:27 Wavs
drwx------ 8 lin root 16384 2008-10-08 19:34 Windoze Games

Output of sudo /sbin/fdisk -l /dev/sd:

Well, there was nothing. Just a blank line after I entered "sudo /sbin/fdisk -l /dev/sd" after it asked for my password.

I do have winxp on "Primary" as it wanted the first part of the drive for it's boot sector. I formatted the drive (with the Ubuntu disk) to allow windoze the first 20 gigs on an 80 gig drive, and then let Ubuntu have all the rest of it. I thought this would work well, since windoze could access my 120 gig external drive, and 256mb flash drive and Ubuntu can't (at the moment). I let Ubuntu do an automatic install after I determined how much space windoze could have. I hope that was okay to do. It just seemed right to me to allow Ubuntu as much room as it could have since windoze is so proprietary about being first on the drive, lol.

I can access Secondary just fine, there's no problem with access. It's just the added descriptions on the drives being "unknown" in Nautilus and when I click on the "Filesystem" tab to see Properties of that drive, which as you tell me is my system files, it said then and still says now on the "Permissions" tab of it's properties that "The permissions of "/" could not be determined". It just really worries me when a computer can't determine it's own properties. I used to think something was really wrong when that happened. Either something fundamental had changed, or the way of looking at it was in error. I'm hoping that it's the latter. I'm also hoping that the lack of a result for "sudo /sbin/fdisk -l" /dev/sd isn't totally amiss.

Again, I thank you all for your attention.
 
Old 10-23-2008, 09:15 AM   #14
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
The fdisk command needs a question mark (wild card character) at the end: sudo /sbin/fdisk -l /dev/sd?

From the output you presented, above, I can see no reason for the "unknown" permissions you report. In the ls output, as you can see, the permissions are all rwx for "root."

Of course the fact that only "root" can access the drive may be your problem, since Nautilus will not be executed as "root."

So, let's see if we can get the permissions set correctly so "lin" can access the drive instead of just "root." (I assume that you Ubuntu user name is "lin," not "linn," since that's what you show in the output.)

First, let's see if we can do it "by hand." Try these commands in a terminal:
Code:
sudo chown -R lin:lin /media/SECONDARY/*
sudo chmod -R a=rwx /media/SECONDARY/*
and then see what Nautilus has to say. (The chown command changes the "owner" and "group" of everything to "lin," and the chmod changes the access modes to rwx. The -R means "recursively.")

If that works, and if you want to keep the "D:" drive at /media/SECONDARY, you should add a line like this:
Code:
LABEL=SECONDARY /media/SECONDARY ntfs-3g defaults,rw,uid=lin,gid=lin 0 0
at the end of your /etc/fstab

Let us know how this works.

DON'T FORGET TO TEST FSTAB CHANGES BEFORE REBOOTING.
 
Old 10-23-2008, 12:16 PM   #15
openSauce
Member
 
Registered: Oct 2007
Distribution: Fedora, openSUSE
Posts: 252

Rep: Reputation: 39
Quote:
Originally Posted by PTrenholme View Post
Strange. I've never had a problem on either XP or Vista. Of course, I don't use Windows for anything serious, so losing those partitions would not cause much of a problem.
It was the Linux partition I lost, after a Windows crash - pretty damning indictment of Windows! And the crash wasn't caused by the IFS driver AFAIK, but for some reason I can reliably induce a BSOD when I try to mount a truecrypt volume in Windows (another indictment - much harder for an ordinary application to crash the whole system in Linux. Penguin 2, Microsoft 0). Now I think about it, maybe IFS doesn't play nicely with truecrypt, but I haven't really looked into it.

linn - glad to see you're realising there's nothing to worry about.

Quote:
Originally Posted by linn
It just really worries me when a computer can't determine it's own properties.
As you've seen, the output of those commands shows it can determine its own properties. PT's instructions will probably fix the message on Nautilus, although I also have some files with rwx------ permissions which show up fine on Nautilus, so I'm still a little confused. In fact, now I look more closely...

Quote:
Originally Posted by PTrenholme
Of course the fact that only "root" can access the drive may be your problem, since Nautilus will not be executed as "root."
I think you misread his output - it's the user lin who is the only one who can access SECONDARY. And on my system, Nautilus is running under my username. So I'm a bit baffled as to why Nautilus can't read the permissions. Maybe a child process with a different UID?

linn: have you got different users set up on your machine by any chance? What's the output of ps aux | grep nautilus?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unrar and Rename to Parent Folder Recursively Vasto Linux - Newbie 9 10-16-2008 07:36 AM
How can I rename a folder's content to the name of the folder itself? xmrkite Linux - Software 7 07-25-2008 01:28 PM
Rename Folder in numerics infonlinebr Linux - Newbie 7 06-10-2008 03:02 PM
rename last character in file/folder name BoraX Programming 9 10-26-2006 11:01 AM
rename file/folder command hct224 Linux - Newbie 4 09-19-2003 10:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration