LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   fluxbox upgrade question.. (https://www.linuxquestions.org/questions/linux-newbie-8/fluxbox-upgrade-question-266917/)

DeadPenguin 12-16-2004 12:58 AM

fluxbox upgrade question..
 
I am still very new to installing/upgrading packages on linux.

I downloaded the new fluxbox-0.9.10 slackware package.

I copied it to /home/blair --- my user home.

I ran installpkg flux*

I then ran startx as root and flux upgraded to .9...

I exited flux
logged in as user blair "me".
ran startx and fluxbox was still 1.14....

How do I install the package so it upgrades flux for everyone not just root user?

I know this question is better poster to software, but I am still a newb:newbie:
. Software forum answers are often go over my head.

Thanks,
Blair

Optimistic 12-16-2004 01:41 AM

That is kinda strange, it should have updated for everyone. I updated Flux with Swaret, so you might try that.

After setting up swaret:
Code:

swaret --upgrade fluxbox
Replace fbsetbg with something that allows for transparent menues:
Code:

swaret --install feh
After that Flux will be up to date and you'll have nice looking, transparent menus.

Swaret

DeadPenguin 12-16-2004 09:21 AM

It seemed weird to me also.

I will try swaret., and thanks for the transparent menus heads up.

Regards,
Blair

DeadPenguin 12-16-2004 11:35 PM

tried swaret.

It says fluxbox packages are up to date.

I did swaret --install feh, and it said no available packages matching feh.

Still stuck.

Optimistic 12-16-2004 11:59 PM

You can get feh if you add linuxpackages.net to your swaret repositories file.

Some Good Info

I'm on my Debian box, so I can't tell you what url you need for linuxpackages, but the answer is on this board somewhere.

Note: Some reccommend against using third party repos with swaret as it can break the system. I haven't noticed anything troubling, but just so you know.

DeadPenguin 12-17-2004 01:14 AM

I followed this to configure swaret
http://shilo.is-a-geek.com/slack/swaret7.html

BTW. I went back into user fluxbox and it says the old version #(0.1.14.), but looks like current version(.0.9.10)???????????

*not sure if version are correct I m doing it from memory.

As user I could now tinker with alpha values.
So I guess something worked.

I will read up on feh.

Still puzzled, but happier.

Thanks,
Blair

MylesCLin 12-28-2004 03:47 PM

Is it saying the old version in the right-click menu?
If so, open up a terminal and type fluxbox --version.
If it says the new 0.9.10, edit ~/.fluxbox/menu to say 0.9.10

comprookie2000 12-28-2004 04:00 PM

You can call it anything you want,sounds like you have the newer fluxbox it is just your old menu,also check your ~/.fluxbox/init and make sure it is reading your menu ~./fluxbox/menu.Here is the first part of mine;
# you can change the menu name in .fluxbox/init to:
# session.menuFile: /home/you/.fluxbox/my-menu
[begin] (Gentoo.tux)
[exec] (aterm) {aterm}
[exec] (Eterm) {Eterm}
[exec] (firefox) {/home/david/firefox-installer/firefox}
[exec] (Run) {fbrun }
See mine is Gentoo.tux,you could call yours SlackBox if you wanted.

DeadPenguin 12-28-2004 10:28 PM

That fixed it.

I changed menu from old version to just "fluxbox".
:D

comprookie on aterm you just have it set as:

[exec] (aterm) {aterm} ?

did you set your aterm settings somewhere else?

I did - ( in /home/me/.fluxbox/menu) :

[exec] (aterm) {aterm -tr -tint blue -fg yellow -cp white}
That gives me transparency a blue tint with yellow text and a white cursor. It shows up better on my dark background.

Just curious:scratch:

Thank you for your help.

Regards,
Blair

comprookie2000 12-28-2004 10:31 PM

I put them in .Xdefaults;
Code:

Aterm*scrollBar: false
Aterm*transparent: true
Aterm*background: black
Aterm*foreground: white
Aterm*tintingType: true
Aterm*shading: 60
Aterm*fading: 50
Aterm*loginShell: true
Aterm*saveLines: 5000
Aterm*font: -pxl-*-*-*-*-*-16-*-*-*-*-*-*-*
Aterm*cursorColor: red
Aterm*title: Gentoo


Aterm*colorBDMode:        on
Aterm*colorBD:          white
Aterm*colorULMode:        on
Aterm*colorUL:                white
XTerm*scrollBar:    false
XTerm*background:  black
XTerm*foreground:  gray
XTerm*cursorColor:  yellow
Xterm*font: -pxl-*-*-*-*-*-16-*-*-*-*-*-*-*

here is some more dot file's for fluxbox;
http://fluxbox.sourceforge.net/download/dotfiles/

DeadPenguin 12-28-2004 10:35 PM

that was fast.

comprookie2000 12-28-2004 10:51 PM

These fonts look great,just edit your style;get the en ones (english)
http://sourceforge.net/project/showf...group_id=95348
Here is the howto;
http://artwizaleczapka.sourceforge.net/README
What I do is download them and then move them to /usr/share/fonts then cd /usr/share/fonts
su
tar xvfj <filename>
remove the tar.bz2
then edit /etc/X11/xorg.conf like this

FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/sharefonts/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/pxl2000-0.95/"
FontPath "/usr/share/fonts/ttf-bitstream-vera/"
FontPath "/usr/share/fonts/artwiz/"
FontPath "/usr/share/fonts/freefont/"
FontPath "/usr/share/fonts/artwiz-aleczapka-en/"
FontPath "/usr/share/fonts/corefonts/"

DeadPenguin 12-29-2004 12:33 AM

Thanks for the info.

I have tried artwiz a few installs ago. ( when I mess up my box beyond repair I just re-install.)
This is a learning process for me. I have learned more with slackware in a couple months than a year plus with SUSE.
anyway i am babbling. Thanks for the help.

I will try artwiz again with your instructions. Thx.

Regards,
Blair

DeadPenguin 12-29-2004 12:45 AM

All right comprookie.

I just checked out you sig links.

Is that desktop picture flux?
How did you do the icons? is that through fbdesk?
The other stuff is that super karamba?

Sorry for all the questions, and I know all this is off the thread topic, but i had 2 ask.

Regards,
Blair.

Thx for the linuxcommand linkthe "ps -A" command has come in handy over the last month.
(I have been looking for that site for a couple weeks.)

cs-cam 12-29-2004 01:17 AM

If you want icons in flux, fbdesk and rox can do it fine but iDesk provides some nice eye candy if you're into looking good too ;) Looks like fluxbox and the "other stuff" is gDesklets, not superkaramba :)


All times are GMT -5. The time now is 02:30 AM.