-   Linux - Newbie (
-   -   Fluxbox help on Slack (

zc923 04-06-2004 08:36 PM

Fluxbox help on Slack
I thought this was gonna be easy...

Downloaded this :

After unpackaging everything, I run "./configure", then "make", then "make install". I followed the instructions on the faq ( to get fluxbox to appear in the GDM sessions menu. Followed them, and no luck. Fluxbox does not appear in the sessions menu.

I installed Fluxbox on RH9 a couple weeks ago on another comp, and everything worked alright. But know, Im stuck.

Any suggestions?

AutOPSY 04-06-2004 08:45 PM

Create the file: /etc/gdm/Sessions/fluxbox with contents:

there are several ways respective to the Desktop Enviornment you are running.

Where do you think its failing?
Those were pretty simple tutorials, being that easy there arent many ways something could go wrong.

zc923 04-06-2004 09:24 PM

Ok, so heres what I got...

created "/etc/gdm/Sessions/fluxbox". It did not appear at all in the sessions menu. So, deleted that file, copied a functioning "gnome" file, and then renamed it fluxbox. Success! I can see it in the sessions menu.

From there, when I try to load fluxbox, I get an error saying that Xwindows ran for less then 10 seconds. Look at the error code, it says that "/etc/X11/Xsession" does not exist. So, after looking at the working gnome one, I, changed this to "etc/X11/xdm/Xsession". Therefore, the line reads "exec /etc/X11/xdm/Xsession /usr/local/bin/fluxbox". Upon trying to start this, it loads gnome (lightnig quick might I add :scratch: ). Upon doing more snooping, I found an "xinitrc.fluxbox" file. I edited the Xsession file, and Changed "Blackbox" to "fluxbox" and changed the exec command to "exec /etc/X11/xinit/xinitrc.fluxbox".
Going back to the "/etc/gdm/Sessions/fluxbox" file, I changed "exec /etc/X11/xdm/Xsession /usr/local/bin/fluxbox" to "/etc/X11/xdm/Xsession fluxbox". And what do You know, It worked!

I guess the fluxbox people should edit their faq...

Steps Outlined:
1. Duplicat a current working file in "/etc/gdm/Sessions/", and rename it to "fluxbox"
2. Edit the new "fluxbox" file, add this

#bin/bash -login <br> exec /etc/X11/xdm/Xsession fluxbox
3. Edit /etc/X11/xdm/Xsession", find "blackbox", replace with "fluxbox", then change the "exec blackbox" to "exec /etc/X11/Xinit/xinitrc.fluxbox".
4. Download this file "". Unpack, and find the file "xinitrc.fluxbox".
5. Copy "xinitrc.fluxbox" to "/etc/X11/Xinit/xinitrc.fluxbox".
6. Enjoy

Thanks guys, If I had not posted, I sould have given up :tisk: .

AutOPSY 04-07-2004 11:47 PM

#bin/bash -login <br> exec /etc/X11/xdm/Xsession fluxbox
add that to the file.

the file has to have lenght bytes >0 .
an empty file will not work

motub 04-08-2004 01:41 AM

No, GDM is different now, and those instructions don't seem to work any more.

What you have to do (I just did this yesterday to add blackbox and KDE to my GDM sessions menu) is go to /usr/share/Xsessions (preferably as root).

You should find a bunch of *.desktop files relating to the WM's currently on your menu.

Right click one of them and open it in a text editor (as root).

Change the entries to reflect the new WM. It's pretty obvious (change the name, change the name again in the tooltip, change the startup command), but you can look in the Xsession files to see the actual startup command if you don't know it.

Save the file as (do not use Save, use Save As) whatever_the_desktop_name_is.desktop. This has to be (afaik) the same name as the desktop name used in the file. So if the name you've used is KDE-3.2.1, the desktop file should be called KDE-3.2.1.desktop. Or maybe I'm just over cautious.

Then you must reboot so that GDM's config file is reread when it restarts. Or I suppose you could stop it and start it, but I'm not sure how that would work. In any case, when you reinitialize GDM, you should have the additional entries and they should work, provided you have the correct startup command in the *.desktop file.

Worked for me, anyway. Hope it helps you.

All times are GMT -5. The time now is 08:57 PM.