LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2006, 04:31 AM   #1
vic11r
LQ Newbie
 
Registered: Nov 2006
Location: Russia
Distribution: Red Hat Enterprise Linux 4
Posts: 7

Rep: Reputation: 0
floppy pause


When dragging files to a floppy disk, the file immediately appears on the target, but the actual copying (LED flashing) starts only about 30 secs later (RHEL4). The same with deletion.
Why this pause?
 
Old 12-04-2006, 04:53 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,594

Rep: Reputation: 125Reputation: 125
Your system probably mounts the floppy with the "async" option. This causes the I/O stuff to be done asynchronically. Try to add "sync" and "dirsync" to your floppy's mount options and that should stop, but in my experience the disc write could take much longer.
 
Old 12-05-2006, 01:59 PM   #3
vic11r
LQ Newbie
 
Registered: Nov 2006
Location: Russia
Distribution: Red Hat Enterprise Linux 4
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by titopoquito
Try to add "sync" and "dirsync" to your floppy's mount options and that should stop
Sorry, but how do I get to the mount options?
 
Old 12-05-2006, 02:11 PM   #4
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,594

Rep: Reputation: 125Reputation: 125
Type "mount" (if the device is mounted) at the command prompt or open your /etc/fstab file (it's the fourth column). From the manpage (man mount) about the "defaults" that you will probably see in /etc/fstab: "Use default options: rw, suid, dev, exec, auto, nouser, and async."
 
Old 12-07-2006, 04:20 AM   #5
vic11r
LQ Newbie
 
Registered: Nov 2006
Location: Russia
Distribution: Red Hat Enterprise Linux 4
Posts: 7

Original Poster
Rep: Reputation: 0
Thank you. 'mount -o sync' helped.
I tried to add sync to fstab via mc, saved the file, rebooted, and then...
The file 'etc/fstab' was unchanged again. like I never modified it.
How can I set this option permanently?
 
Old 12-07-2006, 04:54 AM   #6
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,594

Rep: Reputation: 125Reputation: 125
Usually by just editing it :-| I had this once with Mandrake I think. You should read the documentation, it's a RHEL specific thing I guess. A quick search showed that at least "kudzu" is one program on RHEL that might automatically change /etc/fstab entries.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No pause using std::in gdeward Programming 3 07-23-2006 04:02 PM
pause how to bruse Linux - Newbie 1 07-21-2005 02:58 AM
c++ pause or timeout true_atlantis Programming 2 10-04-2004 11:17 AM
Pause qcoder Programming 3 04-24-2004 03:53 PM
RH & HP4050N PCL - page, pause, page, pause, page andguent Linux - Hardware 0 11-10-2003 08:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration