Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-08-2006, 09:47 PM   #1
LQ Newbie
Registered: Jul 2006
Posts: 8

Rep: Reputation: 0
Floppy Mounting Issues in Red Hat 4

So I'm pretty much completely new to Linux, and I've been using Red Hat 4 with the GNOME GUI. I was transferring some information to a floppy (formatted for Windows) and everything was going well. There was a 'floppy' icon on the desktop that I'd been using to access the floppy disk, and I didn't have to mount it before I could use it or anything. Then, without thinking, I right-clicked on the icon and selected 'unmount'. Apparently, I was supposed to select 'Eject Device' or something instead. So then my pretty little floppy icon disappears and everything goes to hell.

I put the floppy back in the drive and right-clicked on the floppy icon in Computer. I selected Mount Volume, and I got an error saying 'You must specify a filesystem.'. So I thought bone this, I'm going to the console. I go to the console and type in;

mount -t msdos /dev/fd0 /media/floppy

Same error. I also tried 'auto' instead of 'msdos', because that's what it said next to /dev/fd0 in /etc/fstab. I also tried '/mnt' instead of '/media/floppy' (though '/media/floppy' was what was in /etc/fstab). I also tried '/mnt/floppy'. I also tried whacking myself repeatedly over the head with the keyboard.

Any ideas?
Old 10-09-2006, 12:09 AM   #2
Senior Member
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
First, stop whacking yourself in the head with the keyboard. You'll damage the keyboard!

I don't know about the rest of your problems, but the console command you gave was basically correct, with the following observations:
  • You might be fighting an automounter, with unknown (to me) consequences. If you want to use the console command, you might try figuring out which process the automounter is and killing it.
  • The form of the mount command you gave can only be done as root. My experience, however, is that if you try otherwise, it immediately tells you that.
  • Instead of msdos I would recommend vfat. As I understand it, msdos does not understand long file names and perhaps some other things.
  • auto should work if the system can determine the filesystem.
  • The -t option does specify the filesystem. The fact that it claims you still need to specify makes me wonder if there was a typo or missing space, or if this is the result of fighting with the automounter.
Another possibility if RH has it is the "mtools" such as mdir, mdel, mformat, and others which work similar to (but check their man pages for differences) their MS counterparts.

It is possible that your original misadventure (possibly through no fault of your own) screwed up the disk. You might try with a different floppy -- I'd use one that doesn't contain anything important until you figure out what is going on.

Good luck.
Old 10-09-2006, 03:07 AM   #3
LQ Newbie
Registered: Jul 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for your response!

Even though I did try the same thing with another floppy to see if the first one had corrupted, I think that both of them must have been corrupted. Because, at my wit's end, I tried a third... And miraculously it worked, and I was able to mount it.

So who knows.

Thanks again for your suggestions. =)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting USB floppy in Red Hat 9? LDZ420 Linux - Newbie 2 04-26-2004 11:32 AM
RED HAT 9 Floppy Help! Penguin-novice Linux - Hardware 1 10-10-2003 09:13 AM
install red hat 8 from a floppy book Linux - General 19 06-07-2003 04:38 PM
No Floppy in Red Hat Enigma Linux - Newbie 5 03-29-2002 12:11 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:52 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration