-   Linux - Newbie (
-   -   Fixing permissions for lamp on Ubuntu server (

jagrave 12-12-2010 11:03 PM

Fixing permissions for lamp on Ubuntu server
I've set up an Ubuntu Server that myself and two other friends are going to try and do some web development on. I've installed Lamp and such. Each of us have our own accounts, and I've put each of us in a group called devteam. I have also created a folder in the /var/www called development(/var/www/development). I want to create a symbolic link from that location to each of our home directories. Is that possible?
The main problem is that when one of us creates a file in the development directory, the group does not have write privileges. How can you make it where any new file within this directory automatically gives the group full access to the file or folders within the development directory?

Thanks for any help.

jasohl 12-13-2010 04:43 PM

First you need to make sure /var/www/development is assigned the devteam group and permissions are correct (rwx probably). Then use setgid on the directory. "Setting the setgid permission on a directory (chmod g+s) causes new files and subdirectories created within it to inherit its groupID, rather than the primary groupID of the user who created the file." (From this wiki article):

All times are GMT -5. The time now is 04:18 PM.