-   Linux - Newbie (
-   -   Fixing no sound from Intel 7/C210 HDAC running Squeeze 6.0.7 (

brianeray 04-28-2013 08:47 PM

Fixing no sound from Intel 7/C210 HDAC running Squeeze 6.0.7
If this post can help another newbie troubleshoot a "Why is my Debian Squeeze box not generating any sound from the onboard sound controller?", then cool beans.

Since installing Squeeze 6.0.7 on a bare metal workstation, I could get video (e.g., Flash) but no audio whatsoever from the motherboard speaker output. My cheapo speakers worked fine when connected to a Windows notebook. So, some info on my machine ...

The kernel:


# uname -r

The audio controller:


# lspci -v -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
        Subsystem: Biostar Microtech Int'l Corp Device 821e
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at f7210000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Root Complex Link
        Kernel driver in use: HDA Intel

I checked that various ALSA bits were installed and tried numerous other exotic troubleshooting steps at Nothing.

Finally in frustration I cranked up the volume on the speakers all the way and heard muted sounds from Youtube clips. Smacked my forehead, jumped into the Gnome Volume Control widget and maxed out the Master and Front volume levels, backed off the speaker volume, and sound output was normal.

Sometimes, you have to ensure there is gas in the tank.

Andy Alt 05-01-2013 09:38 AM

You can mark this thread as solved, up at the top, under "Thread Tools."

brianeray 05-01-2013 11:09 PM

Thanks Andy. I was looking for that at the time of the original post, but didn't think to try that menu. Now it's officially Solved.

All times are GMT -5. The time now is 01:09 PM.