-   Linux - Newbie (
-   -   Fixing Broken OS from Another Partition??? (

Sumguy 10-15-2013 08:20 AM

Fixing Broken OS from Another Partition???
Hey Everyone!

Inexperienced noob please...flashcards and finger-puppets [explain in simple terms and post specific terminal commands, if applicable].

O-K, I went to install Xmonad last night in Debian [I know... way over my head- just an experiment to satisfy curriosity. Debian is now my test-bed OS- I'm using Crunchbang as my primary]

I logged out and logged back in specifying the Xmonad as my DE/WM....but apparently it is broken. Had to do a hard-shutdown [press power button to turn 'puter off] and now, if I try and run Debian, it won't boot-up, because of the broken Xmonad; and I use auto login, so there is no way to specify another DE.

Can I disable auto login or otherwise fix the system in Debian from my Crunchbang partition? [I do know how to mount a partition].

goumba 10-15-2013 08:31 AM

In your Debian install, you should be able to access a vritual terminal by holding down Alt+Ctrl+Fn (try F1, F2, etc). From there log in and issue


sudo apt-get purge xmonad
Hopefully this will fix your problem.


If that doesn't work, try booting to single user mode. When GRUB comes up, highlight your entry for Debian and edit it (press 'e' if I remember correctly) and add 'single' to the line (or if still as a bad old habit, 'S').

Sumguy 10-15-2013 09:22 AM


Thanks for the suggestions. Unfortunately, the Cntrl+Alt+Fn didn't do anything....

And while I was able to get into the edit mode on GRUB, I don't quite know where to put "single".....

zhjim 10-15-2013 09:43 AM

single goes on the line that starts with linux.

Normaly you should have a grub entry that says recovery mode. If you know your root password you can boot into this and have a command line presented to you. Then go ahead as goumba said.

Sumguy 10-15-2013 09:59 AM

Yes, I had tried recovery mode- same thing- just a black screen with the "busy circle". I'll see if I can edit the GRUB line now. Thanks.

Sumguy 10-15-2013 10:27 AM


I tried the Cntrl+Alt+F1 again; and this time it worked! Removed the Xmonad, and VIOLA[sic]! I'm posting this from Debian.

Thanks to the both of you!

For future reference: When I was in the virtual terminal, after I removed the Xmonad, I typed "exit", and was taken back to a login prompt. Could figure out how to either start the system from there, or exit gracefully- so had to do the hard shutdown. What should I have done?

Sumguy 10-15-2013 11:34 AM

Lesson learned- I'm going to do a minimal Debian install in VirtualBox to use as a test-bed!

zhjim 10-15-2013 11:55 AM

Normaly ctrl-alt-del pushed all together should reboot the system. When logged in you can either use init 0 to shutdown init 6 to restart. Or use the shutdown or reboot command. Also this might vary per distribution. There sometime is poweroff as well.

Or if you just hit the power button once most systems also shutdown. This should be the case with any system with acpi tools installed and acpi beeing active.

Sumguy 10-15-2013 02:18 PM

Thanks, Zhjim! Why didn't I think of Cntrl+Alt+Del?! I tried "shutdown" and "poweroff"- didn't work. I think I might have needed to do "sudo ____"? I always feel like a failure when I have to hit the power button to turn it off! :D Just once I'd like to do it the proper way!

goumba 10-16-2013 02:28 PM

On Debian,


$ sudo halt
will completely shut down the system and


$ sudo reboot
will reboot. If you have kexec-tools installed, you'll get a faster reboot as it reloads the kernel and stuff without you having to go through POST, etc.

All times are GMT -5. The time now is 06:32 AM.