LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   First boot, text only (https://www.linuxquestions.org/questions/linux-newbie-8/first-boot-text-only-335336/)

thomasfingram 06-20-2005 02:50 AM

First boot, text only
 
Today I finished the first installation of Linux I've ever done. I installed Slackware 10.1 on an AMD K-6 450 with 128MB RAM. When I seemed to be done (it said I was), I rebooted by typing REBOOT. When my computer turned on, it scrolled through a ton of text before asking me to logon. The only logon credentials I have are the root, so I used that. Then it gave me a prompt that looked like this:
Code:

root@darkstar:~#
I really have no idea where this 'darkstar' came from or how to get to the gui. Btw I choose gnome, because I liked their website and screenshots better. Really I need this setup so that it loads the gui when the computer starts up and allows a user to login similarly to the way Windows XP does. How do I do this? I have no clue!

Also I didn't install LILO since this is the only operating system that will be on this computer. Thank you for your help in advance!

detpenguin 06-20-2005 02:54 AM

welcome to LQ.org!!!

at the root@darkstar:~#

type startx and it should take you into a window manager...probably KDE.

you can also type xwmconfig and choose from a list of window managers, and after clicking one, type startx and that one will open.

darkstar is the default name slackware gives when installed, if you don't supply one while you're installing it.

also, you might wanna check out the slackware site , especially the book part. lots of helpful info there.

slackware boots into text mode, and you log into a gui using startx. you can use gdm or kdm for a graphical login...the slack site or this site has lots of info on how to use it. i don't use the graphical login, so i can't help you there...

thomasfingram 06-20-2005 03:00 AM

Well in between the time I posted and got a reply, I tried to reboot. The BIOS is set to boot from cd-rom then hard drive. Well there is no cd in the drive so it went to the hard drive, but on the very next line it says
Code:

Error loading operating system
which is of course a problem. Aaack! How do I fix this?

detpenguin 06-20-2005 03:02 AM

you need to install LILO. it's the bootloader.
you can boot into slack using the install cd...once you're logged in, type liloconfig and it will bring up the screen to help you install LILO.

scuzzman 06-20-2005 06:19 AM

Also, you need to create an underpriviledged user and stop running as root.

thomasfingram 06-20-2005 10:18 AM

I have some questions:
Why can't I just use a boot.ini file to point to the installation? Seems like that would be the simplest thing to do...
Why do I even need a bootloader? I am only running Linux on here.
Why did the Slackware setup give me three choices for installing a bootloader? One of these choices was to not install a bootloader (it said this was the safest choice, so I choose that).
I know I need to make limited user accounts. I was going to do that as soon as I got to the gui. I have no idea how to do hardly anything from the command prompt. Like I said earlier, I have less then 24 hours experience with Linux. Thank you guys for your help; I really appreciate everything!

thomasfingram 06-20-2005 10:22 AM

Also I tried booting from the cd again and using liloconfig; is said
Code:

liloconfing: No such file or directory
What's up with that?

titanium_geek 06-20-2005 11:16 AM

the boot loader- it isn't just for loading multiple operating systems. (I'm a mandraker, so I'm not sure why slack would offer you the option of no bootloader)

useradd is the command to create users from the commandline.

titanium_geek


All times are GMT -5. The time now is 03:28 PM.