LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-08-2013, 04:39 PM   #1
gralloy
LQ Newbie
 
Registered: Feb 2013
Posts: 4

Rep: Reputation: Disabled
Firewall activation in Linux mint 14


Can anyone tell me how to activate the firewall in Linux Mint 14 please? Tried Firestarter site but web address no longer valid. New to Linux.

Last edited by gralloy; 02-08-2013 at 04:41 PM.
 
Old 02-08-2013, 06:04 PM   #2
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
Code:
sudo ufw enable
 
Old 02-08-2013, 08:10 PM   #3
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,315

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
http://www.fs-security.com/ is the Firestarter URL; it still seems to work for me.

Firestarter should be in the Mint repositories (Synaptic Package Manager or Software Center); it is for v. 13.

Note that Firestarter is just a front-end for configuring the firewall, but it is a very user-friendly one. Once the firewall is configured, you don't have to run Firestarter for the firewall to be in effect.

The firewall itself is managed by the kernel through a function called iptables.
 
Old 02-10-2013, 02:33 AM   #4
gralloy
LQ Newbie
 
Registered: Feb 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Linux Firewall

Many thanks frankbell for your very prompt response. Managed to get it working but a couple of points if you can help further, it would be appreciated:-
1) When I start the application, a screen appears showing that the firewall status is active but alongside that is another screen stating "Failed to open the system log"

2) Is there a way to ensure that the firewall is always active? When I close the computer down and re-start, I have to manually re-start the firewall.

Apologies if this seems rather banal. Brought up on Windows, now win 7, and I've heard some good reports on Linux, so thought I would give it a go by trying it out on a spare laptop.

One other point if I may - does one need anti-virus and if so, which one.
 
Old 02-10-2013, 08:38 PM   #5
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,315

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
Two questions: when you say "firewall program," what precisely is the program you are referring to and under what username are you starting it?

If you start the program from a command line, it might throw some helpful messages to the terminal. In Mint 13, the command would be sudo gufw.

I found an article about firewalls and Mint 13. I don't have 14 installed, but it might help. I suspect that it hasn't changed much. http://www.xjonquilx.net/2012/06/beg...t-13-maya.html
 
Old 02-11-2013, 02:03 AM   #6
gralloy
LQ Newbie
 
Registered: Feb 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thanks again frankbell. Programme I was using was Firestarter. Uninstalled that and have now configured the Linux 14 packaged firewall and using the pre-confugured options it seems to be functioning. The only issue now is that when I switch off and re-start the machine, I have to sign-in to the firewall again and then run it minimised in the system tray.
 
Old 02-11-2013, 08:46 PM   #7
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,315

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
When you start the firewall program, does it show the firewall as "On"? If so, you don't need to run that little GUI, minimized or otherwise. The firewall should already be on. This is because, unlike in Windows, the iptables firewall is part of Linux, not an add-on that has to be overlayed on the OS.

This article from Ubuntu goes more deeply into how ufw works as well includes some quick ways to check from the command line that it is on:

https://help.ubuntu.com/community/Ip...tables_Options

Last edited by frankbell; 02-11-2013 at 08:48 PM.
 
Old 02-15-2013, 05:57 AM   #8
gralloy
LQ Newbie
 
Registered: Feb 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thanks for the responses and help. Takes a bit of time to get used to the differences between windows and Linux. Slowly getting there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there a substantial difference between Linux Mint Ubuntu and Linux Mint Debian? schachwizard Linux Mint 4 10-09-2010 11:27 PM
Newbie with Mint/ Linux needs to install Clam AV in Mint after 4 Wdws Trogan attack BAKEAPPLEFARM Linux Mint 6 03-24-2010 08:38 PM
Newbie with Mint/ Linux would like to iinstall WINE on Mint so found no help for this BAKEAPPLEFARM Linux Mint 4 05-08-2009 08:33 AM


All times are GMT -5. The time now is 03:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration