-   Linux - Newbie (
-   -   Firefox Plugin Help - Can't Get Mplayer Plugin into Firefox (

Ingla 02-07-2006 02:16 PM

Firefox Plugin Help - Can't Get Mplayer Plugin into Firefox

I'm running Ubuntu 5.10 and have been having no end of trouble with streams.

I went to about: plugins in Firefox and saw that gxine was the main plugin. However, it can't play almost anything...messages such as "no demuxer..", etc. So I renamed the file. Now Firefox shows no plugins except the following:

================================================== =
Shockwave Flash
Default Plugin
Helix DNA Plugin: RealPlayer G2 Plug-In Compatible
Adobe Reader 7.0
Java(TM) Plug-in 1.5.0_05-b05
================================================== ==
All are enabled except the Default Plugin.

I used Automatix to install Mplayer "with the plugins". I later noticed in Synaptic that mplayer plugins showed as not installed. So, I installed them "again". (Synaptic currently lists no mplayer plugins...installed or otherwise).

Searching the filesystem, I found that exists in:

================================================== ==
================================================== ==

mplayerplug-in.xpt is found in:

================================================== ==


It is also in:


where I copied it because some plugin how-to said it should be in components.
For some reason, this last location is not found by Search for Files...but it's there and it appears in File Browser (I wonder what else Search is failing to report). Maybe Firefox can't see it for the same reason (whatever that is). I did the copying as root because of the directory permissions.

================================================== =
/usr/lib/mozilla does not contain a directory called "components".
Neither does /usr/lib/firefox or /usr/lib/netscape.

I have closed and re-opened Firefox and even shut down the computer. No Mplayer plugins appear in Firefox (about: plugins).

I've been trying hard to get the multimedia situation fixed in Ubuntu, but this is really getting baffling. I checked out a Realplayer clip and that plugin worked fine. But I can't see or hear any other kinds of streams.

Maybe I'm wrong, but I figured Mplayer would be a logical first attempt.

Can anyone help get the plugin working?

Many thanks.

satinet 02-07-2006 02:31 PM

please google for the unoffical ubuntu guide. should answer your questions...

m_yates 02-07-2006 02:56 PM

The easiest way to do this is using automatix:

sudo dpkg -i automatix_5.3-3_i386.deb

You will find automatix in the Applications>System Tools menu in gnome. Make sure you aren't running synaptic when you open automatix. You can select check boxes to install mplayer plugin and codecs, flash plugin, the latest firefox 1.5, the latest openoffice 2.0.1, and a host of other useful stuff.

Automatix modifies your /etc/apt/sources.list file with needed repositories and then installs applications using apt.

P.S. Step by step guide here:

Ingla 02-07-2006 03:44 PM


Unfortunately, the Guide just tells you how to install doesn't go into fixing problems.

Any other ideas most welcome.

Thanks very much.

m_yates 02-07-2006 04:11 PM

I should have read your post more carefully. I see you did use automatix. It is strange because I have Ubuntu breezy and used automatix and everything works as expected. I need not need to manually edit the plugin directory or copy the plugin to any new directory. Perhaps you could try purging firefox and the mplayer plugin (dpkg -P mozilla-firefox mozilla-mplayer). You can then try re-installing using automatix. By the way, did you use the latest version of automatix? I am trying to think of what could be different between your installation and mine.

Ingla 02-07-2006 04:25 PM


Yes, I think it's the latest Automatix. I just got it a few days ago.

Meanwhile, I completely removed mplayer with Synaptic and used Automatix to install it again. Same result...the plugins don't appear in Firefox.

I'm stumped.

I downloaded an rpm for the mplayer plugins and used alien to make a deb. However, apt-get couldn't install it, saying "conflicting packages".

Maybe I should completely remove mplayer again and install it from Synaptic instead of Automatix...and then try to install the deb again.

There has to be a solution for this.

Open to any suggestions.


Ingla 02-07-2006 05:01 PM

I just uninstalled mplayer and mplayer fonts using Synaptic. Then installed the plugins with the deb file. No good. The plugins still don't appear in Firefox.

So-o-o, the problem doesn't appear to be with Automatix.

Anyone know whether I can do something in Firefox (about: config?) to make it see the plugins? Probably not.

I had used Automatix to install Firefox 1.5. Maybe it needs the plugins to be in a different directory. I don't know why there are so many.../usr/lib/mozilla, firefox, mozilla-firefox, netscape. Firefox does weird things like that. But, maybe this has been compunded by upgrading to might have left older directories in addition to creating new ones.

I had a similar problem with bookmarks.html. I copied my existing one and replaced the default in profile. Firefox couldn't read it. I had to tell it to import from itself. Apparently it's reading from one of those other directories. Search for Files only found one. This happened with Firefox under Windows also. Firefox had three or four bookmarks.html's in different places after installation, and it was trial and error to find out which one it was reading.

Thus, this maybe be a Firefox thing rather than Ubuntu.

I did find in /netscape/pluginssomething all the plugins that do appear in Firefox, but copying the plugins to there didn't work either.

If anyone is successfully using streaming under Firefox 1.5, maybe you could find out where the working plugins are? (about: plugins gives a file name but no mentioned, Search didn't find one I knew was there).

All help welcome.


craigevil 02-08-2006 12:58 AM

Try looking in /usr/lib/mozilla/plugins/

All the Mplayer plugins on my system.

Ingla 02-08-2006 01:47 AM

Thanks. I'll look there.

Can you also tell me where your system has
mplayerplug-in.xpt? It seems that one is also required.

That's the one some how-to documentation
said belongs in a "Components" directory (it was referring specifically to Ubuntu, but I don't know what verion). That directory doesn't exist on my system in the place referred to (i.e., in the parent directory mentioned). I did see the xpt file in a couple of "plugins" subdirectories.

Thanks a lot.

lilili 02-08-2006 12:37 PM

I have the same problem with you
Gxine keeps on showing up eventhough I want mplayer to play the streaming.
It seems that we have mpplayer files at the same place.
I've tried removing or something like that from mozilla pluggins lib but still no luck.
May be after removing *.so, we need to do /sbin/ldconfig and restart the system

m_yates 02-08-2006 03:14 PM

Here is what I have in /usr/lib/mozilla-firefox/plugins/:

flashplayer.xpt      mplayerplug-in-qt.xpt  mplayerplug-in-wmp.xpt  mplayerplug-in.xpt  mplayerplug-in-rm.xpt

My mplayer plug in works fine. I did, however, have to manually delete totem plugins from the above directory before mplayer would work. Otherwise, the default setup with Ubuntu would cause totem to be selected instead of mplayer.

Ingla 02-08-2006 04:15 PM


Guess what! I have pretty good streaming on all kinds of formats. Here's the story, in the hope that anyone with difficulties in this area can benefit.

First of all, I did get the mplayer plugins into Firefox. I did a search for some plugin files that appeared in about: plugins, and found out that Firefox 1.5 was reading from /opt/... not /usr/. So, I put into "plugins" and mplayerplug-in.xpt into "components" Firefox and voila.

Unfortunately, I still couldn't see or hear many streams. IMO, mplayer just isn't any good. It just hangs on everything until you xkill it. I had had this problem in my previous installation and had manually entered mrl's in other media programs.

Also, Firefox tried opening video streams in gxine, which could play only the audio part.

Still searching, I found quite a good solution. The problem seems to lie with Firefox. I installed the MediaPlayerConnectivity Extension, available at: .

It runs a configuration wizard on Firefox startup after it's installed. I let it do its thing without changing defaults. Still had problems. It wanted to use mplayer for Windows Media Player files...but we've already mentioned mplayer's behavior. Also, it replaced realplay as the default for Real Player files.

So, one goes (in Firefox) to Tools>Extensions>MediaPlayerConnectivity. At the bottom of the window, hit Preferences. This brings up the extension's config. There you select which player it should use for various file types. Browse to /usr/bin/ and they're all there (if you have them installed). Try opening various streams until you've found the player that works and bingo. This works so, if you're having problems, keep playing with the extension's not hard.

Warning: It opens things kind of slowly and you have to click its little icon to make it play the stream. Then it brings up your player...if nothing seems to be happening, wait a minute.

I have it set for "Smart Play" which looks for alternative addresses for the stream and lets you pick one. They don't all work. You might get an error notice like "Missing Component". Just try another address.

That's it. I think the extension is great. Streaming is not as quick and straightforward as it is under Windows but, for me, it's good enough not to send me back there. It's a great step forward for Firefox.

All's well that ends well. Thanks, everyone, for all the help.

m_yates 02-08-2006 04:36 PM

Glad to hear it worked. Strange though....I don't have any problems with mplayer. In addition, after reading your post, I tried installing the mediaplayerconnectivity extension. After installing the extension, I tried playing a quicktime movie trailer and it tried opening in an external window and mplayer froze. I had to x-kill mplayer. I uninstalled the mediaplayerconnectivity extension and opened the same quicktime trailer. It played in the web browser as designed and mplayer didn't freeze. My problem seems to be the exact opposite of yours. :confused:

All times are GMT -5. The time now is 09:04 PM.