LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Firefox installation problems (https://www.linuxquestions.org/questions/linux-newbie-8/firefox-installation-problems-293293/)

Francis 02-22-2005 02:25 AM

Firefox installation problems
 
Hello eveyone, can somebody please save me from tearing my hair out, I'm too young to go bald.

After battling with my computer to install redhat (I think) and get my modem running (complete peice of faulty rubbish CNet external modem) I thought I'd be able to relax and browse the internet. I was wrong, Konkueror was aweful so I decided to download Firefox. I followed the instructions (who's I can't remember) and detared the tarball (sorry I don't know the lingo). I then went into the firefox installer directory and tried to run the installer (all through the shell BTW) but got a message saying that some libgtk-x11-2.0.so.0 library couldn't be found.

It seems that I need this specific library to install firefox, where do I get it and how do I install it?

Sorry I can't quote the shell, I can't copy and paste off it, I can't sit the shell ontop of my browser to rewrite it because my browser just covers it up as soon as I click back on my browser, I can't even line my shell up next to my browser because if I resize my shell window, it cuts off half the message, resizig it back to the normal size, doesn't reveal the text, it's gone missing permemanantly. Maybe I need to get out my camera (not digital thank God) and take a photo of the screen or something?! Maybe Windows isn't that bad after all? Sorry about the rant, I find KDE to be incredibly basic and frustrating (sometimes impossible) to use.

Anyway, can anyone explain what this library thing is that I need, how I get it and how I install it?

Any help would be greatly appreciated [bursts into tears]

P.S. sorry to diss Linux [bursts into more tears]

IBall 02-22-2005 02:33 AM

If you installed RedHat, did you install Gnome ? The gtk library should be part of gnome. If you didn't install gnome, it would be worthwhile to do so and it should be on your installation cds. You may also find gnome more to your taste than KDE.

Once you have installed gnome, try running the installer again. Make sure you are su'ed to root so that you can install firefox to a global location such as /usr/local. Simply type "su" and then enter roots password when prompted.

To "quote from the shell" simply highlight the required text with your mouse, change into the browser and click with the middle button (wheel) where you want to paste. Note that this works with most other apps as well.

ZaphyR 02-22-2005 07:10 AM

you can always search for missing dependencies here: http://rpm.pbone.net/
and then install whatever needed. I dont think you have to install entire Gnome just for this.

also....why would you want to install firefox globally, as IBall suggests? I would rather install it directly to /home, as this is very easy when using the firefox installer...

mAineAc 02-22-2005 07:23 AM

to cut and paste with Linux from the console all you have to do is highlight the text then middle click your mouse where you want to paste it. If you only have a two button mouse then clicking both buttons at once works the same as middle click.

IBall 02-22-2005 08:06 PM

Quote:

Originally posted by ZaphyR
also....why would you want to install firefox globally, as IBall suggests? I would rather install it directly to /home, as this is very easy when using the firefox installer...
I find that it keeps things organised. If you install programs to /usr/local or /opt, then they are all in the same place. If you add a symbolic link to the executable in /usr/bin, then the program will be able to be executed by all users on the machine.

When you complie programs from source, they (normally) install to /usr/local, with config in /etc and a link executable in /usr/bin. RPM packages also install globally.

So, in short, install globally for consistency

--Ian

Francis 02-23-2005 12:33 AM

Um, I don't really want to install gnome unless I have to, I've tried gnome before and found it to be little different from KDE. I looked on my installation CDs and couldn't find anything called libgtk-X11-2.0.so :confused:

IBall 02-23-2005 01:57 AM

Try downloading the pre-compiled version here
I think. You might have better luck with that rather than the installer.

Have you tried the mozilla suite. It should already be installed. If all else fails, perhaps you could try customising konqueror, as I believe it is actually quite a good browser that loads pages faster than gecko based browsers such as firefox.

I hope this helps
--Ian

ZaphyR 02-23-2005 04:02 AM

Quote:

So, in short, install globally for consistency
well, i guess it is all about taste, i install everything in /home/programs for consistency. :)

Francis 02-23-2005 11:20 PM

OK I've downloaded the precompiled version of Firefox and I extracted it to /opt/firefox/. I have some pretty looking files, but firefox doesn't run?

ZaphyR 02-24-2005 02:50 AM

have you tried typing /opt/firefox/firefox in console?

if Firefox starts when doing the above, then try to create a symlink to the firefox exe file:

cd to /usr/bin/
write this in the console:
ln -s /opt/firefox/firefox .

and then try to start firefox again from the console by typing

firefox

or

/usr/bin/firefox

mjjzf 02-24-2005 03:03 AM

I keep the Firefox installation in /opt/ because my wife sometimes uses my PC, too. It is not very clever to put an installation in your own folder, if several users are going to access the programs. On the other hand, there is an issue sometimes with file permissions. Bookmarks is not a problem, as they are stored per-user, but for the search plugins to be changed, you have to run Firefox as root. But then again, that keeps guests from fscking with my plugins... ;)

Francis 02-24-2005 10:33 PM

[root@localhost firefox]# ./firefox
./firefox-bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot load shared object file: No such file or directory
[root@localhost firefox]#

:confused:

I think I need libgtk-X11-2.0.so.0, where do I get this? Is it part of a package? Where would I get such a package?

Francis 02-24-2005 11:37 PM

OK, so I've decided that maybe installing gnome would be the easiest way to get this whole thing working, but I don't know how. I used RPM to look at the gnome-core library and it said that the gnome-libs library was required, I used RPM to instal it, but it was already installed so I then went to install the gnome core library and got a couple of dependancies, I tried installing one of the libraries that the gnome core library required but got a whole load of dependancies. I'm guessing that this isn't the way people normally install software? Is there some installer program that works this kind of stuff out and installs everthing? I believe I've stumbled upon "dependancy hell" ?

chris318 02-24-2005 11:44 PM

Option 1: Welcome to the rpm package managment system. Annoying as hell isn't it. You don't need the full gnome just the gtk2 libs and some others. First install GTK2 and start up mozillia. it will tell you that it can't find libpng or some bs. So go get libpng and install. And so on and so forth until you finally can start mozillia. Wonderfull, system don't you think.

Option 2: Put in a slack cd and install it over you Red Hat partitions and call it a day.

Its up to you.

chris318 02-24-2005 11:51 PM

Oh what a minute, I forgot rpm what even let you install a package without it's dependencies installed first. What a piece of sh$^@!. Good Luck bro. you are going to need it. Man I wouldn't want to be you. It make take you a long long long time to work through it all.

With slack it's no prob. You could just install sh*%() all day long. Some think the package management system is to simple in slack but I think it's great. If you are really in a jam and don't know what depends on what just go ahead and install the package and then run it and it will tell you what libs it needs.


All times are GMT -5. The time now is 10:01 PM.