-   Linux - Newbie (
-   -   firefox/flash player (

javb 06-14-2005 10:45 PM

firefox/flash player
i have installed kanotix, and im using the firefox that comes with it, downloaded from the repositories, so i want to play flash movies from the web, i need the correct plugin. i downloaded from the web, i tryied to put it in the correct directory.. as i use to do when i used to download the firefox instead of using the installed one.

is anyone out there who has done this before and can help me pleasE? what to do.. why doesnt it work?

other thing, i considered to download the official one from firefox, and i did. but it comes with i kind of wizard (the wizard used to work on SuSe with no problem), i tried to ope it, doing double click, did nothing, i did it from console, and it gave a kind of error with shared gtk libraries, please, some information to give me about this, i will appreciate.


tuxrules 06-14-2005 10:50 PM

what exactly did you do???

Post the steps you did to install using CLI...AFAIK installing flash-player is pretty straightforward. Also post the errors you got.


Edit: I believe firefox depends on gtk-libraries...not sure which one.

javb 06-14-2005 11:38 PM

1- downloaded the file .tar from macromedia.

2. unziped it.

3. Read the readme file. (i sais i had to put to files in the plugin directory from firefox directory, as i have this installed i didnt know where was it, so i did "find / -name firefox
" to see where this filder may be.

4. i got this :

5. i put the file in the plugin folder, from all of them.. just to make sure. :p

6. nothing, my plugin just didnt work, so i decided do downloaded the official version from Debian, and the problem with gtk came.. this is the error:
./firefox-installer-bin: error while loading shared libraries: cannot open shared object file: No such file or directory
dont know what to do, would like to fix the installed version, and to make gtk wizards to work too.. who knows in future ill need it. x


craigevil 06-14-2005 11:47 PM

Either use Synaptic or apt-get install flashplugin-nonfree and you will be all set.

Or you can :
Installing Flash Plugin
1. Download Flash Player via,
2. untar the archive
3. `cd install_flash_player_x_linux`
4. `su`
5. Copy "" and "flashplayer.xpt" to the plugins directory at "/usr/lib/firefox/plugins"
6. Restart your web browser


zickner 06-15-2005 12:42 AM


in addition you can checkk if the plugin was 'accepted' by firefox: type "about:plugins" as url and see if flash is in there,


axobeauvi 06-15-2005 09:46 AM

did you put the files in /usr/lib/browser-plugins/ ?

javb 06-15-2005 01:37 PM

the thing is that i hav 64 bits platform, and the installer is not supported, so i have to use" the coping the file manually" process, i have copied them in this, i did ls -la, and this is what i have.
ls -la /usr/lib/mozilla-firefox/plugins

-rwxrwxrwx 1 root root 856 Jun 15 14:20 flashplayer.xpt
-rwxrwxrwx 2 root root 2096844 Jun 15 14:20
lrwxrwxrwx 1 root root 39 Jun 9 17:11 -> /etc/alternatives/

java came installed, and apt-get does not have flash installer on the repositories for debian sid. (kanotix 64)

mmmm doesnt work.

(other thing, an idea of why the installer doesnt work? the gtk problem i mentioned in the threaa?

craigevil 06-15-2005 02:04 PM

Search the Debian package list for GPL Flash , there is a 64bit version.

javb 06-15-2005 05:45 PM

no way, it just doesnt WORK!

what about the problem using the wizard to install the official one from ? ?

the error when i try the wizard is:

./firefox-installer-bin: error while loading shared libraries: cannot open shared object file: No such file or directory

---- if i get this installed, i mean, working, i can EASYLY get my flash plugin working with no problem..

edong23 06-16-2005 12:19 AM

that error is pretty self explanitory. you need libgtk. if you are using some form of debian (which is what i gather, then apt-get it, however you do that. :) ) but if you cant figure that out download the source from

and install it. libgtk is a part of gtk. you will likely run into a few more of these if you get that one fixed. same thing though.

javb 06-16-2005 09:29 AM

incredible, but it still doesnt work, i downloaded everything from gtk page, i compiled it, i installed it, i did everything, but still giving me the same error.. i was looking on forums about this problem, and have done other things too..

damn... why is just so hard to start the the simple wizard in other istribution and here not?

(MY FIRST Disilusion of KANOTIx :P)

the error: --> ./firefox-installer-bin: error while loading shared libraries: cannot open shared object file: No such file or directory

mrcheeks 06-16-2005 09:51 AM

Install gtk2 with apt-get, why don't you use apt-get or synaptic?????

edong23 06-17-2005 12:13 AM

hm, still didnt find it huh. try:

locate libgtk-x11
# and see what directory it got installed into. then edit /etc/ to include that directory, and
ldconfig # as root

try that then try the installer. or what he said i dont know though as i dont use debian. everything but it.

axobeauvi 06-17-2005 09:11 AM

so you don't have that file ?
see if it's another version or not in a normal lib dir
if it is another version try to make a symlink to the one you have

javb 06-17-2005 12:38 PM


it didnt work.. how come, isnt anybody out there with KANOTIX or UBUNTU that is trying to install firefox?


thanks people who have tried to help.

All times are GMT -5. The time now is 05:18 AM.