LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   firefox and internet just took a dump on me!! (https://www.linuxquestions.org/questions/linux-newbie-8/firefox-and-internet-just-took-a-dump-on-me-922108/)

Ted Nugent 01-04-2012 08:32 PM

firefox and internet just took a dump on me!!
 
O.K. does nobody on frigging "linuxquestions.com" have any ideas here besides "Josh" I appreciate any help - the only response I got was to type in some text between a vertical line- I don't have a vert. line on my keyboard- is this an industry known symbol or something?? I lost my frigging internet!!I need help- have time right now to try stuff!! The winning answer gets a cigar:
I was using the internet and somehow made the little search bar in the upper rt. hand corner disappear. After attempting to add it back via google search preferences page, not only did nothing happen but when I attempted to restart firefox, nobody home! I click on the firefox icon in the toolbar and it opens a tab on the bottom panel and I get the spinning timer thing for about 15 seconds and then nothing happens. the tab disappears and we are back to where we started- no internet, home page no nothing.
I am a major computer dork (as in I know next to nothing about them) and have tried unsuccessfully to bring firefox back (or to open anything to access the internet). I have spent hours dorking with the 'terminal' and have attempted to uninstall/reinstall firefox with 'synaptic package manager' and add/remove programs from the app. page.
I need help.
Ted

corp769 01-04-2012 08:52 PM

Hello,

In a terminal, run the following:
Code:

pkill firefox
ps aux | grep firefox

After running the ps command, note any instances of firefox running, if any. If there are, use kill -9 to make sure that firefox is completely not running. After you check that, run firefox from the terminal itself, and note of any warnings and errors, and post them here. If nothing happens as far as any messages, try running firefox in safe mode. Run "firefox --help" for the correct options on how to start it in safe mode.

Cheers,

Josh

Ted Nugent 01-04-2012 08:56 PM

what is the vertical line between "ps aux" and "grep firefox"?

chrism01 01-04-2012 10:58 PM

The vertical line '|' is known as the pipe symbol and exists on every keybd (I've ever seen).
However, it is a shift value ie its the upper symbol on a key with 2 symbols on it.
Depending on your location (actually your keybd make/model/type) it could be on one of several keys.
It'll be on the main key section (ie not the right hand side numeric keys block & not on the arrow keys or insert/home/page-up etc block; nor on the fn keys row at the top).
On my std US type keybd, its just above the Enter key; key has the '\' as main symbol & '|' as the shift option.

HTH

Ted Nugent 01-04-2012 11:06 PM

wow, thanks for the response, Chris!
I found what I think is the symbol- it looks like a frigging colon on my keyboard. I am attempting to enter text mentioned from Josh and will report back
thanks,
Ted

Ted Nugent 01-04-2012 11:08 PM

I just entered the grep thing from Josh and got a bunch of numbers with pts/0 and R+
what is this stuff?

Ted Nugent 01-04-2012 11:11 PM

update, after re-reading Josh's advice I tried entering just "firefox" on the terminal and got " Segmentation fault (core dumped)"
is this good?

chrism01 01-04-2012 11:11 PM

You need to post it here so we can tell you :)
Please post between code tags, as described here https://www.linuxquestions.org/quest...do=bbcode#code

Ted Nugent 01-04-2012 11:14 PM

Chris,
I read that link you gave me and dont know where to find "code"- in fact, I just keep refreshing this page to see if anyone has written back- you would think I am 12 years old=I am in computer years. Where do I post so you can see it? i.e.where is "here"?
Ted

nprezident 01-04-2012 11:17 PM

why don't you try to uninstall firefox and reinstall firefox or install google chrome to get the internet back working ...

chrism01 01-04-2012 11:19 PM

That page shows an example of how to paste between code tags; find this string "The [code] tag switches to a fixed-width (monospace) font and preserves all spacing." and follow the example

Ted Nugent 01-04-2012 11:20 PM

yo nprezident,
I did try to uninstall firefox but found my way to 'synaptic manager' and there are like 50 "firefox" programs listed. Linux is definitely for people who have a very good understanding of computers and mainly the language associated with them.

polpak 01-04-2012 11:37 PM

Note am NON-Technical using openSUSE 11.4 - noted you only recently joined so may be new to linux !

Admit Linux was frightening to self when new, soon realized is more stable than windows, as long as do the correct thing, stick to simple updates for a while. Not sure about the version you were using.



Self logged into terminal as root, which needed system administration password, saw similar results logged into terminal as ordinary user.

Different Linux versions may show different results, am showing results from my openSUSE 11.4 for pkill


CODE
Code:

linux-fy2u:~ # pkill --help
pkill: invalid option -- '-'
Usage: pkill [-SIGNAL] [-fvx] [-n|-o] [-P PPIDLIST] [-g PGRPLIST] [-s SIDLIST]
        [-u EUIDLIST] [-U UIDLIST] [-G GIDLIST] [-t TERMLIST] [PATTERN]



Josh advised how to force closure of all operating applications of firefox, then you may need open it again.


Josh's second instruction gives information about where firefox may still be working - you may see nowhere if all were force closed.

Firefox should open again if you tell it to.


Self did NOT try command Josh advised you to do, as do not wish close my working fine Firefox.




Terminal command ps aux shows a lot more results, using the | grep firefox filters results showing only results with firefox in them.


Code:

linux-fy2u:~ # ps aux | grep firefox
1003      7949  0.0  0.0  12832  1576 ?        S    14:27  0:00 /bin/sh /usr/bin/firefox
1003      7954  2.7  2.1 811052 168664 ?      Sl  14:27  2:47 /usr/lib64/firefox/firefox-bin
1003      8005 10.1  0.8 508644 66696 ?        Sl  14:27  10:14 /usr/lib64/firefox/plugin-container /usr/lib64/browser-plugins/libflashplayer.so -greomni /usr/lib64/firefox/omni.jar 7954 true plugin
root      8765  0.0  0.0  6608  572 pts/1    S+  16:08  0:00 grep firefox
linux-fy2u:~ #


polpak 01-04-2012 11:52 PM

These results for my openSUSE 11.4 the command uname -a showing others which linux version we use.

This helps them help you.


Code:

linux-fy2u:~ # uname -a
Linux linux-fy2u 2.6.37.6-0.9-desktop #1 SMP PREEMPT 2011-10-19 22:33:27 +0200 x86_64 x86_64 x86_64 GNU/Linux
linux-fy2u:~ #



Program software are prepared for each distribution/package/version of Linux, installing incorrect versions for your operating system likely to cause problems.

As Technical knowledge increases you soon may be able to format for your system software, then install so it works fine.

Self being Technically-Challenged leave it to the experts, everything I need is available prepared by them.

polpak 01-05-2012 12:49 AM

Ted appears to be using Ubuntu 7.1


Leave help now to our more ubuntu knowledgeable people here who will know best :-)




Information re Ted from https://answers.launchpad.net/ubuntu...uestion/183678

Quote:

ted nugent (popkapusta) said 4 hours ago: #19

terminal read:
No LSB modules are available.
Distributor ID:Ubuntu
Description: Ubuntu 7.10
Release: 7.1
Dodenme: gutsy


All times are GMT -5. The time now is 06:06 AM.