-   Linux - Newbie (
-   -   Finding driver from Mint to use in Arch (

stozi 03-07-2010 03:01 AM

Finding driver from Mint to use in Arch
I'm using the vesa video driver on Arch right now which gives me 1028x768 resolution. If I run the Mint LiveCD I get more like 1680x1050. My video chip is VIA VX700. lsmod on the liveCD gives one via-related result that lsmod on Arch doesn't, simply 'via.' since the via xorg driver in synaptic says it's a dummy to get you on the openchrome driver, I installed the same on Arch and did "hwd -xa" which is meant to autoconfig a new xorf.conf file for you. It stuck to vesa.

I previously tried 'xorg -configure' with openchrome, which it chose, but left a blank black screen.

Maybe Mint isn't using the openchrome driver. It doesn't seem to be using an xorg.conf at all and I can't find out how to see unequivocally what video driver it uses. I could well be barking up the totally wrong tree, anyway.

Thanks for any help, other than this one point I'm in OS heaven.

reed9 03-07-2010 08:38 AM

The Arch Wiki is your friend.

According to the that xf86-video-via is in the AUR. If the openchrome driver doesn't support your card, try that.

stozi 03-07-2010 03:02 PM

Makepkg was unable to build xf86-video-via-git package.
Thanks, I hadn't seen that wiki, but I had tried to install xf86-video-via-git with yaourt. At first I got an error necessitating I edit pkgbuild line "options=('nolibtool')" to "options=('!libtool')". Now I get this:

==> Install or build missing dependencies for xf86-video-via-git:
==> Building and installing package
mkdir: cannot create directory `/var/abs': Permission denied
==> WARNING: Unable to write in /var/abs/local/yaourtbuild/xf86-video-via-git directory. Using /tmp directory

==> xf86-video-via-git dependencies:
- unichrome-dri (already installed)
- libgl (already installed)
- pkgconfig (already installed)
- xorg-server (already installed)
- xf86driproto (already installed)
==> Making package: xf86-video-via-git 20070131-1 i686 (Sat Mar 6 05:09:35 PST 2010)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==> Extracting Sources...
==> Entering fakeroot environment...
==> Starting build()...
==> Connecting to GIT server....
/tmp/yaourt-tmp-lee/aur-xf86-video-via-git/xf86-video-via-git/./PKGBUILD: line 27: git: command not found
==> GIT checkout done or server timeout
==> Starting make...
cp: cannot stat `/tmp/yaourt-tmp-lee/aur-xf86-video-via-git/xf86-video-via-git/src/xf86-video-via': No such file or directory
/tmp/yaourt-tmp-lee/aur-xf86-video-via-git/xf86-video-via-git/./PKGBUILD: line 35: cd: /tmp/yaourt-tmp-lee/aur-xf86-video-via-git/xf86-video-via-git/src/xf86-video-via-build: No such file or directory
/tmp/yaourt-tmp-lee/aur-xf86-video-via-git/xf86-video-via-git/./PKGBUILD: line 37: ./ No such file or directory
/tmp/yaourt-tmp-lee/aur-xf86-video-via-git/xf86-video-via-git/./PKGBUILD: line 38: ./configure: No such file or directory
make: *** No targets specified and no makefile found. Stop.
==> ERROR: Build Failed.
Error: Makepkg was unable to build xf86-video-via-git package.
I also tried unistalling vesa, installing xf86-video-unichrome and running hwd -xa, but even with vesa unistalled it insists on it. The openchrome site (which seems the only of the 3 drivers offered by Mint) doesn't say it supports my chip, but the unichrome site does.

***Ok, Xorg -configure worked with unichrome, where hwd -xa did not. Wow, 1680x1050, someone pass the tissues.

reed9 03-07-2010 03:29 PM

Hmm. I can't find much of help here, beyond lots of people complaining that VIA support sucks. :)

It looks like xf86-video-via is actually deprecated and according to the openchrome wiki won't build with recent xorg releases.

Given that the unichrome site specifically mentions your card, that would seem to be the way to go. Have you tried running without an xorg.conf file at all? It's frequently not necessary. I would recommend trying that and if it gives you trouble, post the contents of /var/log/Xorg.0.log.

stozi 03-08-2010 12:31 AM

good idea
I am interested in trying that, but the link from the arch beginners' wiki seems broken/out of date. Now that I have an xorg.conf, must I delete it to run without? Not finding any hints in the Xorg wiki.

When I first started, following the beginners' wiki, it had me using an unsupported resolution, so a third of the desktop was off screen to the bottom right.

smeezekitty 03-08-2010 12:33 AM

Just use mv /etc/xorg.conf /etc/xorg_.old
Just reverse those to restore it.

All times are GMT -5. The time now is 06:12 AM.