LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Filesystem should be Writeable! Why isn't it? (https://www.linuxquestions.org/questions/linux-newbie-8/filesystem-should-be-writeable-why-isn%27t-it-131006/)

lectraplayer 01-02-2004 08:50 PM

Filesystem should be Writeable! Why isn't it?
 
I'm trying to get my FAT32 partitions writeable under Linux. I've been in my fstab several times in the past but never had this problem. However, even as root, when I change the permissions of the filesystem, something in Linux immediately changes it back (and a change note is immediately reflected). I have been playing in my fstab trying to fix this, and have come across several wierd behaviors, including my access point (/mnt/data to be specific) completely vanishing. What is doing this? Right now, I can read the filesystem on /mnt/data, but I cannot write to it. I'll post my /etc/fstab later if you guys want it.

darthtux 01-02-2004 09:04 PM

/etc/fstab should be something like

/dev/hd? /mnt/data vfat auto,owner,rw 1 2

make sure there is a rw and not only r in the current fstab

After you edit the file do
mount -a

lectraplayer 01-02-2004 09:24 PM

Here's my current fstab (with a few comments)

LABEL=/1 / ext3 defaults 1 1

none /dev/pts devpts gid=5,mode=620 0 0

LABEL=/home /home ext2 defaults 1 2

none /proc proc defaults 0 0

none /dev/shm tmpfs defaults 0 0

/dev/hda5 swap swap defaults 0 0

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0

/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

/dev/hda1 /mnt/win98 vfat
*Windows 98 home disk*
/dev/hda6 /mnt/winswap vfat
*Windows swap disk*
/dev/hda8 /mnt/oldlin ext2
*an old Linux partition*
/dev/hda7 /mnt/data vfat users 0 0
*my data partition, why not writeable?*

Adding an rw by where I have users causes my access point to vanish. That's what is actually driving me nutzo.:scratch:

scott_R 01-02-2004 09:27 PM

Yeah, the main idea is that fat32 retains whatever permissions it's mounted with. If you mount it with read only permission, then try to chmod a file, you'll get nowhere, even as root. If you mount it read-write, it's dangerous, but it'll work.

If you use your fat32 partitions a lot, you might want to create a user with rw permissions to that mount point, then add that user to whoever needs access. Another user can be set up with just read only permissions, but this is done from the linux side, not the mount/windows side, and can be a real pain to set up correctly.

darthtux 01-02-2004 09:30 PM

Try

/dev/hda1 /mnt/win98 vfat auto,owner,kudzu,rw 1 2

lectraplayer 01-03-2004 07:48 PM

I'll try that and see what happens. :D

Also, if I remember correctly now, I think Kudzu was the killer last time (causing me to lose the /mnt/data access point).

Tried it: /dev/hda7 does not mount in this case. When I mount it by hand, I, again, cannot write to it. The same thing happens all over.

If there was any doubt, I'm trying to make my data partition writeable. /dev/hda7. I have no reason to make /mnt/win98 writeable, as a matter of fact, I would rather that one be read only for now.

lectraplayer 01-27-2004 07:32 PM

Something I've noticed: Lately, RedHat 9 has started saying that FAT32 support is still in ALPHA, though I have never seen that until here lately. Could that have something to do with it? If so, where can I get updates for my FAT32 "engine"?

lectraplayer 02-03-2004 08:15 PM

nudge

megaspaz 02-03-2004 10:07 PM

if i remember correctly, even if you set the rw flag in fstab, that still won't work. i didn't for me anyway. what will work is setting the umask option in fstab. if you don't care about who has write permissions to your fat32 partition you can just use:

umask=0000

that will set the permissions of that partition when mounted to 777.

lectraplayer 02-04-2004 02:11 PM

Thanks! I'll try that. I am the only user here anyway. ...and I like your sig. I guess that explains why I don't get that many crapy ideas, I always fart. :p


All times are GMT -5. The time now is 05:27 PM.