LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Filesystem Repair (https://www.linuxquestions.org/questions/linux-newbie-8/filesystem-repair-336680/)

borisys 06-24-2005 02:48 AM

Filesystem Repair
 
Hi

I am new with linux and I recently had an unwanted shutdown
now when I tried to reboot linux red hat it gives me the following msg:

Your system appears to have shutdown uncleanly
Press y to integrate filesystems check
checking root filesystem

/: Inodes that were part of corrupted orphan linked list found.

/: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
(i.e., without -a or -p options)

*** An error occurred during the file system check.
*** Dropping you to a shell; the system will reboot
*** when you leave the shell.
Give root password for maintenance
(or type Control-D for normal startup):

so I entered the root password and then I type "fsck"
following by "reboot" but it does not solve the problem because it goes back to
"Your system appears to have shutdown uncleanly" and so on....

i do not really understand what is happing ...

and also, i try to get the disk status by command 'df -h'
all the drive disk size, disk used , avail & use % is same.

Mounted On
/dev/sda2 146G 5.3G 133G 4% /
/dev/sda1 146G 5.3G 133G 4% /boot

it is impossible.

Who can help me to solve the problem , the system have important data.

thank you for you help

best regards
boris

themo 06-24-2005 04:03 AM

Hi!

If you have an ext2 filesystem and your linux is on the first partition of your hard disk:
e2fsck /dev/hda1 (not fsck)

By ext3 filesystem...I think:e3fsck /dev/hda1

Hope I could help. I know 10 linux commands so I'm very newb to :D, but it soloved my problem when I had the same of your.

cheers.

dgar 06-24-2005 10:45 AM

fsck'ing hard drive
 
# Check ALL "Linux" partitions found in /etc/fstab

/sbin/fsck -CA

borisys 06-24-2005 10:24 PM

Hi all,

i already try follow yr method. but still not solve the problem.
have u any other method to solve the problem ?

best regards
boris


All times are GMT -5. The time now is 07:45 PM.