LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Files destroyed under Linpus Linux on Pendrive (https://www.linuxquestions.org/questions/linux-newbie-8/files-destroyed-under-linpus-linux-on-pendrive-765777/)

g0-Tt 10-31-2009 08:45 AM

Files destroyed under Linpus Linux on Pendrive
 
This Thread might be related somehow to this Thread, except there is nothing mentioned about sleep-mode.

i was just looking up the internet for a solution of that very problem, when i found this forum. the thing is that i have the same problem. i plugged in my pen-drive, did some work in the internet and finally wasn't able to find my data anymore. all there was are files and folders with names made of cryptical symbols and with insane storage-size (between a few mb till 2 gb). if i'd added the size of that files all together it would be the size of the pen-drive with a factor of let's say 10. so what i did was that i plugged it into my old windows xp desktop-computer and it showed the same data as linpus before. for the fact that both systems showed the same thing i thought it to be a failure of the pen-drive. some more thing to mention, the amount of cryptical files and folders weren't the same amount of my original files and folders.

so there is just nothing more to tell about this issue. i didnt used recovery and did put the pen-drive in a secure place since there are some important files on and i was hoping to find a solution in some months or so.

i bought a new pen-drive. downloaded a few files from the internet at university-pool (windows) went home and downloaded a few files (pdf) more that i needed in addition. the system of linpus went into sleep-mode after i did the same thing :-D. since the system worked fine in the last weeks all the differents there is, is the sleep-mode. i would say that this is the trigger-point. i woke up and most of my files were gone. again cryptical names, this time mixed with some names ot original files and folders, but both weren't accessable anymore. the pendrive is a different typ this time, therefore it's definitly no failure of those devices.

FILES INCLUDED IN THAT ISSUE:
exe, html, pdf, txt, dll, (all kind of files of many different portable-win-apps), jpg, mp3, bmp, just everything there is!!!
not the whole pendrive is been destroyed but all root-folders which i worked in during the session before the sleep-mode. that means if i work at a file in a subfolder of a rootfolder for example. all the files and subfolders (with their folders and files and so on) are gone be destroyed. even if i didnt even worked in that folder but since it has the same root folder as the folder i worked in: GONE.

thorkelljarl 10-31-2009 09:33 AM

Live-cd...

What happens when you try to boot a live-cd; anything readable?

g0-Tt 10-31-2009 10:47 AM

Ok, it seems like the folder-structur is damaged. There are 3 txt-files which weren't accessable under Windows and Linpus but under my Linux-Live-Cd they are. But 2 Folders are still damaged and therefore also their subfolders and some pdfs in it. They are shown red under "Midnight Commander" (DataManager) and left out under Zsh.

g0-Tt 10-31-2009 12:42 PM

is there a good solution for this?
do i have to use a recovery-program on this or would it work with testdisk or something else?

thorkelljarl 10-31-2009 07:14 PM

Don't know...

I don't know enough to recommend anything as I have never had the problem. As told by others, TestDisk may help you, or perhaps more likely, PhotoRec. It probably depends on what has been done to the data.

If you use that live-cd and the command "fdisk-l" with the pendrive attached, do you see your partition tables as you expect to see them? If not, then a restoration of the partitions with TestDisk might help.

It is also recommended that you use the command "dd" or a copy of Clonezilla to make an clone copy of the HDD or partitions that are at fault and of the pendrive, allowing yourself the chance of fumbling an attempted recovery without loosing the files.

You are probably not the only one who has had this problem with linpus, and you might try a linpus or pendrive help group if this thread doesn't draw a response from some one more knowing than I.

You might try to revise your post to be as explicit as possible in describing the problem, giving the sequence of actions and error messages when you try to mount the files.

http://www.cgsecurity.org/wiki/TestDisk

http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

http://www.cgsecurity.org/wiki/PhotoRec

http://www.cgsecurity.org/wiki/PhotoRec_Step_By_Step

You might also think about replacing linpus with one of the other netbook editions of linux. TestDisk and PhotoRec are on several rescue live-cds.

Do these pendrives by any chance have U3 on them?

Wim Sturkenboom 11-01-2009 01:22 AM

Just to confirm: you do eject/unmount your pendrives before pulling them out?

smeezekitty 11-01-2009 01:46 AM

What filesystem was the pendrive formatted as?

g0-Tt 11-01-2009 01:43 AM

yes i did unmount them (only from time to time i dont, but not when this problem occurred -> recognized data is damaged again, unmounted, tryed it at windows instead). the filesystem is fat32. i am gonna take a look for the partition tables, today.

edit: no it's not U3, its just a colletion of a few portable apps and some programs which dont need a registry-entry. the most important things on it are the pdf's and the bookmarks of my firefox.

g0-Tt 11-01-2009 07:41 AM

there are some other failures that might be related to this. when using the firefox 2.0 of linpus and watching a youtube music-video an error appears. acer aspire one goes into sleep-mode and after returning to work the sound of the video isnt there anymore. that means when i try to watch it again, i am only able to see the videos without sound. F5 doesn't work on this, i need to close firefox and start it again.

i just thought, since the pendrive is mounted under something like /dev/sdb1 and the video under /tmp there might me a link between those symptoms.

g0-Tt 11-01-2009 08:06 AM

ok i just checked on the partions. there is one with WIN95 FAT32 exactly like i should be.


All times are GMT -5. The time now is 12:06 PM.