-   Linux - Newbie (
-   -   File /var/adm/messages cannot be read. (

prathamesh7478 02-28-2013 12:19 PM

File /var/adm/messages cannot be read.
Hello Guys,

I am getting following messages from one of our Production Servers

Unusual System Events
File /var/adm/messages cannot be read.

Can you Help on this,that why i am getting this messages.

lrtward 02-28-2013 02:31 PM

Can you cat /var/adm/messages?
What are the ownership/permissions on /var/adm/messages?
Where are you seeing "File /var/adm/messages cannot be read."?

unSpawn 02-28-2013 02:32 PM


Originally Posted by prathamesh7478 (Post 4901777)
File /var/adm/messages cannot be read.

It could be checking the wrong location (like /var/log/ instead) or the logging / monitoring application hasn't got appropriate access rights, or the file was deleted, or an attempt was made to rotate the log but logrotate couldn't create the file anew because the file system was full already (as in your


Originally Posted by prathamesh7478 (Post 4901777)
why i am getting this messages.

Your first thread was about copying huge files (let me guess: to /var), your second one was about /var being full so now the reason "why" isn't interesting but why you haven't gone over there yet to fix things good. If you're an admin you should know what to do (else ask an admin) or else spill some serious information like what services the machine runs, what files are open in /var, where there's enough free space to move files to, current space usage in /var, stuff like that.

lrtward 02-28-2013 02:34 PM


Originally Posted by unSpawn (Post 4901862)
Your first thread was about copying huge files (let me guess: to /var), your second one was about /var being full ...

Ooohhh, good observation!

prathamesh7478 02-28-2013 03:06 PM

thanks irtward,

i canot cat the file it has a message.z exstention,and
i am getting this error through our mail from that particular server.

Habitual 02-28-2013 03:43 PM

Is /var a separate partition mount?

df -hT /var
You said "Production Servers" were having this issue...
all at the same time? or at once? That is curious.

Please let us know.


prathamesh7478 02-28-2013 05:11 PM

No its a particular production server
/dev/md/dsk/d1 2.0G 1.6G 389M 81% /var
Mounted on var directory.

chrism01 02-28-2013 07:12 PM


cd /var/adm
ls -lt messages*

This will show owners/perms and existing messages files.

Your messages.z can be read with zcat, unless its actually messages.Z, in which case use the uncompress cmd.
I'm guessing this is Solaris.

The error msg implies the old messages files has been rotated and the new one one not created or its been deleted or it cannot be created due to a full partition.
Can you run both du and df on that partition and post the results.
It may be a deleted file that is still being held open by a process.
Also run df -i to show the inodes usage.

PS if this has indeed already been solved, please post the soln, otherwise ask the Mods to undo the 'SOLVED' flag.

colucix 03-01-2013 07:38 AM

Moderator note: thread marked as unsolved, until the OP posts a solution (as requested). @prathamesh7478: as mentioned this thread is strictly related to the other one you started. Please, drive the discussion in only one place (here) to avoid confusion and to add information that can be useful to solve your issue(s). Thank you in advance.

linosaurusroot 03-01-2013 09:11 AM

/var/adm/ is normal on Solaris but /var/log/ is normal on Linux. Is this message coming from software developed for Solaris?

prathamesh7478 03-01-2013 12:51 PM

Hello Guys,thanks for your inputs.

The issue is resolved when we found out the messages file was compress
by some one so its extension had change messages.z.So the process using it could not find it.I just created a normal file messages and the issue was solved the alerts stopped automatically.

All times are GMT -5. The time now is 07:04 PM.