-   Linux - Newbie (
-   -   file system error during booting (

uttamsaxena 07-22-2001 06:30 AM

file system error during booting
I use Red hat Linux. One day I had to restart my system due to hang up. after that when ever I boot in Linux following text appers:

checking root file system
/dev/hda5 contains a file system error, check forced
unattached inode 5628

/dev/hda5: unexpected inconsistency; Run fsck Manually
( i.e., without -a or -p options)

*** An error occured during the file system check.
*** Dropping you to a shell; the system will reboot
*** when you leave the shell

Give root password for maintenance
(or type control-D for normal startup):

On typing Control-D above thing repeat again but on giving the root password, following line appears. I do not no what to do thereafter.Please help.

(Repair filesystem) 1 #

Thomas_Delrue 07-22-2001 07:24 AM

I had this one also (and very often)

if you do not unmount your file-systems before you turn off you box or reboot it, you get this error... It simpley says that it has found 'inconsistancies'...

Indeed enter the root-password and when the prompt ("(file system repair step X#)") appears, all you need to do is enter "fsck /dev/hda5 -p" (NOTE the -p; this will answer all confirmation questions with YES ALSO NOTE that you execute fsck on hda5 - or whatever device is giving you the error)

It will give some output (the last one should be something like '0.0% INCONSISTANCY' or whatever) and when you are finishes, just enter 'reboot'...

That should solve your problem... (well, it solves mine)

Heyhey, look at this: a newbie helping a newbie! (man I feel good)

uttamsaxena 07-22-2001 12:19 PM

Thanks Thomas
That solved my problem.

Thomas_Delrue 07-22-2001 12:22 PM

be nice
So, next time you toy around in Linux, be nice and shutDown using the proper commands,... (hihihi);)

BBoy_no_01 12-24-2005 02:09 PM

Doesn't work fore me....:(
I have Slackware 10.1 and the same problem...but i dont't have a root i press enter and the system reboots.Any advice?
PS:Ctrl+d aloso reboots!

Linux4Dummies 01-07-2006 04:26 PM

How do you find out what number the hda is? I think mine's hda6, but I can't really remember.

gilead 01-07-2006 04:33 PM

Try running:


fdisk -l /dev/hda

Linux4Dummies 01-21-2006 09:35 PM

Right, so running fsck and pressing y repeatedly helped my brother's computer. But then I ran an update for my own laptop.... so many errors... they won't stop... it won't boot... screw FC4. I've lost all faith in my repositories, and there are more reliable versions out there. Bah.

All times are GMT -5. The time now is 01:41 PM.