LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-07-2005, 08:31 AM   #1
Enoon
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Rep: Reputation: 0
file permissons on fat32 disk - won't change


Hi I'm currently trying to get filepermissions to write on my fat32 disk as a regular user. Using suse 9.3, I tried editing this in the root-konqueror but it never saved the changes I made. I tried doing it in teh commandline as su with the command chmod o+w *dir* and chmod 777 *dir* but that didn't wokr either.
The permissions it has atm are

drwxr-xr-x

The partitions are mounted under fstab just as auto - no other options.
Eventually I want to recursively get all files on those hds to be write as well as read. I'm wondering do I need to add other options in fstab to make it possible for any user to write on these files? or am I doing something wrong with the chmod? fat32 does allow suse9.3 to write on it - right?? I know mandriva had no problems with it.

thanks for any help
 
Old 10-07-2005, 08:53 AM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,579

Rep: Reputation: 220Reputation: 220Reputation: 220
Read/write permissions on a FAT32 partition are set by editing /etc/fstab, not by changing mountpoint permissions. If you could post that file and indicate which partition you want changed, I can show you how to make the edit. Basically, the line in fstab for the partition should look something like this:

/dev/hd** <mount point> umask=0,codepage=850,iocharset=iso8859-1 0 0

where hd** corresponds to the partition you want to change. The important part is "umask=0".
 
Old 10-07-2005, 11:26 AM   #3
Enoon
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
ok this is my fstab:

/dev/sda7 / ext3 acl,user_xattr 1 1
/dev/hdb6 /mnt/leftbrain vfat auto 0 0
/dev/hdb5 /mnt/rightbrain vfat auto 0 0
/dev/sda6 /mnt/thepineal vfat auto 0 0

/dev/sda5 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvdrecorder /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0


I need all the vfat partitions to be read and write for all users and automatically mounted - do I leave auto as an option there then? to reduce firther problems with this, could you explain the options I will need to put in there?
thanks for your help!
 
Old 10-07-2005, 11:48 AM   #4
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 264

Rep: Reputation: 30
Offtopic I know, but nice naming conventions!
 
Old 10-07-2005, 12:35 PM   #5
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
try putting the "showexec" option in. That fstab is kinda weird.
 
Old 10-07-2005, 01:03 PM   #6
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
Quote:
Originally posted by Enoon
ok this is my fstab:

/dev/sda7 / ext3 acl,user_xattr 1 1
/dev/hdb6 /mnt/leftbrain vfat auto 0 0
/dev/hdb5 /mnt/rightbrain vfat auto 0 0
/dev/sda6 /mnt/thepineal vfat auto 0 0

/dev/sda5 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvdrecorder /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0


I need all the vfat partitions to be read and write for all users and automatically mounted - do I leave auto as an option there then? to reduce firther problems with this, could you explain the options I will need to put in there?
thanks for your help!
Change the the vfat lines to:

Code:
/dev/hdb6            /mnt/leftbrain       vfat       auto,umask=000                  0 0
/dev/hdb5            /mnt/rightbrain      vfat       auto,umask=000                  0 0
/dev/sda6            /mnt/thepineal       vfat       auto,umask=000                  0 0
Then remount them all as root.
That might do it.
Also, is the sda6 thingy a flash drive? Auto means the device will be mounted at boottime. If it's a removable device you might wanna make it a noauto.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing FAT32 on SATA disk AgentX Solaris / OpenSolaris 6 10-22-2005 04:11 PM
Can't change permissions for FAT32-HD ghanalinux Linux - Hardware 2 06-20-2005 12:10 AM
Can't change permissions for FAT32-HD ghanalinux Linux - Hardware 1 06-17-2005 12:05 PM
Mounting a FAT32 hard disk alex_zcb Linux - Hardware 17 12-22-2004 06:55 PM
Can't see my first disk (fat32) c0c0deuz Linux - Newbie 1 09-15-2001 02:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration