LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   file permission denied, install postfix (https://www.linuxquestions.org/questions/linux-newbie-8/file-permission-denied-install-postfix-317022/)

aw_wolfe 04-25-2005 03:05 PM

file permission denied, install postfix
 
Frustrated newbie trying to install a BASIC mailserver. Trying to use postfix.

Compiled source.
Configured (I think)

When check the configuration using.....

'postfix check'

I get an error 'postfix: fatal: /etc/postfix/postfix-script: Permission denied
'

I've tried to change that directory permission using various chmod commands like

chmod 777 /etc/postfix/postfix-script

but still get the same error of permission denied when I 'postfix check'

Not sure what or why this is happening.

Thanks for any help,

Tony

acid_kewpie 04-25-2005 03:37 PM

odd. does the interpreter exist on your system? check the first line of the file, normally /bin/sh which should exist... also show us "ls -l /etc/postfix" please.

aw_wolfe 04-25-2005 04:05 PM

ls -l
 
drwxrwxrwx 2 root root 4096 Apr 25 11:28 postfix-script

aw_wolfe 04-25-2005 04:06 PM

sorry
 
Sorry, for being an idiot, but not sure what you mean by the interpreter and checking the file (which file? what interpreter ?)

acid_kewpie 04-25-2005 04:28 PM

ok well.. "postfix_script" is clearly a directory.... see the "d" at the start there... no wonder it won't run!

aw_wolfe 04-25-2005 04:59 PM

yep THANKS. Not sure why it got setup that way.

Will have to track down what went wrong during the install.

Tony

ajc 07-12-2011 11:38 AM

Disable SElinux
 
This error can occur if you have SElinux enabled on your system. Disable SElinux if it is active.

Peverel 07-13-2011 08:27 AM

I just entered "postfix check" in a terminal and was told "postfix" is in sbin and requires superuser privileges. Maybe you need sudo. You would certainly need that to change permissions on a folder in /etc, which you should not do under any circumstances.


All times are GMT -5. The time now is 05:31 AM.