-   Linux - Newbie (
-   -   file and print sharing (

gwc 06-02-2005 08:21 PM

file and print sharing
I have recently set a box with Fedora Core 2 on it. I then used the up2date tool to update to Core 3. The problem that I am having is trying to share files and my printer on this box with my other two computers running Win XP. From the linux box I can see and browse the boxes running XP but I can see the linux box using the XP boxes. I have tried to figure out how to configure samba without much success. I have spent two days searching and reading posts and instructions.
I also tried to download and install the latest version of samba to see if that would make a difference. So I downloaded samba-3.0.14a-1.i386.rpm, samba-client-3.0.14a-1.i386.rpm, and samba-common-3.0.14a-1.i386.rpm. The problem that I am having now is that when I try to install samba-3.0.14a-1.i386.rpm it tells me that it needs and can not find samba-common-3.0.14a-1.i386.rpm. When I try to install samba-common-3.0.14a-1.i386.rpm it tells me that I already have a newer version installed.
Is there anything on the net where it gives good detailed instructions on how to setup and work with file and print sharing in fedora core 3. I have gone and read many of the different items posted on the net and none of them work.


Lleb_KCir 06-02-2005 09:13 PM

follow the samba basic HOWTO to get things setup nice and easy so windows can see it.

MarvinTPA 06-03-2005 01:17 PM

I don't know if this will help much, but I was having similar problems while running Debian (Woody) linux. It seems that initially, everything was fine, then the next day it didn't work. I no longer remeber exactly what happened, but I do remember (this is the part where I try to be helpfull) that installing SWAT was very helpfull for browsing the SAMBA configurations. SWAT is an HTML interface for SAMBA. It sort of gives it a GUI frontend that I, as a beginner found very helpful for troubleshooting.

It was very easy to use and setup, so don't be shy.


awallac1 06-03-2005 02:59 PM

I had similar problems on a Redhat samba server/win 2k/xp clients network - until I disabled the Linux firewall. Everything worked fine then - give it a try and if it works you've then "narrowed" it down to iptables! Can't get to the linux box at the moment but if I hear back from you I'll dig out the rules I applied.


All times are GMT -5. The time now is 04:42 AM.